Graphics and Media Lab CSL: Main Page

Graphics and Media Lab CSL Documentation

1.0.0

Introduction

Graphics & Media Lab Common Source Library is a C++ library that contains a set of classes frequently used in graphics research and development.

General description

The library contains several packages, separated by particular functionality. The following sections describe them.

Base

This package contains the most general classes and utilities:

  • definitions like ASSERT(), VERIFY() and NULL
  • gml::String type definition (derived from std::string)
  • smart pointer facility (gml::Ref, gml::SmartObject
  • object-orienter callback facility (gml::Callback)

Math

Math package contains the most general math utilities: vectors, matrices, etc.

  • vectors: 2D, 3D, 4D (gml::TVector2, gml::TVector3, gml::TVector4)
  • matrices: 2x2, 3x3, 4x4 (gml::TMatrix2x2, gml::TMatrix3x3, gml::TMatrix4x4)
  • quaternions (gml::TQuaternion)
  • bounding boxes (2D, 3D) and bounding spheres (gml::BBox2, gml::BBox2, gml::BSphere3)

The library was designed independent on particular compiler, though currently we assume Win32 platform. It uses neigher MFC nor VCL or any other popular API. At the same time there is preprocessor switches that allow integration of GML data types with MFC/VCL data types.

The library uses STL and assumes STL usage by the programmer (though it is not a necessary condition)

Color

Color package defines gml::TColor3 and gml::TColor4 clases that represent color values.

Files

Files package defines some common utilities to work with filesystem:

  • gml::File provides an object-oriented way to read & write to text and finary files (FILE* wrapper)
  • gml::PathString to parse strings containing file & path names
  • gml::FileFinder used to enumerate files directories
  • CIniFile provides facility for loading & saving of INI-files

Images

This is the most complete package so far. It defines several classes to work with different kinds of images, apply filters, etc.

  • gml::Image is a base class, it has several descendant, like gml::SimpleImage, gml::IntelImage, gml::GDIImage
  • filters can be applied to any image independent of its type Many filters have been implemented: blurring, color conversion, resizing, etc
  • Images can loaded/saved in multiple formats using either internal interface or external library FreeImage.

Net

Net package defines single class gml::Socket, which is a simple wrapper over standart sockets functionality.

Utils3D

This package have some classes, useful for developing 3D graphics application independent on different APIs like OpenGL or DirectX.

  • gml::Camera and gml::Viewport classes
  • gml::Browser class is a helper for navigation through a 3D scene
  • gml::FrameCounter allow to calculate average frame rates (FPS)
  • also several utility functions available.

UtilsGL

UtilsGL contains some useful utilities for OpenGL programming:

  • OpenGL extentions handling (taken from NVidia SDK)
  • OGL Win32 context management (gml::GLRC)

GML Common Source Library is contastantly evolving, so all the packages are updated frequently.

Installing and Usage

  • Unpack the archive
  • Link with necessary packages (depends on functionalities you are going to use). Note: all the packages depend on Base and on Math
  • The header <CSL/base/gmlcommon.h> must be included before any other includes of GML files. It usually worth to include this file into precompiled headers list (stdafx.h for MSVC)
Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlbbox2.h File Reference

gmlbbox2.h File Reference

A class for 2D boundary box (BBox2) definition. More...

#include "gmlvector2.h"
#include <limits>

Namespaces

namespace gml

Detailed Description

A class for 2D boundary box (BBox2) definition.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlbbox3.h File Reference

gmlbbox3.h File Reference

A class for 2D boundary box (BBox3) definition. More...

#include "gmlvector3.h"
#include <limits>

Namespaces

namespace gml

Detailed Description

A class for 2D boundary box (BBox3) definition.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlbrowser.h File Reference

gmlbrowser.h File Reference

A class for 3d virtual camera. More...

#include "gmlviewport.h"
#include "../math/gmlvector2.h"
#include "../math/gmlbbox3.h"

Namespaces

namespace gml

Detailed Description

A class for 3d virtual camera.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlbsphere3.h File Reference

gmlbsphere3.h File Reference

defines template class BSphere33<T> More...

#include "gmlmath.h"
#include "gmlbbox3.h"

Namespaces

namespace gml

Detailed Description

defines template class BSphere33<T>

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlcallback.h File Reference

gmlcallback.h File Reference

Definitions of callback helpers. More...

#include "gmlfunctioncallback.h"
#include "gmlmethodcallback.h"

Namespaces

namespace gml

Detailed Description

Definitions of callback helpers.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlcamera.h File Reference

gmlcamera.h File Reference

A class for 3d virtual camera. More...

#include "../math/gmlmatrix4.h"

Namespaces

namespace gml

Detailed Description

A class for 3d virtual camera.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlcommon.h File Reference

gmlcommon.h File Reference

General routines like ASSERT etc. More...

#include <assert.h>

Namespaces

namespace | gml

Defines

#define | ASSERT(expr)
custom assertion (DEBUG mode only)

#define | VERIFY(f) ((void)(f))
#define | NULL 0

Typedefs

typedef unsigned char | BYTE
typedef unsigned short | WORD
typedef unsigned long | DWORD

Detailed Description

General routines like ASSERT etc.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlcommongl.h File Reference

gmlcommongl.h File Reference

OpenGL helpers. More...

Namespaces

namespace | gml

Defines

#define | CHECK_GL ASSERT(glGetError() == GL_NO_ERROR)

Detailed Description

OpenGL helpers.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlframecounter.h File Reference

gmlframecounter.h File Reference

Simple frame rate (FPS) counter. More...

Namespaces

namespace gml

Detailed Description

Simple frame rate (FPS) counter.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlglrc.h File Reference

gmlglrc.h File Reference

Class for operations with GL Win32 context. More...

Namespaces

namespace gml

Detailed Description

Class for operations with GL Win32 context.

Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlmath.h File Reference

gmlmath.h File Reference

Common mathematic utility routines, gml::Math. More...

#include <math.h>

Namespaces

namespace | gml

Defines

#define | PI 3.1415926535897

Detailed Description

Common mathematic utility routines, gml::Math.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlmatrix2.h File Reference

gmlmatrix2.h File Reference

Definition of TMatrix2x2 template class and utility routines. More...

#include "gmlvector2.h"

Namespaces

namespace gml

Detailed Description

Definition of TMatrix2x2 template class and utility routines.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlmatrix3.h File Reference

gmlmatrix3.h File Reference

Definition of TMatrix3x3 template class and utility routines. More...

#include "gmlvector3.h"
#include "gmlvector2.h"

Namespaces

namespace gml

Detailed Description

Definition of TMatrix3x3 template class and utility routines.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlmatrix4.h File Reference

gmlmatrix4.h File Reference

Definition of TMatrix4x4 template class and utility routines. More...

#include "gmlvector3.h"
#include "gmlvector4.h"

Namespaces

namespace gml

Detailed Description

Definition of TMatrix4x4 template class and utility routines.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlmesh.h File Reference

gmlmesh.h File Reference

Definition of gml::Mesh class. More...

#include "../base/gmlsmartobject.h"
#include "../color/gmlcolor.h"
#include "../math/gmlvector2.h"
#include "../math/gmlvector3.h"
#include <vector>

Namespaces

namespace gml

Detailed Description

Definition of gml::Mesh class.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlpathstring.h File Reference

gmlpathstring.h File Reference

defines gml::PathString More...

#include "../base/gmlcommon.h"
#include "../base/gmlstring.h"
#include <list>

Namespaces

namespace | gml
namespace | std

Detailed Description

defines gml::PathString

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlquat.h File Reference

gmlquat.h File Reference

Definition of TQuaternion template class. More...

#include "gmlmatrix4.h"

Namespaces

namespace gml

Detailed Description

Definition of TQuaternion template class.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlref.h File Reference

gmlref.h File Reference

Definitions of smart reference. More...

Namespaces

namespace gml

Detailed Description

Definitions of smart reference.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlsmartobject.h File Reference

gmlsmartobject.h File Reference

Definitions of smart object (which supports smart references). More...

Namespaces

namespace gml

Detailed Description

Definitions of smart object (which supports smart references).

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlsocket.h File Reference

gmlsocket.h File Reference

Windows sockets handling (Win32 API). More...

#include <string>

Namespaces

namespace gml

Detailed Description

Windows sockets handling (Win32 API).

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlstring.h File Reference

gmlstring.h File Reference

defines gml::String More...

#include <string>
#include <afxwin.h>

Namespaces

namespace gml

Detailed Description

defines gml::String

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlutils3d.h File Reference

gmlutils3d.h File Reference

3d projections etc (utilities) More...

#include "gmlviewport.h"
#include "../math/gmlbbox3.h"

Namespaces

namespace gml

Detailed Description

3d projections etc (utilities)

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlutilsgl.h File Reference

gmlutilsgl.h File Reference

A set of OGL utitility functions. More...

#include "../math/gmlbbox3.h"
#include "../color/gmlcolor.h"

Namespaces

namespace gml

Detailed Description

A set of OGL utitility functions.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlvector2.h File Reference

gmlvector2.h File Reference

defines template gml::TVector2, gml::Math2 and typedefs with utility functions More...

#include "gmlmath.h"
#include "gmlvector3.h"
#include "../base/gmlcommon.h"
#include <ipl.h>
#include <cv.h>
#include <afxwin.h>
#include <windows.hpp>

Namespaces

namespace gml

Detailed Description

defines template gml::TVector2, gml::Math2 and typedefs with utility functions

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlvector3.h File Reference

gmlvector3.h File Reference

defines template gml::TVector3, gml::Math3 and typedefs with utility functions More...

#include "gmlmath.h"
#include <afxwin.h>
#include <ipl.h>
#include <cv.h>
#include <windows.hpp>

Namespaces

namespace gml

Detailed Description

defines template gml::TVector3, gml::Math3 and typedefs with utility functions

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlvector4.h File Reference

gmlvector4.h File Reference

defines template gml::TVector4, gml::Math3 and typedefs with utility functions More...

#include "gmlvector3.h"

Namespaces

namespace gml

Detailed Description

defines template gml::TVector4, gml::Math3 and typedefs with utility functions

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: gmlviewport.h File Reference

gmlviewport.h File Reference

A class for 3d viewport. More...

#include "gmlcamera.h"
#include "../math/gmlvector3.h"

Namespaces

namespace gml

Detailed Description

A class for 3d viewport.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateBBox2 class Reference

BBox2 Class Template Reference
[Math2]

A template class for 2D boundary box. More...

#include <gmlbbox2.h>

List of all members.

Public Member Functions

Constructors
BBox2 ()
no initialization

BBox2 (const TVector2< T > &point)
from point

BBox2 (const TVector2< T > &point1, const TVector2< T > &point2)
from two points

Comparison operators and methods
bool | NotEmpty () const
Test for validity.

bool | IsDot () const
If the box is actually a dot.

bool | Includes (const TVector2< T > &point) const
Test for point inclusion.

bool | Includes (const BBox2< T > &box) const
Test for box inclusion.

bool | Intersects (const BBox2< T > &box) const
Test for intersection.

Miscellanious methods
void | Include (const TVector2< T > &point)
Expand the box to include the given point.

void | Include (const TVector2< T > *points, int npoints)
Expand the box to include the given points.

void | Include (const BBox2< T > &box)
Expand the box to include the given box.

void | Include (const BBox2< T > *bboxes, int nbboxes)
Expand the box to include the given boxes.

void | Intersect (const BBox2< T > &box)
Intersect with given box.

void | SetRect (const T &in_Left, const T &in_Top, const T &in_Right, const T &in_Bottom)
Set box sizes.

void | ExpandBy (const T &in_Value)
Adjust size by given value (give < 0 to deflate).

void | ExpandBy (const T &in_HValue, const T &in_VValue)
Adjust sizes by given value (give < 0 to deflate).

void | Translate (const TVector2< T > &vct)
Translate the box to given vector.

BBox2< T > | Translated (const TVector2< T > &vct) const
Returns box translated by vct.

TVector2< T > | Diag () const
Return diagonal.

TVector2< T > | Center () const
Return Center of this box.

double | Volume () const
Return value of the volume.

double | Width () const
Return value of width.

double | Height () const
Return value of height.

BBox2 (const tagRECT &p)
BBox2< T > & | operator= (const tagRECT &p)
operator tagRECT ()
operator CvRect ()

Public Attributes

TVector2< T > | vmin
Minimal boundary.

TVector2< T > | vmax
Maximal boundary.

Detailed Description

template<class T>
class gml::BBox2< T >

A template class for 2D boundary box.

The documentation for this class was generated from the following file:
  • gmlbbox2.h
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateBBox3 class Reference

BBox3 Class Template Reference
[Math3]

A template class for 2D boundary box. More...

#include <gmlbbox3.h>

List of all members.

Public Member Functions

Constructors
BBox3 ()
no initialization

BBox3 (const TVector3< T > &point)
from point

BBox3 (const TVector3< T > &point1, const TVector3< T > &point2)
from two points

Comparison operators and methods
bool | NotEmpty () const
Test for validity.

bool | IsDot () const
If the box is actually a dot.

bool | Includes (const TVector3< T > &point) const
Test for point inclusion.

bool | Includes (const BBox3< T > &box) const
Test for box inclusion.

bool | Intersects (const BBox3< T > &box) const
Test for intersection.

Miscellanious methods
void | Include (const TVector3< T > &point)
Expand the box to include the given point.

void | Include (const TVector3< T > *points, int npoints)
Expand the box to include the given points.

void | Include (const BBox3< T > &box)
Expand the box to include the given box.

void | Include (const BBox3< T > *bboxes, int nbboxes)
Expand the box to include the given boxes.

void | Intersect (const BBox3< T > &box)
Intersect with given box.

void | ExpandBy (const T &in_Value)
Adjust size by given value (give < 0 to deflate).

void | ExpandBy (const TVector3< T > &expand_vec)
Adjust sizes by given value (give < 0 to deflate).

void | Translate (const TVector3< T > &vct)
Translate the box to given vector.

BBox3< T > | Translated (const TVector3< T > &vct) const
Returns box translated by vct.

TVector3< T > | Diag () const
Return diagonal.

TVector3< T > | Center () const
Return Center of this box.

double | Volume () const
Return value of the volume.

Public Attributes

TVector3< T > | vmin
Minimal boundary.

TVector3< T > | vmax
Maximal boundary.

Detailed Description

template<class T>
class gml::BBox3< T >

A template class for 2D boundary box.

The documentation for this class was generated from the following file:
  • gmlbbox3.h
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Browser class Reference

Browser Class Reference
[Utils3D]

3D navigation helper class More...

#include <gmlbrowser.h>

List of all members.

Public Types

enum | NAV_MODE { NAV_TRACKBALL, NAV_WALK }

Public Member Functions

Browser (Viewport &viewport)
void | SetNavigationMode (NAV_MODE nav_mode)
ModeBrowser * | GetModeBrowser ()
void | SetDomain (const BBox3f &scene_size, bool update_position=true)
BBox3f | GetDomain () const
void | MouseButton (const Vector2i &pos, int button, bool pressed)
void | MouseMotion (const Vector2i &pos, int button)
void | MousePassiveMotion (const Vector2i &pos)
void | MouseWheel (const Vector2i &pos, int delta)
bool | KeyDown (int key, int options)
bool | KeyUp (int key, int options)

Detailed Description

3D navigation helper class

The documentation for this class was generated from the following files:
  • gmlbrowser.h
  • gmlbrowser.cpp
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateBSphere3 class Reference

BSphere3 Class Template Reference
[Math3]

Template class for 3D bounding sphere. More...

#include <gmlbsphere3.h>

List of all members.

Miscellanious methods

void | Include (const TVector3< T > &point)
Expand the sphere to include given point.

void | Include (const BSphere3 &bsphere)
Expand the sphere to include given sphere.

T | radius
Radius of the sphere.

TVector3< T > | center
Center point.

Public Member Functions

Constructors
BSphere3 ()
default constructor

BSphere3 (const TVector3< T > &center0, const double radius0=0)
initialize class members by defined values

BSphere3 (const BBox3< T > &bbox)
construct sphere from given bounding box

Detailed Description

template<class T>
class gml::BSphere3< T >

Template class for 3D bounding sphere.

Parameters:
T - template type of TVector elements
Warning:
Use it with some SIGNED integral type, or a real type

The documentation for this class was generated from the following file:
  • gmlbsphere3.h
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Callback class Reference

Callback Class Reference
[Base]

Base class for callback with no arguments and no return value. More...

#include <gmlcallback.h>

Inheritance diagram for Callback:

List of all members.

Public Member Functions

virtual void | Call ()=0
void | Call () const
Callback method.

Detailed Description

Base class for callback with no arguments and no return value.

Member Function Documentation

void Call ( ) const [inline]

Callback method.

This method will be called for the callback with the appropriate arguments and must be defined by a derived class.

The documentation for this class was generated from the following file:
  • gmlcallback.h
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Camera class Reference

Camera Class Reference
[Utils3D]

Class representing 3d virtual camera. More...

#include <gmlcamera.h>

List of all members.

Public Member Functions

void | SetViewAngle (float view_angle)
set camera view angle (angle should be between 0 and 180 degrees)

float | GetViewAngle () const
return camera view angle

void | SetDistanceToTarget (float target_distance)
set distance from camera to target

float | GetDistanceToTarget () const
return distance from camera to target

const Matrix4x4d & | GetTransform () const
set view transformation

void | SetTransform (const Matrix4x4d &view_transform)
return view transformation

Vector3d | GetViewVector () const
get view vector of camera (normalized)

Vector3d | GetUpVector () const
get up vector of camera (normalized)

Vector3d | GetRightVector () const
get up vector of camera (normalized)

Vector3d | GetObserver () const
void | SetObserver (const Vector3d &obs)
Matrix4x4d | GetRotation () const
void | SetRotation (const Matrix4x4d &rot)

Protected Attributes

Matrix4x4d m_view_transform
OGL ready viewing transform (global -> eye).

Matrix4x4d m_inv_view_transform
inverse view transform (eye -> global)

float | m_view_angle
view angle (degrees)

float | m_target_distance
distance to target

Detailed Description

Class representing 3d virtual camera.

The documentation for this class was generated from the following file:
  • gmlcamera.h
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: CIniFile class Reference

CIniFile Class Reference
[Files]

Handling of INI-files. More...

#include <gmlinifile.h>

List of all members.

Public Member Functions

bool | IsSuchKeyInFile (const char *key)
bool | IsSuchNameInThisKey (const char *key, const char *name)
CIniFile ()
Default constructor.

CIniFile (const char *inipath)
Constructor, can specify pathname here instead of using SetPath later.

virtual | ~CIniFile ()
Default destructor.

void | SetPath (const char *newpath)
Sets path of ini file to read and write from.

bool | ReadFile ()
Reads ini file specified using CIniFile::SetPath().

void | WriteFile ()
Writes data stored in class to ini file.

void | Reset ()
Deletes all stored ini data.

int | GetNumKeys ()
number of keys currently in the ini

int | GetNumValues (const char *keyname)
number of values stored for specified key

std::string | GetValue (const char *keyname, const char *valuename)
gets value of [keyname] valuename =

void | GetValue (const char *keyname, const char *valuename, char *out_pcBuf, int in_iMaxChar)
gets value of [keyname] valuename =

int | GetValueI (const char *keyname, const char *valuename)
gets value of [keyname] valuename =

double | GetValueF (const char *keyname, const char *valuename)
gets value of [keyname] valuename =

bool | SetValue (const char *key, const char *valuename, const char *value, bool create=1)
sets value of [keyname] valuename =.

bool | SetValueI (const char *key, const char *valuename, int value, bool create=1)
sets value of [keyname] valuename =.

bool | SetValueF (const char *key, const char *valuename, double value, bool create=1)
sets value of [keyname] valuename =.

bool | DeleteValue (const char *keyname, const char *valuename)
deletes specified value

bool | DeleteKey (const char *keyname)
deletes specified key and all values contained within

Public Attributes

std::string | error
will contain error info if one occurs ended up not using much, just in ReadFile and GetValue

Detailed Description

Handling of INI-files.

Member Function Documentation

bool ReadFile ( )

Reads ini file specified using CIniFile::SetPath().

Returns:
true if successful, false otherwise

std::string GetValue | ( | const char * | keyname,
 |  | const char * | valuename
 | ) |

gets value of [keyname] valuename =

Returns:
"", or 0 if key/value not found. Sets error member to show problem

void GetValue | ( | const char * | keyname,
 |  | const char * | valuename,
 |  | char * | out_pcBuf,
 |  | int | in_iMaxChar
 | ) |

gets value of [keyname] valuename =

Returns:
"", or 0 if key/value not found. Sets error member to show problem

int GetValueI | ( | const char * | keyname,
 |  | const char * | valuename
 | ) |

gets value of [keyname] valuename =

Returns:
"", or 0 if key/value not found. Sets error member to show problem

double GetValueF | ( | const char * | keyname,
 |  | const char * | valuename
 | ) |

gets value of [keyname] valuename =

Returns:
"", or 0 if key/value not found. Sets error member to show problem

bool SetValue | ( | const char * | key,
 |  | const char * | valuename,
 |  | const char * | value,
 |  | bool | create = 1
 | ) |

sets value of [keyname] valuename =.

specify the optional paramter as false (0) if you do not want it to create the key if it doesn't exist.

Returns:
true if data entered, false otherwise

bool SetValueI | ( | const char * | key,
 |  | const char * | valuename,
 |  | int | value,
 |  | bool | create = 1
 | ) |

sets value of [keyname] valuename =.

specify the optional paramter as false (0) if you do not want it to create the key if it doesn't exist.

Returns:
true if data entered, false otherwise

bool SetValueF | ( | const char * | key,
 |  | const char * | valuename,
 |  | double | value,
 |  | bool | create = 1
 | ) |

sets value of [keyname] valuename =.

specify the optional paramter as false (0) if you do not want it to create the key if it doesn't exist.

Returns:
true if data entered, false otherwise

bool DeleteValue | ( | const char * | keyname,
 |  | const char * | valuename
 | ) |

deletes specified value

Returns:
true if value existed and deleted, false otherwise

bool DeleteKey ( const char * keyname )

deletes specified key and all values contained within

Returns:
returns true if key existed and deleted, false otherwise

The documentation for this class was generated from the following files:
  • gmlinifile.h
  • gmlinifile.cpp
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: DIntelImage class Reference

DIntelImage Class Reference
[Images]

Intel libraries IplImage wrap class. More...

#include <IntelImage.h>

List of all members.

Public Member Functions

void | DeleteImages ()
Free image memory (called automatically).

bool | CheckImage (int width, int height, int in_iChannels)
Check if image matches the specified size and channels number.

IplImage * | GetImage ()
Get pointer to stored image.

int | width ()
Get width of the image.

int | height ()
Get height of the image.

int | step ()
Get image aligned width.

unsigned char * | GetLineFast (int in_iLine)
Get pointer to line.

unsigned char * | GetLineSafe (int in_iLine)
Get pointer to line.

Creation
DIntelImage ()
Default constructor.

void | CreateImage (int width, int height, int depth=IPL_DEPTH_8U, int nChannels=3)
Create an empty image with specified size, bit depth and channels number.

void | AttachImage (IplImage *in_pImage)
Attach IplImage. The image is replaced by in_pImage, memory management will be done by DIntelImage from now on.

void | CloneImage (IplImage *in_pImage)
Create a full copy of the in_pImage.

void | CopyOf (DIntelImage &in_Image, int desired_color=-1)
Create a copy of the given DIntelImage with possibility of color <-> grayscale transfer.

Relation to SimpleImage
gml::SimpleImage * | CopyToSimpleImage ()
Destruction
IplImage * | DetachImage ()
Detach IplImage. The detached IplImage should be destroyed by the programmer.

virtual | ~DIntelImage ()
Destructor.

Filework
bool | LoadImage (const char *in_sFileName)
Load image from file.

void | SaveImage (const char *in_sFileName)
Save image to file.

Image drawing (actually, painting) in MFC
void | DrawImage (CDC *in_pDC, CPoint in_vOrigin, float in_dRatio)
Paint image in MFC device context with specified offset and scale.

void | DrawImage (CDC *in_pDC, CPoint in_vOrigin, int in_iHeight=-1)
Paint image in MFC device context with specified offset and destination image height.

void | DrawImage (CDC *in_pDC, gml::BBox2i in_SrcBox, gml::BBox2i in_TrgBox)
Paint part of the image in MFC device context in specified window.

Image drawing (actually, painting) in Borland Object Window Library
void | DrawImage (Graphics::TBitmap *in_pTarget, TPoint in_vOrigin, float in_dRatio=1)
Paint image in Borland OWL TBitmap with specified offset and scale.

Protected Member Functions

Forbidden operations
DIntelImage (DIntelImage &)
Copy constructor (not implemented).

DIntelImage operator= (DIntelImage &)
Assignment operator (not implemented).

Protected Attributes

IplImage * | m_pImage
Pointer to stored IplImage.

Detailed Description

Intel libraries IplImage wrap class.

Member Function Documentation

void CopyOf | ( | DIntelImage & | in_Image,
 |  | int | desired_color = -1
 | ) |

Create a copy of the given DIntelImage with possibility of color <-> grayscale transfer.

Parameters:
in_Image | image to copy;
desired_color | contols the color properties of the resulting image (-1 - do not change color/grayscale properties, 0 - the image becomes grayscale, 1 - image becomes color).

bool LoadImage ( const char * in_sFileName )

Load image from file.

Load image from a specified filename. Returns true in case of success, false on error. Depends on the highgui.dll and (c)vlgrfmts.dll installed on your machine (both libraries are provided with Intel OpenCV), but usually jpeg, bmp, tiff, pxm are supported.

void SaveImage ( const char * in_sFileName )

Save image to file.

Save image to a specified filename. The image format is taken from the file extension (jpg, bmp, tif, pxm). Depends on the highgui.dll and (c)vlgrfmts.dll installed on your machine (both libraries are provided with Intel OpenCV), but usually jpeg, bmp, tiff, pxm are supported.

void DrawImage | ( | CDC * | in_pDC,
 |  | CPoint | in_vOrigin,
 |  | float | in_dRatio
 | ) |

Paint image in MFC device context with specified offset and scale.

Function is available only if GML_USE_MFC is defined at the time of compilation. The image is scaled to the given ratio and painted in the CDC with the specified offset

void DrawImage | ( | CDC * | in_pDC,
 |  | CPoint | in_vOrigin,
 |  | int | in_iHeight = -1
 | ) |

Paint image in MFC device context with specified offset and destination image height.

Function is available only if GML_USE_MFC is defined at the time of compilation. The image is scaled to fit the given height (aspect ratio is preserved) and painted in the CDC with the specified offset

void DrawImage | ( | CDC * | in_pDC,
 |  | gml::BBox2i | in_SrcBox,
 |  | gml::BBox2i | in_TrgBox
 | ) |

Paint part of the image in MFC device context in specified window.

Function is available only if GML_USE_MFC is defined at the time of compilation. The image is scaled to fit the given window (aspect ratio is preserved)

void DrawImage | ( | Graphics::TBitmap * | in_pTarget,
 |  | TPoint | in_vOrigin,
 |  | float | in_dRatio = 1
 | ) |

Paint image in Borland OWL TBitmap with specified offset and scale.

Function is available only if GML_USE_OWL is defined at the time of compilation. The image is scaled to the given ratio and painted in the TBitmap with the specified offset

The documentation for this class was generated from the following files:
  • IntelImage.h
  • IntelImage.cpp
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: DrawSurface class Reference

DrawSurface Class Reference

Generic image class. More...

#include <gmldrawsurface.h>

Inheritance diagram for DrawSurface:

SmartObject GDISurface IntelSurface List of all members.

Public Member Functions

DrawSurface ()
Constructor..

virtual | ~DrawSurface ()
Empty destructor.

virtual void | DrawLine (int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | DrawLine (gml::Vector2i in_vStart, gml::Vector2i in_vEnd, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | FrameRect (int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | FrameRect (gml::Vector2i in_vMin, gml::Vector2i in_vMax, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | Circle (int in_iX0, int in_iY0, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | Circle (gml::Vector2i in_vCenter, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | PolyLine (gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))=0
virtual void | PolyGon (gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))=0

Detailed Description

Generic image class.

Some functionality should be defined in children

The documentation for this class was generated from the following file:
  • gmldrawsurface.h
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: File class Reference

File Class Reference
[Files]

A class for working with files (a wrapped to FILE *). More...

#include <gmlfile.h>

List of all members.

Methods

bool | Open (const char *mode)
Opening of file according to mode. The list of allowed modes:.

bool | Opened () const
True if file was previously opened.

bool | Close ()
Close the file.

bool | ReadStr (String &out_buff, int len_buff, bool *out_nl=NULL)
bool | ReadStr (char *out_buff, int len_buff, bool *out_nl=NULL)
bool | ReadStr (String &out_buff)
void | Read (BYTE *out_buff, int len_buff, int &out_size)
void | WriteStr (const String &str)
void | WriteStr (const char *out_buff,...)
void | Write (const BYTE *buff, int size)
void | Flush ()
bool | Remove ()
bool | Rename (const PathString &new_file_name)
bool | IsError ()
PathString | PathName () const
int | Printf (const char *format,...)
bool | Seek (long offset)
bool | SeekCur (long offset)
bool | SeekEnd (long offset)
long | FilePos () const
Gets current file offset.

long | FileSize () const
Returns the size of the file in bytes.

bool | Copy (const PathString &name_from, const PathString &name_to)
enum | { MODE_TEXT, MODE_BINARY }
enum | { MODE_READ, MODE_WRITE, MODE_READ_WRITE }
FILE * | fd
int | mode_tb
int | mode_rw

Public Member Functions

Constructors
File (const PathString &full_pathname)
Sets a full path to the file only.

File (const File &file)
Copy constructor.

~File ()
Destructor. File will be closed if it was opened.

Protected Types

Detailed Description

A class for working with files (a wrapped to FILE *).

Constructor & Destructor Documentation

File ( const File & file )

Copy constructor.

File may not be opened. Debug version asserts if this condition is violated.

Member Function Documentation

bool Open ( const char * mode )

Opening of file according to mode. The list of allowed modes:.

Parameters:
mode - i/o mode of the file to open
  • "r" - open for reading only; the file must exist.
  • "w" - create a new file or open an existing file for writing.
  • "a" - open for writing at the end-of-file or create for writing if the file does not exist.
  • "r+" - open an existing file for reading and writing.
  • "w+" - open an empty file for reading and writing.
  • "a+" - open for reading and appending; create a file if it does not exist.
Note:
Files are open in text mode as a default. Character 'b' may be appended to the above modes to open file in binary mode ('b' may also precede '+' sign). Path to file must be specified. Debug version asserts if this condition is violated.

bool Close ( )

Close the file.

Returns:
  • true (if there were no problems when working with the file and the file was closed successfully).
  • false (either I/O error while working with file or closing error).
Note:
File must be opened. Debug version asserts if this condition is violated

The documentation for this class was generated from the following files:
  • gmlfile.h
  • gmlfile.cpp
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FileFinder class Reference

FileFinder Class Reference
[Files]

#include <gmlfilefinder.h>

List of all members.

Public Member Functions

bool | FindFiles (const char *filefilter="*", const gml::PathString &="", int recursionlevel=-1)
gml::PathString | GetStartDir ()
std::vector< gml::PathString > & | GetCompleteFileList ()

Protected Member Functions

FileFinder (const FileFinder &right)
const FileFinder & | operator= (const FileFinder &right)

Detailed Description

A class which enumerate all the files and directories under specified start directory
Todo:
: add directory structure handling

Member Function Documentation

bool FindFiles | ( | const char * | filefilter = "*",
 |  | const gml::PathString & | = "",
 |  | int | recursionlevel = -1
 | ) |

search the startdir for files with a specified filename or extension filter. startdir == NULL => from the current directory recursion level == -1 => all sub-levels

The documentation for this class was generated from the following file:
  • gmlfilefinder.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterGrayscale class Reference

FilterGrayscale Class Reference
[ImageFilters]

Creates a grayscale version of a color bitmap. More...

#include <gmlfiltergrayscale.h>

Inheritance diagram for FilterGrayscale:

ImageFilter List of all members.

Public Types

enum METHOD {
M_R, M_G, M_B, M_AVERAGE,
M_EYE
}
method to convert from RGB to LUM: take RED, GREEN, BLUE, or simple average color, or use "human eye" formula

Public Member Functions

virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

void | SetMethod (METHOD m)

Detailed Description

Creates a grayscale version of a color bitmap.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlfiltergrayscale.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterLum2RGB class Reference

FilterLum2RGB Class Reference
[ImageFilters]

Creates a Lum2RGB version of a color bitmap. More...

#include <gmlfilterlum2rgb.h>

Inheritance diagram for FilterLum2RGB:

ImageFilter List of all members.

Public Member Functions

virtual void Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

Detailed Description

Creates a Lum2RGB version of a color bitmap.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlfilterlum2rgb.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterMedianBlur class Reference

FilterMedianBlur Class Reference
[ImageFilters]

Creates a MedianBlur version of a color bitmap. More...

#include <gmlfiltermedian.h>

Inheritance diagram for FilterMedianBlur:

ImageFilter List of all members.

Public Member Functions

virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

virtual void | SetRadius (int r)

Detailed Description

Creates a MedianBlur version of a color bitmap.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlfiltermedian.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterRepres class Reference

FilterRepres Class Reference
[ImageFilters]

Transferres between different representations. More...

#include <gmlfilterrepres.h>

Inheritance diagram for FilterRepres:

ImageFilter List of all members.

Public Member Functions

FilterRepres (Image::REPRES in_Repres=Image::R_BYTE, double in_dCoeff=1, bool in_bClipTypeBounds=true)
void | SetParam (Image::REPRES in_Repres=Image::R_BYTE, double in_dCoeff=1, bool in_bClipTypeBounds=true)
virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

Detailed Description

Transferres between different representations.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlfilterrepres.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterResize class Reference

FilterResize Class Reference
[ImageFilters]

Creates a MedianBlur version of a color bitmap. More...

#include <gmlfilterresize.h>

Inheritance diagram for FilterResize:

ImageFilter List of all members.

Public Types

enum | RESIZE_TYPE { FASTEST = 1, BILINEAR }

Public Member Functions

FilterResize (int in_iDstWdt, int in_iDstHgt, RESIZE_TYPE in_Type)
virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

virtual void | SetResizeParam (int in_iDstWdt, int in_iDstHgt, RESIZE_TYPE in_Type)

Detailed Description

Creates a MedianBlur version of a color bitmap.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlfilterresize.h
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterRGB2BGR class Reference

FilterRGB2BGR Class Reference
[ImageFilters]

Creates a Lum2RGB version of a color bitmap. More...

#include <gmlfilterrgb2bgr.h>

Inheritance diagram for FilterRGB2BGR:

ImageFilter List of all members.

Public Member Functions

virtual void ApplyInPlace (Image *pBmp) const
In-Place Apply.

Detailed Description

Creates a Lum2RGB version of a color bitmap.

Member Function Documentation

virtual void ApplyInPlace ( Image * pBmp ) const [virtual]

In-Place Apply.

Applies the filter to pBmp. The base-class version copies the bitmap after calling Apply (pBmp, pTempBmp).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlfilterrgb2bgr.h
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FilterRGB2RGBA class Reference

FilterRGB2RGBA Class Reference
[ImageFilters]

Creates a grayscale version of a color bitmap. More...

#include <gmlfilterrgb2rgba.h>

Inheritance diagram for FilterRGB2RGBA:

ImageFilter List of all members.

Public Member Functions

FilterRGB2RGBA (const gml::Color3ub &in_Color=gml::Color3ub(255, 255, 255))
virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

void | SetTransparentColor (const gml::Color3ub &in_Color)

Detailed Description

Creates a grayscale version of a color bitmap.

Member Function Documentation

void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following files:
  • gmlfilterrgb2rgba.h
  • gmlfilterrgb2rgba.cpp
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FrameCounter class Reference

FrameCounter Class Reference
[Utils3D]

Simple frame rate (FPS) counter. More...

#include <gmlframecounter.h>

List of all members.

Public Member Functions

FrameCounter ()
constructor

~FrameCounter ()
destructor

void | SetUpdateSpeed (double ms)
Set counted update speed in milliseconds.

double | GetUpdateSpeed () const
Return counter update speed.

void | SetMinimumFrameCount (int count)
Set minimum number of frames needed to calculate FPS.

double | GetMinimumFrameCount () const
Return counter update speed.

void | Reset ()
Signal that animation cycle is started.

void | FrameStarted ()
Signal that current frame is to be drawn.

void | FrameFinished ()
Signal that current frame is finished.

bool | Updated () const
Tells whether FPS has been updated.

double | GetFrameCount () const
Return the framecount (frames per second).

double | GetMeanFrameTime () const
Return the mean frame time (msec).

Detailed Description

Simple frame rate (FPS) counter.

Member Function Documentation

void SetMinimumFrameCount ( int count ) [inline]

Set minimum number of frames needed to calculate FPS.

FPS will be made and Updated() flag will be set only if time since latest update > update speed and number of drawn frames (calls to FrameFinished()) > minimum number of frames

void Reset ( )

Signal that animation cycle is started.

Probably should be called before first frame

void FrameStarted ( )

Signal that current frame is to be drawn.

Should be called before each scene display

void FrameFinished ( )

Signal that current frame is finished.

Should be called after each scene display

bool Updated ( ) const

Tells whether FPS has been updated.

Check this after call to FrameFinished. Flag cleared after next call to FrameFinished

The documentation for this class was generated from the following files:
  • gmlframecounter.h
  • gmlframecounter.cpp
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: FRImageLoader class Reference

FRImageLoader Class Reference
[Images]

Image loader based on FreeImage third-party library. More...

#include <gmlfrimageloader.h>

Inheritance diagram for FRImageLoader:

ImageLoader List of all members.

Public Member Functions

virtual bool | EnumerateLoadableFormats (void(*f)(IMAGE_FORMAT f))
virtual bool | EnumerateSaveableFormats (void(*f)(IMAGE_FORMAT f))
virtual IMAGE_FORMAT | CheckBitMapFile (const std::string &path)
virtual bool | LoadBitMap (const std::string &path, Image &out_bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int flags=0)
virtual bool | SaveBitMap (const std::string &path, const Image &bitmap, IMAGE_FORMAT format, int flags=0)

Detailed Description

Image loader based on FreeImage third-party library.

The documentation for this class was generated from the following files:
  • gmlfrimageloader.h
  • gmlfrimageloader.cpp
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: GDIImage class Reference

GDIImage Class Reference
[Images]

Manipulates uncompressed device- and platform-independent bitmaps. More...

#include <gmlgdiimage.h>

Inheritance diagram for GDIImage:

Image SmartObject List of all members.

Public Member Functions

GDIImage ()
Creates an empty bitmap.

virtual | ~GDIImage ()
Destroys the bitmap.

GDIImage (const Image &Orig)
Copy constructor.

GDIImage (const GDIImage &Orig)
Copy constructor.

GDIImage & | operator= (const Image &Orig)
Assignment operator.

GDIImage & | operator= (const GDIImage &Orig)
long | GetMemUsed ()
Returns the amount of memory used by the object.

long | GetBytesPerLine () const
Returns number of bytes used per line.

const BYTE * | GetRawData () const
BYTE * | GetRawData ()
Access to raw data array. Warning!!! Dangerous function! Use with care.

void | PaintImage (HDC in_hDC, DWORD dwRop=SRCCOPY)
Paint image.

void | PaintImage (HDC in_hDC, POINT in_ptDstOrg, DWORD dwRop=SRCCOPY)
Paint image at a specified offset.

void | PaintImage (HDC in_hDC, POINT in_ptDstOrg, SIZE in_DstSize, DWORD dwRop=SRCCOPY)
Fit image to specified rectangle.

void | PaintImageRect (HDC in_hDC, POINT in_ptDstOrg, RECT in_SrcRect, SIZE in_DstSize, DWORD dwRop=SRCCOPY)
Fit image fragment to specified rectangle.

virtual gml::DrawSurface * | GetDrawSurface ()
Draw surface.

virtual bool | FastResizeImage (double in_dScale, gml::GDIImage &out_ResImg)
Fast GDI image resize.

Protected Member Functions

virtual void | ConstructorInitLocals ()
virtual bool | InternalCreate (int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)
virtual void | FreeMembers ()
Delete memory allocated by member variables.

virtual void | InitLineArray ()
Initialize internal table of line addresses.

virtual void | InternalChangeOrientation (ORIENT new_orient)
virtual void | InternalPaint (HDC in_hDC, int in_iDstOrgX, int in_iDstOrgY, int in_iDstWdt, int in_iDstHgt, int in_iSrcOrgX, int in_iSrcOrgY, int in_iSrcWdt, int in_iSrcHgt, DWORD dwRop)

Static Protected Member Functions

long | GetBytesPerLine (int width, FORMAT f, REPRES r)

Protected Attributes

BYTE * | m_pBits
Pointer to the bits.

HDC | m_hDC
Internal device context.

BITMAPINFO | m_BMInfo
Bitmap info structure.

RGBQUAD | m_pPalette [255]
Palette for 1-channel images.

RGBQUAD * | m_pColorTable
HBITMAP | m_hBMP
BITMAP handel.

HGDIOBJ | m_hOldHandle
Neded for cleanup.

int | m_iBytesPerLine
Bytes per line in the created DIB.

Friends

class | GDISurface

Detailed Description

Manipulates uncompressed device- and platform-independent bitmaps.

The data is stored sequentially without padding in the bitmap. The class implements exactly the interface defined by gml::Image without additions.

Member Function Documentation

virtual bool InternalCreate | ( | int | Width,
 |  | int | Height,
 |  | FORMAT | format,
 |  | REPRES | repres,
 |  | ORIENT | orient = O_BOTTOMLEFT
 | ) | [protected, virtual]

Create a new bitmap with uninitialized bits. (Assume no memory is allocated yet.)

Implements Image.

virtual void InternalChangeOrientation ( ORIENT new_orient ) [protected, virtual]

Change image orientation to given state

Warning:
you should set m_orient variable after actual operation

Implements Image.

The documentation for this class was generated from the following file:
  • gmlgdiimage.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: GDISurface class Reference

GDISurface Class Reference
[Images]

Generic image class. More...

#include <gmlgdisurface.h>

Inheritance diagram for GDISurface:

DrawSurface SmartObject List of all members.

Public Member Functions

GDISurface (gml::GDIImage *in_pImage)
Constructor..

virtual | ~GDISurface ()
Empty destructor.

void | DrawLine (int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))
void | DrawLine (gml::Vector2i in_vStart, gml::Vector2i in_vEnd, Color3ub in_Color=Color3ub(255, 255, 255))
void | FrameRect (int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))
void | FrameRect (gml::Vector2i in_vMin, gml::Vector2i in_vMax, Color3ub in_Color=Color3ub(255, 255, 255))
void | Circle (int in_iX0, int in_iY0, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))
void | Circle (gml::Vector2i in_vCenter, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))
void | PolyLine (gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))
void | PolyGon (gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))

Protected Member Functions

DWORD | GetColor (gml::Color3ub in_Color)

Protected Attributes

GDIImage * | m_pImage

Detailed Description

Generic image class.

Some functionality should be defined in children

The documentation for this class was generated from the following file:
  • gmlgdisurface.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: GLRC class Reference

GLRC Class Reference
[UtilsGL, UtilsGL]

OpenGL context handling
Attention:
Include windows.h before using this file! Usage:
  GLRC glrc;
  // inside window creation
  glrc.Create(wnd);
  // before rendering into window
  glrc.MakeCurrent();
  // ...
  // display in the screen (in case of double buffering)
  glrc.SwapBuffers();
  // ..
  // delete gl context (may be avoided, because called in destructor anyway)
  glrc.Destroy();
.
More...

#include <gmlglrc.h>

List of all members.

Public Member Functions

Class Construction/Destruction
GLRC (HWND wnd)
Constructor from Window Handle (HWND).

GLRC (HDC hdc)
Constructor form Device Context Handle(HDC).

void | Destroy ()
Destory GL context (also called in destructor).

virtual | ~GLRC ()
Context members
virtual bool | Create ()
Member, needed to create context. Call this before use of OpenGL.

bool | IsCurrent () const
Member, that return true if opengl is ready to draw.

bool | MakeCurrent ()
Prepare current context for use.

void | SwapBuffers ()
Call this insted of opengl's swap buffer, at the end of the drawing.

Protected Attributes

bool | m_created
true inside Create() / Destory() pair

HWND | m_wnd
Window handle.

HDC | m_dc
Device Context handle.

HGLRC | m_glrc
OpenGL Context handle.

Detailed Description

OpenGL context handling
Attention:
Include windows.h before using this file! Usage:
  GLRC glrc;
  // inside window creation
  glrc.Create(wnd);
  // before rendering into window
  glrc.MakeCurrent();
  // ...
  // display in the screen (in case of double buffering)
  glrc.SwapBuffers();
  // ..
  // delete gl context (may be avoided, because called in destructor anyway)
  glrc.Destroy();
.

Todo:
Add possibility to select pixel format (double/single buffer, stencil, etc)

Constructor & Destructor Documentation

virtual ~GLRC ( ) [virtual]

Virtual Destructor

The documentation for this class was generated from the following file:
  • gmlglrc.h
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Image class Reference

Image Class Reference
[Images]

Generic image class. More...

#include <gmlimage.h>

Inheritance diagram for Image:

SmartObject GDIImage IntelImage SimpleImage List of all members.

Public Types

enum | FORMAT { F_L, F_RGB, F_RGBA, F_BGR }
enum REPRES {
R_BYTE, R_WORD, R_DWORD, R_FLOAT,
R_DOUBLE
}
enum | ORIENT { O_TOPLEFT, O_BOTTOMLEFT }
line order in the image More...

Public Member Functions

Image ()
virtual | ~Image ()
Empty destructor.

Image (Image &in_Image)
Image & | operator= (Image const &Orig)
bool const | operator== (Image const &Other)
virtual void | Create (int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)
void | CreateCopy (const Image &rSrImage)
Creates a copy of rSrImage, converting color depth if nessesary.

bool | CreateFromDIB (struct tagBITMAPINFO *in_pDIB, BYTE *in_pcData=NULL)
Creates from a bitmap header.

void | CreateFilteredCopy (const Image &rSrImage, const ImageFilter &rFilter)
void | CreateComposition (const std::vector< Image * > &src, const ImageComposer &comp)
bool | Created () const
void | Clear ()
void | ApplyFilter (const ImageFilter &filter)
Applies a filter to the bitmap.

void | Decompose (const ImageDecomposer &decomposer, std::vector< Image * > &out_res)
Applies a decompositor to the bitmap.

bool | ChangeOrientation (ORIENT new_orient)
Change orientation of the image to new one.

bool | ChangeFormat (FORMAT new_format)
Change image format.

bool | ChangeRepres (REPRES new_repres)
Change image pixel representetion.

int | GetWidth () const
int | GetHeight () const
FORMAT | GetFormat () const
REPRES | GetRepres () const
ORIENT | GetOrient () const
virtual long | GetMemUsed ()=0
int | GetElemSize () const
virtual long | GetBytesPerLine () const =0
Returns number of bytes used per line.

BYTE ** | GetLineArray () const
Returns pointer to an array containing the starting addresses of the bitmap lines.

virtual void | Lock (bool bReadable, bool bWriteable)
virtual void | Unlock ()
Unlocks the Bitmap surface.

bool | IsLocked () const
bool | AlmostEqual (const Image &Bmp, int epsilon) const
void | PaintImage (CDC *in_pDC, CPoint dst_org, CSize dst_size, DWORD dwRop=SRCCOPY)
virtual gml::DrawSurface * | GetDrawSurface ()=0

Static Public Member Functions

int | Format2Channels (FORMAT f)
int | Repres2Size (REPRES r)
int | ElemSize (FORMAT f, REPRES r)

Protected Member Functions

virtual bool | InternalCreate (int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)=0
virtual void | FreeMembers ()=0
Delete memory allocated by member variables.

virtual void | InitLineArray ()=0
Initialize internal table of line addresses.

void | InternalCopy (const Image &rSrImage)
void | InitLocals (int width, int height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)
Can be called from internalCreate() to initialize object state.

virtual void | InternalChangeOrientation (ORIENT new_orient)=0

Protected Attributes

int | m_width
int | m_height
bool | m_created
FORMAT | m_format
REPRES | m_repres
ORIENT m_orient
current orientation order

BYTE ** | m_line_array
Table of the starting addresses of the lines.

int | m_lock_count
Number of times the bitmap was locked.

Detailed Description

Generic image class.

Some functionality should be defined in children

Member Enumeration Documentation

enum ORIENT

line order in the image

Enumeration values:
O_TOPLEFT | lines are going left-right, top-bottom
O_BOTTOMLEFT | lines are left-right, bottom-top

Constructor & Destructor Documentation

Image ( )

Empty constructor. Constructors in derived classes create a small empty bitmap to ensure that the object is always in a sane state.

Member Function Documentation

bool const operator== ( Image const & Other )

Test for equality. This function actually tests every pixel, so it's not fast. It's meant mainly for use in asserts and such.

virtual void Create | ( | int | Width,
 |  | int | Height,
 |  | FORMAT | format,
 |  | REPRES | repres,
 |  | ORIENT | orient = O_BOTTOMLEFT
 | ) | [virtual]

Creates a new empty bitmap. Memory for the bits is allocated but not initialized. Previous contents of the bitmap object are discarded

bool CreateFromDIB | ( | struct tagBITMAPINFO * | in_pDIB,
 |  | BYTE * | in_pcData = NULL
 | ) |

Creates from a bitmap header.

Parameters:
in_pDIB | Óêàçàòåëü íà BITMAPINFO (õðàíèëèùå ñâîéñòâ DIB'à)
in_pcData | Óêàçàòåëü íà ïèêñåëüíûå bitmap äàííûå. Åñëè óñòàíîâëåí â NULL - ñ÷èòàåòñÿ, ÷òî äàííûå ðàñïîëàãàþòñÿ ñðàçó çà BITMAPINFO

void CreateFilteredCopy | ( | const Image & | rSrImage,
 |  | const ImageFilter & | rFilter
 | ) |

Creates a copy of rSrImage, applying rFilter on the way. Depending on the filter called, this is often much faster than CreateCopy() followed by ApplyFilter().

bool ChangeOrientation ( ORIENT new_orient )

Change orientation of the image to new one.

Note:
if it already set, nothing will changed

bool ChangeFormat ( FORMAT new_format )

Change image format.

Note:
if it already set, nothing will changed, currently implemented only for RGB <-> BGR change

bool ChangeRepres ( REPRES new_repres )

Change image pixel representetion.

Note:
if it already set, nothing will changed

virtual void Lock | ( | bool | bReadable,
 |  | bool | bWriteable
 | ) | [virtual]

Locks bitmap. GetLineArray() and other direct-access methods should only be called if the bitmap is locked. Lock and Unlock keep a lock count.

virtual bool InternalCreate | ( | int | Width,
 |  | int | Height,
 |  | FORMAT | format,
 |  | REPRES | repres,
 |  | ORIENT | orient = O_BOTTOMLEFT
 | ) | [protected, pure virtual]

Create a new bitmap with uninitialized bits. (Assume no memory is allocated yet.)

Implemented in GDIImage, IntelImage, and SimpleImage.

void InternalCopy ( const Image & rSrImage ) [protected]

Creates a new Image as copy of rSrImage. Assumes there is no memory allocated yet.

virtual void InternalChangeOrientation ( ORIENT new_orient ) [protected, pure virtual]

Change image orientation to given state

Warning:
you should set m_orient variable after actual operation

Implemented in GDIImage, IntelImage, and SimpleImage.

Member Data Documentation

int m_lock_count [protected]

Number of times the bitmap was locked.

Default is m_LockCount always >= 1, so access to bits is always possible.

The documentation for this class was generated from the following file:
  • gmlimage.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: ImageComposer class Reference

ImageComposer Class Reference
[ImageFilters]

Produce single image from several reference images. More...

#include <gmlimagecomposer.h>

List of all members.

Public Member Functions

virtual void Apply (const std::vector< Image * > &source, Image *pBmpDest) const

Detailed Description

Produce single image from several reference images.

Member Function Documentation

virtual void Apply | ( | const std::vector< Image * > & | source,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Composer to *(pBmpSource[0]).. *(pBmpSource[n_images - 1]) and stores the result in pBmpDest.

The documentation for this class was generated from the following file:
  • gmlimagecomposer.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: ImageDecomposer class Reference

ImageDecomposer Class Reference
[ImageFilters]

Decompose an image into several destination images. More...

#include <gmlimagecomposer.h>

List of all members.

Public Member Functions

virtual void Apply (Image *pBmpSource, std::vector< Image * > &out_dest) const
Decompase pBmpSource to several images which are stored in out_dest.

Detailed Description

Decompose an image into several destination images.

The documentation for this class was generated from the following file:
  • gmlimagecomposer.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: ImageFilter class Reference

ImageFilter Class Reference
[ImageFilters]

Interface for generic image modifier. More...

#include <gmlimagefilter.h>

Inheritance diagram for ImageFilter:

FilterGrayscale FilterLum2RGB FilterMedianBlur FilterRepres FilterResize FilterRGB2BGR FilterRGB2RGBA ReflectFilter SetRectFilter List of all members.

Public Member Functions

virtual void | ApplyInPlace (Image *pBmp) const
In-Place Apply.

virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

Detailed Description

Interface for generic image modifier.

Member Function Documentation

virtual void ApplyInPlace ( Image * pBmp ) const [virtual]

In-Place Apply.

Applies the filter to pBmp. The base-class version copies the bitmap after calling Apply (pBmp, pTempBmp).

Reimplemented in FilterRGB2BGR.

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented in FilterGrayscale, FilterLum2RGB, FilterMedianBlur, FilterRepres, FilterResize, FilterRGB2RGBA, ReflectFilter, and SetRectFilter.

The documentation for this class was generated from the following file:
  • gmlimagefilter.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: ImageLoader class Reference

ImageLoader Class Reference
[Images]

Loading and saving bitmaps to files (base class). More...

#include <gmlimageloader.h>

Inheritance diagram for ImageLoader:

FRImageLoader SimpleImageLoader List of all members.

Public Types

enum IMAGE_FORMAT {
FORMAT_BMP, FORMAT_ICO, FORMAT_JPEG, FORMAT_PNG,
FORMAT_PGM, FORMAT_PGMRAW, FORMAT_PPM, FORMAT_TIFF,
FORMAT_TARGA, FORMAT_UNKNOWN
}

Public Member Functions

virtual bool | EnumerateLoadableFormats (void(*f)(IMAGE_FORMAT f))=0
virtual bool | EnumerateSaveableFormats (void(*f)(IMAGE_FORMAT f))=0
virtual IMAGE_FORMAT | CheckBitMapFile (const std::string &path)=0
virtual bool | LoadBitMap (const std::string &path, Image &out_bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int flags=0)=0
virtual bool | SaveBitMap (const std::string &path, const Image &bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int in_iQuality=100, int flags=0)=0

Static Public Member Functions

std::string | GetFormatExtension (IMAGE_FORMAT format)
Get file extension for particular image file format.

Detailed Description

Loading and saving bitmaps to files (base class).

Member Function Documentation

std::string GetFormatExtension ( IMAGE_FORMAT format ) [static]

Get file extension for particular image file format.

Parameters:
Image format
Returns:
A string containing required extension

The documentation for this class was generated from the following file:
  • gmlimageloader.h
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: IntelImage class Reference

IntelImage Class Reference
[Images]

Manipulates uncompressed device- and platform-independent bitmaps. More...

#include <gmlintelimage.h>

Inheritance diagram for IntelImage:

Image SmartObject List of all members.

Public Member Functions

IntelImage ()
Creates an empty bitmap.

virtual | ~IntelImage ()
Destroys the bitmap.

IntelImage (const Image &Orig)
Copy constructor.

IntelImage (const IntelImage &Orig)
Copy constructor.

IntelImage & | operator= (const Image &Orig)
Assignment operator.

IntelImage & | operator= (const IntelImage &Orig)
long | GetMemUsed ()
Returns the amount of memory used by the object.

long | GetBytesPerLine () const
Returns number of bytes used per line.

const BYTE * | GetRawData () const
BYTE * | GetRawData ()
Access to raw data array. Dangerous function! Use with care.

_IplImage * | GetImage ()
Access to intel image structure! Use with care.

virtual gml::DrawSurface * | GetDrawSurface ()
Draw surface.

Protected Member Functions

virtual void | ConstructorInitLocals ()
virtual bool | InternalCreate (int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)
virtual void | FreeMembers ()
Delete memory allocated by member variables.

virtual void | InitLineArray ()
Initialize internal table of line addresses.

virtual void | InternalChangeOrientation (ORIENT new_orient)

Protected Attributes

_IplImage * | m_pImage
Pointer to stored IplImage.

BYTE * | m_pBits
int | m_iBytesPerLine

Detailed Description

Manipulates uncompressed device- and platform-independent bitmaps.

The data is stored sequentially without padding in the bitmap. The class implements exactly the interface defined by gml::Image without additions.

Member Function Documentation

virtual bool InternalCreate | ( | int | Width,
 |  | int | Height,
 |  | FORMAT | format,
 |  | REPRES | repres,
 |  | ORIENT | orient = O_BOTTOMLEFT
 | ) | [protected, virtual]

Create a new bitmap with uninitialized bits. (Assume no memory is allocated yet.)

Implements Image.

virtual void InternalChangeOrientation ( ORIENT new_orient ) [protected, virtual]

Change image orientation to given state

Warning:
you should set m_orient variable after actual operation

Implements Image.

The documentation for this class was generated from the following file:
  • gmlintelimage.h
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: IntelSurface class Reference

IntelSurface Class Reference
[Images]

Generic image class. More...

#include <gmlintelsurface.h>

Inheritance diagram for IntelSurface:

DrawSurface SmartObject List of all members.

Public Member Functions

IntelSurface (gml::IntelImage *in_pImage)
Constructor..

virtual | ~IntelSurface ()
Empty destructor.

void | DrawLine (int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))
void | DrawLine (gml::Vector2i in_vStart, gml::Vector2i in_vEnd, Color3ub in_Color=Color3ub(255, 255, 255))
void | FrameRect (int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))
void | FrameRect (gml::Vector2i in_vMin, gml::Vector2i in_vMax, Color3ub in_Color=Color3ub(255, 255, 255))
void | Circle (int in_iX0, int in_iY0, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))
void | Circle (gml::Vector2i in_vCenter, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))
void | PolyLine (gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))
void | PolyGon (gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))

Protected Member Functions

int | GetColor (gml::Color3ub in_Color)

Protected Attributes

IntelImage * | m_pImage

Detailed Description

Generic image class.

Some functionality should be defined in children

The documentation for this class was generated from the following file:
  • gmlintelsurface.h
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateMath class Reference

Math Class Template Reference
[Math]

A template class for precision related staff. More...

#include <gmlmath.h>

Inheritance diagram for Math:

Math2 Math3 Math4 List of all members.

Static Public Member Functions

bool | AboutZero (const double v, const double tolerance)
Comparisons with given tolerance.

bool | AboutZero (const double v)
bool | NearZero (const double v)
bool | AboutEqual (const double v1, const double v2, const double tolerance)
bool | AboutEqual (const double v1, const double v2)
bool | NearEqual (const double v1, const double v2)
int | SignAbout (const double v, const double tolerance)
Determine sing of value with some tolerance around zero.

int | SignAbout (const double v)
int | SignNear (const double v)

Static Public Attributes

const double | TOLERANCE = 1.0E-05f
default tolerance (type dependent)

const double | MIN_VALUE = numeric_limits<float>::min()
Maximum values for float and double types (rounded down).

const double | MAX_VALUE = numeric_limits<float>::max()
Minimal positive values for float and double types (rounded up).

const double | EPSILON = numeric_limits<float>::epsilon()
minimum positive floating point number x such that 1.0 + x != 1.0

Detailed Description

template<class T>
class gml::Math< T >

A template class for precision related staff.

Parameters:
T is a real type like float, double
Note:
use typedefs MathD, MathF

The documentation for this class was generated from the following files:
  • gmlmath.h
  • gmlmath.cpp
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateMath2 class Reference

Math2 Class Template Reference
[Math2]

Comparison of 2D vectors with a tolerance. More...

#include <gmlvector2.h>

Inheritance diagram for Math2:

Math List of all members.

Static Public Member Functions

bool | AboutZero (const TVector2< T > &v, const double tolerance)
bool | AboutZero (const TVector2< T > &v)
bool | NearZero (const TVector2< T > &v)
bool | AboutEqual (const TVector2< T > &v1, const TVector2< T > &v2, const double tolerance)
bool | AboutEqual (const TVector2< T > &v1, const TVector2< T > &v2)
bool | NearEqual (const TVector2< T > &v1, const TVector2< T > &v2)

Detailed Description

template<class T>
class gml::Math2< T >

Comparison of 2D vectors with a tolerance.

Parameters:
T - some REAL type (float, double)

The documentation for this class was generated from the following file:
  • gmlvector2.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateMath3 class Reference

Math3 Class Template Reference
[Math3]

Comparison of 2D vectors with a tolerance. More...

#include <gmlvector3.h>

Inheritance diagram for Math3:

Math List of all members.

Static Public Member Functions

bool | AboutZero (const TVector3< T > &v, const double tolerance)
bool | AboutZero (const TVector3< T > &v)
bool | NearZero (const TVector3< T > &v)
bool | AboutEqual (const TVector3< T > &v1, const TVector3< T > &v2, const double tolerance)
bool | AboutEqual (const TVector3< T > &v1, const TVector3< T > &v2)
bool | NearEqual (const TVector3< T > &v1, const TVector3< T > &v2)

Detailed Description

template<class T>
class gml::Math3< T >

Comparison of 2D vectors with a tolerance.

Parameters:
T - some REAL type (float, double)

The documentation for this class was generated from the following file:
  • gmlvector3.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateMath4 class Reference

Math4 Class Template Reference
[Math4]

Comparison of 4D vectors with a tolerance. More...

#include <gmlvector4.h>

Inheritance diagram for Math4:

Math List of all members.

Static Public Member Functions

bool | AboutZero (const TVector4< T > &v, const double tolerance)
bool | AboutZero (const TVector4< T > &v)
bool | NearZero (const TVector4< T > &v)
bool | AboutEqual (const TVector4< T > &v1, const TVector4< T > &v2, const double tolerance)
bool | AboutEqual (const TVector4< T > &v1, const TVector4< T > &v2)
bool | NearEqual (const TVector4< T > &v1, const TVector4< T > &v2)

Detailed Description

template<class T>
class gml::Math4< T >

Comparison of 4D vectors with a tolerance.

Parameters:
T - some REAL type (float, double)

The documentation for this class was generated from the following file:
  • gmlvector4.h
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: PathString class Reference

PathString Class Reference
[Files]

Processing of the path to file. More...

#include <gmlpathstring.h>

Inheritance diagram for PathString:

String List of all members.

Public Member Functions

Constructors
PathString (const string &rhs)
PathString (const string &rhs, size_type pos, size_type n)
PathString (const char *s, size_type n)
PathString (const char *s)
PathString (size_type n, char c)
PathString (const_iterator first, const_iterator last)
PathString (const string &path, const string &filename, const string &extension=string())
Constructs an object from path+filename+extension.

Path handling
string | Path () const
Returns extracted path from full path to the file.

string | Filename () const
Returns full name of the file (with extension).

string | Basename () const
Returns base name of the file (without extension).

string | Extension () const
Returns extension of the file (dot is not included).

void | Split (string *path, string *filename, string *extension=NULL) const
Splits path name into path, base filename and extension.

bool | MakeFullPath (const PathString &relative_to=PathString())
File or directory handling
bool | IsFile () const
Check: 'this' string is the name of the real plain file.

bool | IsDir () const
Check: 'this' string is the name of the directory.

bool | CurDir ()
Get current working directory to 'this' pathname.

bool | ChDir () const
Change current working directory to 'this' pathname.

bool | MkDir () const
Create directory with name specified by 'this' pathname.

bool | RmDir () const
Remove directory with name specified by 'this' pathname.

bool | ExePath ()
Get full path to the current program.

bool | ListFileName (list< PathString > &filelist, PathString *mask) const

Static Public Attributes

const char | PATH_SEPARATOR = '\\'
char path separator for currents OS

const string | PATH_SEPARATOR_STR = string("\\")
string path separator for current OS

Protected Member Functions

bool | CheckMask (const PathString &mask) const
void | CorrectSeparators ()

Detailed Description

Processing of the path to file.

Constructor & Destructor Documentation

PathString | ( | const string & | path,
 |  | const string & | filename,
 |  | const string & | extension = string()
 | ) |

Constructs an object from path+filename+extension.

The path separator will be added if string path does not end by path separator. The dot will be added between filename and extension if extension does not begin by dot.

Note:
If parameter extension is absent then filename contains the full name of the file.

Member Function Documentation

string Path ( ) const

Returns extracted path from full path to the file.

Note:
In case if path cannot be extracted, an empty string will be returned.

string Filename ( ) const

Returns full name of the file (with extension).

Note:
If full name is not extracted, an empty string will be returned.

string Basename ( ) const

Returns base name of the file (without extension).

Note:
If base name is not extracted, an empty string will be returned.

string Extension ( ) const

Returns extension of the file (dot is not included).

Note:
If extension is not extracted, an empty string will be returned.

void Split | ( | string * | path,
 |  | string * | filename,
 |  | string * | extension = NULL
 | ) | const

Splits path name into path, base filename and extension.

Note:
If parameter extension is absent then filename will contain file name with extension.

bool MakeFullPath ( const PathString & relative_to = PathString() )

Expand current path to full path relative to 'relative_to' argument.

Warning:
relative_to must be a full path or NULL if to work with current directory

bool RmDir ( ) const

Remove directory with name specified by 'this' pathname.

Note:
Directory must be empty

bool ListFileName | ( | list< PathString > & | filelist,
 |  | PathString * | mask
 | ) | const

Non-obligatory parameter mask defines mask for the filtration.

The documentation for this class was generated from the following files:
  • gmlpathstring.h
  • gmlpathstring.cpp
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateRef class Reference

Ref Class Template Reference
[Base, Base]

Smart pointer class Smart pointers provide automatic memory management, so that programmer never cares on freeing memory. Smart pointers mechanism frees an object when there are no any references to it. Smart pointers should be used instead of standard C pointers:
  Object* obj; // standard pointer, should be deleted after use
  gml::Ref<Object> obj; // smart pointer frees memory when necessary
Attention:
Smart pointers works only with objects that support AddRef() and Release() operations. It is assumed that object keeps a reference count (a number of smapt pointers pointing to it). This reference count is incremented in AddRef() command and decremented in Release(). Also Release() performs check whether reference count is 0 and calls 'delete this'. GML provides special base class for this: gml::SmartObject. If you want to use smart pointers either derive your object from this class or provide own implementation of AddRef() and Release() methods. 1) initialization Smart pointers are initiliazed just like the standard pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);

Smart pointers must never be defined like this: gml::Rev<Object>* obj; !!! 2) use of smart pointers Smart pointers are dereferenced like normal pointers:

  gml::Ref<Object> obj =  new Object(1,2,3);
  obj->SomeMethod();
  (*obj).SomeMethod();
3) smart pointers as parameters Smart pointers are implicitly casted to normal pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);
  Object* obj1 =  obj;
This operation is dangerous unless used properly. You should use it like follows. Smart pointers may be passed to functions and returned from functions like normal pointers.
  ...
  Object* SomeMethod(Object* obj);
  ...
  gml::Ref<Object> obj =  new Object(1,2,3);
  gml::Ref<Object> obj1 = SomeMethod(obj);
The general rule is this: Use ONLY smart pointers when storing objects. Use normals pointers when passing smart pointers as parameters or return values So the following is forbidden:
  class SomeClass
    {
    private:
      Object* obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        } // at this point obj will be deleted, and m_obj will be undefined!!
    };
Correct use:
  class SomeClass
    {
    private:
      gml::Ref<Object> obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        }
    };
.
More...

#include <gmlref.h>

List of all members.

Public Member Functions

Ref (T *real_ptr=NULL)
Default contructor.

Ref (const Ref &rhs)
Copy constructor.

~Ref ()
Destructor.

Ref & | operator= (const Ref &rhs)
Overloaded operator =.

T * | operator-> () const
Overloaded operator.

T & | operator * () const
Overloaded operator.

int | IsSet () const
Whether this pointer is not null.

operator T * () const
Implicit conversion to C pointer.

void | Set (T *real_ptr)
Forced assignment of C pointer to this reference
Attention:
Danger function, use it carefully.

void | Clear ()
Cleans this reference.

Related Functions

(Note that these are not member functions.)

Ref< newT > & | ConvRef (const Ref< oldT > &old_ref)
Casting & convertion of smart references.

Detailed Description

template<class T>
class gml::Ref< T >

Smart pointer class Smart pointers provide automatic memory management, so that programmer never cares on freeing memory. Smart pointers mechanism frees an object when there are no any references to it. Smart pointers should be used instead of standard C pointers:
  Object* obj; // standard pointer, should be deleted after use
  gml::Ref<Object> obj; // smart pointer frees memory when necessary
Attention:
Smart pointers works only with objects that support AddRef() and Release() operations. It is assumed that object keeps a reference count (a number of smapt pointers pointing to it). This reference count is incremented in AddRef() command and decremented in Release(). Also Release() performs check whether reference count is 0 and calls 'delete this'. GML provides special base class for this: gml::SmartObject. If you want to use smart pointers either derive your object from this class or provide own implementation of AddRef() and Release() methods. 1) initialization Smart pointers are initiliazed just like the standard pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);

Smart pointers must never be defined like this: gml::Rev<Object>* obj; !!! 2) use of smart pointers Smart pointers are dereferenced like normal pointers:

  gml::Ref<Object> obj =  new Object(1,2,3);
  obj->SomeMethod();
  (*obj).SomeMethod();
3) smart pointers as parameters Smart pointers are implicitly casted to normal pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);
  Object* obj1 =  obj;
This operation is dangerous unless used properly. You should use it like follows. Smart pointers may be passed to functions and returned from functions like normal pointers.
  ...
  Object* SomeMethod(Object* obj);
  ...
  gml::Ref<Object> obj =  new Object(1,2,3);
  gml::Ref<Object> obj1 = SomeMethod(obj);
The general rule is this: Use ONLY smart pointers when storing objects. Use normals pointers when passing smart pointers as parameters or return values So the following is forbidden:
  class SomeClass
    {
    private:
      Object* obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        } // at this point obj will be deleted, and m_obj will be undefined!!
    };
Correct use:
  class SomeClass
    {
    private:
      gml::Ref<Object> obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        }
    };
.

Note:
Nevertheless, nobody restricts you from passing smart pointers as parameters and return values. Simple pointers are just have more natural interface. 4) casting of smart pointers Since smart pointers are implicitly casted to C pointers, casting rules are the same as for C pointers. The only issue appears when use need to cast from one smart pointer to another. In this case you need to use gml::ConvRef() operation:
  gml::Ref<BaseObject> b;
  gml::Ref<DerivedObject> c;
  c = b; // this may not work in compilers which nor support template casting methods
  c = gml::ConvRef<DerivedObject>(b); // OK
Attention:
This simple example not working (!) :
  Object* CreateObject()
    {
    gml::Ref<Object> obj = new Object;
    return obj; // at this point reference count of obj is 1, so the obj is deleted
                // before returned from the function!
    }
Correct use is one of the following:
  Object* CreateObject()
    {
    Object* obj = new Object;
    return obj;
    }

  gml::Ref<Object> CreateObject()
    {
    gml::Ref<Object> obj = new Object;
    return obj;
    }
Warning:
It is forbidden to assign arrays created by new[] to smart pointers
  gml::Ref<Object> obj = new Object[10]; // result is undefined!!!!!

All smart object should be create by new operator! The following is strictly forbidden :

  Object obj;
  gml::Ref<Object> = &obj;

The documentation for this class was generated from the following file:
  • gmlref.h
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: ReflectFilter class Reference

ReflectFilter Class Reference
[ImageFilters]

Creates a grayscale version of a color bitmap. More...

#include <gmlreflectfilter.h>

Inheritance diagram for ReflectFilter:

ImageFilter List of all members.

Public Member Functions

ReflectFilter (bool in_bVert, bool in_bHor)
virtual void Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

Detailed Description

Creates a grayscale version of a color bitmap.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlreflectfilter.h
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: SetRectFilter class Reference

SetRectFilter Class Reference
[ImageFilters]

Creates a grayscale version of a color bitmap. More...

#include <gmlsetrectfilter.h>

Inheritance diagram for SetRectFilter:

ImageFilter List of all members.

Public Member Functions

SetRectFilter (double in_dValue)
SetRectFilter (double in_dValue, gml::Vector2i in_vMin, gml::Vector2i in_vMax)
SetRectFilter (double in_dValue, int in_iMinX, int in_iMinY, int in_iMaxX, int in_iMaxY)
void | SetParam (double in_dValue)
void | SetParam (double in_dValue, gml::Vector2i in_vMin, gml::Vector2i in_vMax)
void | SetParam (double in_dValue, int in_iMinX, int in_iMinY, int in_iMaxX, int in_iMaxY)
virtual void | Apply (const Image *pBmpSource, Image *pBmpDest) const
Applies the Filter to pBmpSource and stores the result in pBmpDest.

Detailed Description

Creates a grayscale version of a color bitmap.

Member Function Documentation

virtual void Apply | ( | const Image * | pBmpSource,
 |  | Image * | pBmpDest
 | ) | const [virtual]

Applies the Filter to pBmpSource and stores the result in pBmpDest.

The base-class version copies the bitmap before calling ApplyInPlace (pBmpDest).

Reimplemented from ImageFilter.

The documentation for this class was generated from the following file:
  • gmlsetrectfilter.h
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: SimpleImage class Reference

SimpleImage Class Reference
[Images]

Manipulates uncompressed device- and platform-independent bitmaps. More...

#include <gmlsimpleimage.h>

Inheritance diagram for SimpleImage:

Image SmartObject List of all members.

Public Member Functions

SimpleImage ()
Creates an empty bitmap.

virtual | ~SimpleImage ()
Destroys the bitmap.

SimpleImage (const Image &Orig)
Copy constructor.

SimpleImage (const SimpleImage &Orig)
Copy constructor.

SimpleImage & | operator= (const Image &Orig)
Assignment operator.

SimpleImage & | operator= (const SimpleImage &Orig)
long | GetMemUsed ()
Returns the amount of memory used by the object.

long | GetBytesPerLine () const
Returns number of bytes used per line.

const BYTE * | GetRawData () const
BYTE * | GetRawData ()
Access to raw data array. Dangerous function! Use with care.

virtual int | GetRawDataSize () const
virtual gml::DrawSurface * | GetDrawSurface ()
Draw surface.

Static Public Member Functions

long | GetMemNeeded (int width, int height, FORMAT f, REPRES r)
Returns memory needed by a bitmap with the specified attributes.

long | GetBitsMemNeeded (int width, int height, FORMAT f, REPRES r)
Returns memory needed by bitmap bits.

Protected Member Functions

virtual void | ConstructorInitLocals ()
virtual bool | InternalCreate (int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)
virtual void | FreeMembers ()
Delete memory allocated by member variables.

virtual void | InitLineArray ()
Initialize internal table of line addresses.

virtual void | InternalChangeOrientation (ORIENT new_orient)

Protected Attributes

BYTE * | m_pBits
Pointer to the bits.

Detailed Description

Manipulates uncompressed device- and platform-independent bitmaps.

The data is stored sequentially without padding in the bitmap. The class implements exactly the interface defined by gml::Image without additions.

Member Function Documentation

virtual bool InternalCreate | ( | int | Width,
 |  | int | Height,
 |  | FORMAT | format,
 |  | REPRES | repres,
 |  | ORIENT | orient = O_BOTTOMLEFT
 | ) | [protected, virtual]

Create a new bitmap with uninitialized bits. (Assume no memory is allocated yet.)

Implements Image.

virtual void InternalChangeOrientation ( ORIENT new_orient ) [protected, virtual]

Change image orientation to given state

Warning:
you should set m_orient variable after actual operation

Implements Image.

The documentation for this class was generated from the following file:
  • gmlsimpleimage.h
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: SimpleImageLoader class Reference

SimpleImageLoader Class Reference
[Images]

Image loader based on FreeImage third-party library. More...

#include <gmlsimpleimageloader.h>

Inheritance diagram for SimpleImageLoader:

ImageLoader List of all members.

Public Member Functions

virtual bool | EnumerateLoadableFormats (void(*f)(IMAGE_FORMAT f))
virtual bool | EnumerateSaveableFormats (void(*f)(IMAGE_FORMAT f))
virtual IMAGE_FORMAT | CheckBitMapFile (const std::string &path)
virtual bool | LoadBitMap (const std::string &path, Image &out_bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int flags=0)
virtual bool | SaveBitMap (const std::string &path, const Image &bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int in_iQuality=100, int flags=0)
virtual void | GetExifMarker (std::vector< unsigned char > &out_pcData)
virtual void | SetExifMarker (std::vector< unsigned char > &in_pcData)

Detailed Description

Image loader based on FreeImage third-party library.

The documentation for this class was generated from the following files:
  • gmlsimpleimageloader.h
  • gmlbmp.cpp
  • gmlsimpleimageloader.cpp
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: SmartObject class Reference

SmartObject Class Reference
[Base]

Base class for objects with support for reference counting. More...

#include <gmlsmartobject.h>

Inheritance diagram for SmartObject:

DrawSurface Image GDISurface IntelSurface GDIImage IntelImage SimpleImage List of all members.

Public Member Functions

void | AddRef ()
Increment reference count.

void | Release ()
Decrement reference count.

virtual | ~SmartObject ()
Destructor is virtual.

Detailed Description

Base class for objects with support for reference counting.

See also:
gml::Ref

Member Function Documentation

void AddRef ( ) [inline]

Increment reference count.

Warning:
This function is used internally, you should never call it

void Release ( ) [inline]

Decrement reference count.

Warning:
This function is used internally, you should never call it

The documentation for this class was generated from the following file:
  • gmlsmartobject.h
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Socket class Reference

Socket Class Reference
[Net]

A wrapper for Win32 stream socket. More...

#include <gmlsocket.h>

List of all members.

Public Member Functions

bool | Create (int nSocketPort=0, const char *lpszSocketAddress=NULL)
bool | Bind (int nSocketPort, const char *lpszSocketAddress=NULL)
void | Close ()
bool | Connect (const char *lpszHostAddress, int nHostPort)
bool | Accept (gml::Socket &rConnectedSocket)
bool | Listen (int nConnectionBacklog=5)
int | Receive (void *lpBuf, int nBufLen, int nFlags=0)
int | Send (const void *lpBuf, int nBufLen, int nFlags=0)
bool | SendFile (const std::string &out_filename)
bool | ReceiveFile (const std::string in_filename)

Static Public Member Functions

bool | InitSockets ()
Initilize Win32 sockets (MUST be called before use of sockets).

Detailed Description

A wrapper for Win32 stream socket.

The documentation for this class was generated from the following files:
  • gmlsocket.h
  • gmlsocket.cpp
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: String class Reference

String Class Reference
[Base]

Standard string with some extensions. More...

#include <gmlstring.h>

Inheritance diagram for String:

PathString List of all members.

Public Member Functions

Standard constructors (the same as in std::string)
String ()
Empty string.

String (const string &rhs)
Copy constructor.

String (const string &rhs, size_type pos, size_type n)
Constructor from substring.

String (const char *s, size_type n)
From N characters of C string.

String (const char *s)
From C string.

String (size_type n, char c)
A sequence of n chars.

String (const_iterator first, const_iterator last)
two iterators point to a some string of list of chars

MFC, VCL - specific functions (use defines to enable them)
CString | AsCString () const
Conversion to MFC string.

Utility functions
int | AsInt () const
To integer.

double | AsDouble () const
To double.

void | Format (const char *format,...)
write a formatted string and a variable list of arguments to this object

void | FormatV (const char *format, va_list arglist)
write a formatted string and a variable list of arguments to this object

Detailed Description

Standard string with some extensions.

Note:
use it instead of std::string
Warning:
If you wish to make classes derived from String (or std::string) please be careful NOT no provide own destructor. This is so because the base class std::string has no virtual destructor and in case of addressing via pointer to the base class destructor of derived class will not be called!

Constructor & Destructor Documentation

String | ( | const string & | rhs,
 |  | size_type | pos,
 |  | size_type | n
 | ) | [inline]

Constructor from substring.

Parameters:
rhs | is a source string
pos | is a start position
n | is number of characters

Member Function Documentation

CString AsCString ( ) const [inline]

Conversion to MFC string.

Note:
works only if GML_USE_MFC is defined

int AsInt ( ) const [inline]

To integer.

Returns:
return 0 if the input cannot be converted to a value of that type

double AsDouble ( ) const [inline]

To double.

Returns:
return 0.0 if the input cannot be converted to a value of that type

The documentation for this class was generated from the following files:
  • gmlstring.h
  • gmlstring.cpp
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTColor3 class Reference

TColor3 Class Template Reference
[Color]

3 Color repsentation More...

#include <gmlcolor.h>

List of all members.

Public Member Functions

TColor3 ()
no initialization

TColor3 (T r0, T g0, T b0)
TColor3< T > & | operator *= (const double d)
TColor3< T > | operator * (const double d) const
TColor3< T > & | operator+= (const TColor3< T > &u)
TColor3< T > & | operator-= (const TColor3< T > &u)
TColor3< T > | operator+ (const TColor3< T > &u) const
TColor3< T > | operator- (const TColor3< T > &u) const
TColor3< T > & | operator/= (const double d)
TColor3< T > | operator/ (const double d) const
operator T * ()
Convert a TColor3 to array of (3) elements.

operator const T * () const
Convert a TColor3 to array of (3) elements.

Static Public Member Functions

const TColor3< T > & | Cast (const T *u)
Treat array of (3) elements as a TColor3.

TColor3< T > & | Cast (T *u)
Treat array of (3) elements as a TColor3.

Related Functions

(Note that these are not member functions.)

TColor3< T > | operator * (const double d, const TColor3< T > &u)
Multiplication of scalar d by TColor3 u.

Detailed Description

template<class T>
class gml::TColor3< T >

3 Color repsentation

The documentation for this class was generated from the following file:
  • gmlcolor.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTColor4 class Reference

TColor4 Class Template Reference
[Color]

4 Color repsentation More...

#include <gmlcolor.h>

List of all members.

Public Member Functions

TColor4 ()
no initialization

TColor4 (T r0, T g0, T b0, T w0=1)
TColor4< T > & | operator *= (const double d)
TColor4< T > | operator * (const double d) const
TColor4< T > & | operator+= (const TColor4< T > &u)
TColor4< T > & | operator-= (const TColor4< T > &u)
TColor4< T > | operator+ (const TColor4< T > &u) const
TColor4< T > | operator- (const TColor4< T > &u) const
TColor4< T > & | operator/= (const double d)
TColor4< T > | operator/ (const double d) const
operator T * ()
Convert a TColor4 to array of (4) elements.

operator const T * () const
Convert a TColor4 to array of (4) elements.

Static Public Member Functions

const TColor4< T > & | Cast (const T *u)
Treat array of (4) elements as a TColor4.

TColor4< T > & | Cast (T *u)
Treat array of (4) elements as a TColor4.

Related Functions

(Note that these are not member functions.)

TColor4< T > | operator * (const double d, const TColor4< T > &u)
Multiplication of scalar d by TColor4 u.

Detailed Description

template<class T>
class gml::TColor4< T >

4 Color repsentation

The documentation for this class was generated from the following file:
  • gmlcolor.h
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTMatrix2x2 class Reference

TMatrix2x2 Class Template Reference
[Math2x2]

Template class for 2x2 matrix. More...

#include <gmlmatrix2.h>

List of all members.

Public Member Functions

T | Det ()
TMatrix2x2< T > | MultVectStr (TVector2< T > &v1, TVector2< T > &v2)
Constructors
TMatrix2x2 ()
No initialization.

TMatrix2x2 (T r)
Initialization by diagonal element.

TMatrix2x2 (const T *m)
Initialization by array of T.

TMatrix2x2 (T a00, T a01, T a10, T a11)
Direct initialization by components (row order).

Access to values
T * | RawArray ()
Provide access to internal contents.

void | GetValue (T *mp) const
Copy this matrix mp array (! column-major order).

const T * | GetValue () const
Provide const access to the buffer.

void | SetValue (const T *mp)
Copy data from mp array.

void | SetValue (T r)
Initialization by a diagonal component.

T & | operator() (int row, int col)
access operator (e.g. m(1,0) = 20)

const T & | operator() (int row, int col) const
const access operator (e.g. a = m(1,0))

T & | Elem (int row, int col)
Return (row, col) element.

const T & | Elem (int row, int col) const
Return const (row, col) element.

Row and column access
void | SetRow (int r, const TVector2< T > &t)
Set row r of this matrix to vector t.

void | SetColumn (int c, const TVector2< T > &t)
Set column c of this matrix to vector t.

void | GetRow (int r, TVector2< T > &t) const
Set vector t equal to row r of this matrix.

TVector2< T > | GetRow (int r) const
Return row r.

void | GetColumn (int c, TVector2< T > &t) const
Set vector t equal to column c of this matrix.

TVector2< T > | GetColumn (int c) const
Return column c.

Matrix-2-Matrix operations
TMatrix2x2< T > & | MultRight (const TMatrix2x2< T > &b)
Multiplication to matrix b (right).

TMatrix2x2< T > & | MultLeft (const TMatrix2x2< T > &b)
Multiplication to matrix b (left).

TMatrix2x2< T > & | operator *= (const TMatrix2x2< T > &mat)
this *= mat

TMatrix2x2< T > & | operator+= (const TMatrix2x2< T > &mat)
this += mat

TMatrix2x2< T > | operator/ (const double d)
Matrix-2-Vector operations
void | MultMatrixVec (const TVector2< T > &src, TVector2< T > &dst) const
dst = M * src

void | MultMatrixVec (TVector2< T > &src_and_dst) const
src_and_dst = M * src_and_dst

void | MultVecMatrix (const TVector2< T > &src, TVector2< T > &dst) const
dst = src * M

void | MultVecMatrix (TVector2< T > &src_and_dst) const
src_and_dst = src_and_dst * M

Matrix-2-Scalar operations
TMatrix2x2< T > & | operator *= (const T &r)
Multiplication by scalar r (diagonal).

Miscellaneous
void | MakeIdentity ()
Make E-matrix from this one.

TMatrix2x2< T > | Inverse () const
Return an inverse matrix.

TMatrix2x2< T > | Transpose () const
Return transposed matrix.

Static Public Member Functions

const TMatrix2x2< T > & | Identity ()
Return predefined identity matrix.

Protected Attributes

T | m [4]

Friends

TMatrix2x2< T > | operator * (const TMatrix2x2< T > &m1, const TMatrix2x2< T > &m2)
Matrix multiplication (return m1 * m2).

bool | operator== (const TMatrix2x2< T > &m1, const TMatrix2x2< T > &m2)
Equality operator.

bool | operator!= (const TMatrix2x2< T > &m1, const TMatrix2x2< T > &m2)
Unequality operator.

Related Functions

(Note that these are not member functions.)

TMatrix2x2< T_TO > | Conv (const TMatrix2x2< T_FROM > &u)
Convert TMatrix2x2<T_FROM> to TMatrix2x2<T_TO>.

TMatrix2x2< float > | ConvF (const TMatrix2x2< T > &u)
Convert TMatrix2x2<T> to TMatrix2x2<float>.

TMatrix2x2< double > | ConvD (const TMatrix2x2< T > &u)
Convert TMatrix2x2<T> to TMatrix2x2<double>.

Detailed Description

template<class T>
class gml::TMatrix2x2< T >

Template class for 2x2 matrix.

Parameters:
T - template type of matrix elements
Warning:
Use it with some SIGNED integral type, or a real type Elements are stored in column-major order (OpenGL-style) E.g.:

    a0  a2
    a1  a3

Member Function Documentation

T* RawArray ( ) [inline]

Provide access to internal contents.

Warning:
Use with care, this function is dangerous!

The documentation for this class was generated from the following file:
  • gmlmatrix2.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTMatrix3x3 class Reference

TMatrix3x3 Class Template Reference
[Math3x3]

Template class for 3x3 matrix. More...

#include <gmlmatrix3.h>

List of all members.

Public Member Functions

T | Det ()
TMatrix3x3< T > | MultVectStr (TVector3< T > &v1, TVector3< T > &v2)
Constructors
TMatrix3x3 ()
No initialization.

TMatrix3x3 (T r)
Initialization by diagonal element.

TMatrix3x3 (const T *m)
Initialization by array of T.

TMatrix3x3 (T a00, T a01, T a02, T a10, T a11, T a12, T a20, T a21, T a22)
Direct initialization by components (row order).

Access to values
T * | RawArray ()
Provide access to internal contents.

void | GetValue (T *mp) const
Copy this matrix mp array (! column-major order).

const T * | GetValue () const
Provide const access to the buffer.

void | SetValue (const T *mp)
Copy data from mp array.

void | SetValue (T r)
Initialization by a diagonal component.

T & | operator() (int row, int col)
access operator (e.g. m(2,1) = 20)

const T & | operator() (int row, int col) const
const access operator (e.g. a = m(2,1))

T & | Elem (int row, int col)
Return (row, col) element.

const T & | Elem (int row, int col) const
Return const (row, col) element.

Row and column access
void | SetScale (T s)
Set scale components of this matrix to the same value s.

void | SetScale (const TVector3< T > &s)
Set scale components of this matrix to values from vector s.

void | SetTranslation (const TVector2< T > &t)
Set translation part of this matrix to values of vector t.

void | GetTranslation (TVector2< T > &t) const
Set vector t to translation part of this matrix.

TVector2< T > | GetTranslation () const
Return translation part of this matrix.

void | SetRotation (const TMatrix3x3< T > &mat)
Set rotation part of the matrix (a 2x2 upper left corner).

void | GetRotation (TMatrix3x3< T > &mat) const
Set mat to rotation part of this matrix.

TMatrix3x3< T > | GetRotation () const
Return rotation part of this matrix (a 2x2 upper left corner).

void | SetRow (int r, const TVector3< T > &t)
Set row r of this matrix to vector t.

void | SetColumn (int c, const TVector3< T > &t)
Set column c of this matrix to vector t.

void | GetRow (int r, TVector3< T > &t) const
Set vector t equal to row r of this matrix.

TVector3< T > | GetRow (int r) const
Return row r.

void | GetColumn (int c, TVector3< T > &t) const
Set vector t equal to column c of this matrix.

TVector3< T > | GetColumn (int c) const
Return column c.

Matrix-2-Matrix operations
TMatrix3x3< T > & | MultRight (const TMatrix3x3< T > &b)
Multiplication to matrix b (right).

TMatrix3x3< T > & | MultLeft (const TMatrix3x3< T > &b)
Multiplication to matrix b (left).

TMatrix3x3< T > & | operator *= (const TMatrix3x3< T > &mat)
this *= mat

TMatrix3x3< T > & | operator+= (const TMatrix3x3< T > &mat)
this += mat

TMatrix3x3< T > & | operator/= (const double d)
TMatrix3x3< T > | operator *= (const double d)
TMatrix3x3< T > | operator/ (const double d)
TMatrix3x3< T > | operator= (const TMatrix3x3< T > &mat)
Matrix-2-Vector operations
void | MultMatrixVec (const TVector2< T > &src, TVector2< T > &dst) const
dst = M * src

void | MultMatrixVec (TVector2< T > &src_and_dst) const
src_and_dst = M * src_and_dst

void | MultVecMatrix (const TVector2< T > &src, TVector2< T > &dst) const
dst = src * M

void | MultVecMatrix (TVector2< T > &src_and_dst) const
src_and_dst = src_and_dst * M

void | MultMatrixVec (const TVector3< T > &src, TVector3< T > &dst) const
dst = M * src

void | MultMatrixVec (TVector3< T > &src_and_dst) const
src_and_dst = M * src_and_dst

void | MultVecMatrix (const TVector3< T > &src, TVector3< T > &dst) const
dst = src * M

void | MultVecMatrix (TVector3< T > &src_and_dst) const
src_and_dst = src_and_dst * M

void | MultMatrixDir (const TVector3< T > &src, TVector3< T > &dst) const
dst = M * src (only rotation and scale part, no translation)

void | MultMatrixDir (TVector3< T > &src_and_dst) const
src_and_dst = M * src_and_dst (only rotation and scale part, no translation)

void | MultDirMatrix (const TVector2< T > &src, TVector2< T > &dst) const
dst = src * M (only rotation and scale part, no translation)

void | MultDirMatrix (TVector2< T > &src_and_dst) const
src_and_dst = src_and_dst * M (only rotation and scale part, no translation)

Miscellaneous
Multiplication by scalar r (diagonal)

void | MakeIdentity ()
Make E-matrix from this one.

TMatrix3x3< T > | Inverse () const
Return an inverse matrix.

TMatrix3x3< T > | Transpose () const
Return transposed matrix.

Static Public Member Functions

const TMatrix3x3< T > & | Identity ()
Return predefined identity matrix.

Protected Attributes

T | m [9]

Friends

TMatrix3x3< T > | operator * (const TMatrix3x3< T > &m1, const TMatrix3x3< T > &m2)
Matrix multiplication (return m1 * m2).

bool | operator== (const TMatrix3x3< T > &m1, const TMatrix3x3< T > &m2)
Equality operator.

bool | operator!= (const TMatrix3x3< T > &m1, const TMatrix3x3< T > &m2)
Unequality operator.

Related Functions

(Note that these are not member functions.)

TMatrix3x3< T_TO > | Conv (const TMatrix3x3< T_FROM > &u)
Convert TMatrix3x3<T_FROM> to TMatrix3x3<T_TO>.

TMatrix3x3< float > | ConvF (const TMatrix3x3< T > &u)
Convert TMatrix3x3<T> to TMatrix3x3<float>.

TMatrix3x3< double > | ConvD (const TMatrix3x3< T > &u)
Convert TMatrix3x3<T> to TMatrix3x3<double>.

Detailed Description

template<class T>
class gml::TMatrix3x3< T >

Template class for 3x3 matrix.

Parameters:
T - template type of matrix elements
Warning:
Use it with some SIGNED integral type, or a real type Elements are stored in column-major order (OpenGL-style) E.g.:

    a0  a3  a6
    a1  a4  a7
    a2  a5  a8

Member Function Documentation

T* RawArray ( ) [inline]

Provide access to internal contents.

Warning:
Use with care, this function is dangerous!

void SetTranslation ( const TVector2< T > & t ) [inline]

Set translation part of this matrix to values of vector t.

Translation part is the 3-th column, so it is valid for use with column-vectors V = M * V; V = (v1 v2 v3 v4)T

See also:
MultMatrixVec

The documentation for this class was generated from the following file:
  • gmlmatrix3.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTMatrix4x4 class Reference

TMatrix4x4 Class Template Reference
[Math4x4]

Template class for 4x4 matrix. More...

#include <gmlmatrix4.h>

List of all members.

Public Member Functions

Constructors
TMatrix4x4 ()
No initialization.

TMatrix4x4 (T r)
Initialization by diagonal element.

TMatrix4x4 (const T *m)
Initialization by array of T.

TMatrix4x4 (T a00, T a01, T a02, T a03, T a10, T a11, T a12, T a13, T a20, T a21, T a22, T a23, T a30, T a31, T a32, T a33)
Direct initialization by components (row order).

Access to values
T * | RawArray ()
Provide access to internal contents.

void | GetValue (T *mp) const
Copy this matrix mp array (! column-major order).

const T * | GetValue () const
Provide const access to the buffer.

void | SetValue (const T *mp)
Copy data from mp array.

void | SetValue (T r)
Initialization by a diagonal component.

T & | operator() (int row, int col)
access operator (e.g. m(2,3) = 20)

const T & | operator() (int row, int col) const
const access operator (e.g. a = m(2,3))

T & | Elem (int row, int col)
Return (row, col) element.

const T & | Elem (int row, int col) const
Return const (row, col) element.

Row and column access
void | SetScale (T s)
Set scale components of this matrix to the same value s.

void | SetScale (const TVector3< T > &s)
Set scale components of this matrix to values from vector s.

void | SetTranslation (const TVector3< T > &t)
Set translation part of this matrix to values of vector t.

void | GetTranslation (TVector3< T > &t) const
Set vector t to translation part of this matrix.

TVector3< T > | GetTranslation () const
Return translation part of this matrix.

void | SetRotation (const TMatrix4x4< T > &mat)
Set rotation part of the matrix (a 3x3 upper left corner).

void | GetRotation (TMatrix4x4< T > &mat) const
Set mat to rotation part of this matrix.

TMatrix4x4< T > | GetRotation () const
Return rotation part of this matrix (a 3x3 upper left corner).

void | SetRow (int r, const TVector4< T > &t)
Set row r of this matrix to vector t.

void | SetColumn (int c, const TVector4< T > &t)
Set column c of this matrix to vector t.

void | GetRow (int r, TVector4< T > &t) const
Set vector t equal to row r of this matrix.

TVector4< T > | GetRow (int r) const
Return row r.

void | GetColumn (int c, TVector4< T > &t) const
Set vector t equal to column c of this matrix.

TVector4< T > | GetColumn (int c) const
Return column c.

Matrix-2-Matrix operations
TMatrix4x4< T > & | MultRight (const TMatrix4x4< T > &b)
Multiplication to matrix b (right).

TMatrix4x4< T > & | MultLeft (const TMatrix4x4< T > &b)
Multiplication to matrix b (left).

TMatrix4x4< T > & | operator *= (const TMatrix4x4< T > &mat)
this *= mat

TMatrix4x4< T > & | operator+= (const TMatrix4x4< T > &mat)
this += mat

Matrix-2-Vector operations
void | MultMatrixVec (const TVector3< T > &src, TVector3< T > &dst) const
dst = M * src

void | MultMatrixVec (TVector3< T > &src_and_dst) const
src_and_dst = M * src_and_dst

void | MultVecMatrix (const TVector3< T > &src, TVector3< T > &dst) const
dst = src * M

void | MultVecMatrix (TVector3< T > &src_and_dst) const
src_and_dst = src_and_dst * M

void | MultMatrixVec (const TVector4< T > &src, TVector4< T > &dst) const
dst = M * src

void | MultMatrixVec (TVector4< T > &src_and_dst) const
src_and_dst = M * src_and_dst

void | MultVecMatrix (const TVector4< T > &src, TVector4< T > &dst) const
dst = src * M

void | MultVecMatrix (TVector4< T > &src_and_dst) const
src_and_dst = src_and_dst * M

void | MultMatrixDir (const TVector3< T > &src, TVector3< T > &dst) const
dst = M * src (only rotation and scale part, no translation)

void | MultMatrixDir (TVector3< T > &src_and_dst) const
src_and_dst = M * src_and_dst (only rotation and scale part, no translation)

void | MultDirMatrix (const TVector3< T > &src, TVector3< T > &dst) const
dst = src * M (only rotation and scale part, no translation)

void | MultDirMatrix (TVector3< T > &src_and_dst) const
src_and_dst = src_and_dst * M (only rotation and scale part, no translation)

Matrix-2-Scalar operations
TMatrix4x4< T > & | operator *= (const T &r)
Multiplication by scalar r (diagonal).

Miscellaneous
void | MakeIdentity ()
Make E-matrix from this one.

TMatrix4x4< T > | Inverse () const
Return an inverse matrix.

TMatrix4x4< T > | Transpose () const
Return transposed matrix.

void | Ortho (double left, double right, double bottom, double top, double znear, double zfar)

Static Public Member Functions

const TMatrix4x4< T > & | Identity ()
Return predefined identity matrix.

Protected Attributes

T | m [16]

Friends

TMatrix4x4< T > | operator * (const TMatrix4x4< T > &m1, const TMatrix4x4< T > &m2)
Matrix multiplication (return m1 * m2).

bool | operator== (const TMatrix4x4< T > &m1, const TMatrix4x4< T > &m2)
Equality operator.

bool | operator!= (const TMatrix4x4< T > &m1, const TMatrix4x4< T > &m2)
Unequality operator.

Related Functions

(Note that these are not member functions.)

TMatrix4x4< T_TO > | Conv (const TMatrix4x4< T_FROM > &u)
Convert TMatrix4x4<T_FROM> to TMatrix4x4<T_TO>.

TMatrix4x4< float > | ConvF (const TMatrix4x4< T > &u)
Convert TMatrix4x4<T> to TMatrix4x4<float>.

TMatrix4x4< double > | ConvD (const TMatrix4x4< T > &u)
Convert TMatrix4x4<T> to TMatrix4x4<double>.

Detailed Description

template<class T>
class gml::TMatrix4x4< T >

Template class for 4x4 matrix.

Parameters:
T - template type of matrix elements
Warning:
Use it with some SIGNED integral type, or a real type Elements are stored in column-major order (OpenGL-style) E.g.:

    a0  a4  a8  a12
    a1  a5  a9  a13
    a2  a6  a10 a14
    a3  a7  a11 a15

Member Function Documentation

T* RawArray ( ) [inline]

Provide access to internal contents.

Warning:
Use with care, this function is dangerous!

void SetTranslation ( const TVector3< T > & t ) [inline]

Set translation part of this matrix to values of vector t.

Translation part is the 4-th column, so it is valid for use with column-vectors V = M * V; V = (v1 v2 v3 v4)T

See also:
MultMatrixVec

The documentation for this class was generated from the following file:
  • gmlmatrix4.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTQuaternion class Reference

TQuaternion Class Template Reference
[Math]

quaternion template More...

#include <gmlquat.h>

List of all members.

Public Member Functions

TQuaternion (const T v[4])
TQuaternion (T q0, T q1, T q2, T q3)
TQuaternion (const TMatrix4x4< T > &m)
TQuaternion (const TVector3< T > &axis, T radians)
TQuaternion (const TVector3< T > &rotateFrom, const TVector3< T > &rotateTo)
TQuaternion (const TVector3< T > &from_look, const TVector3< T > &from_up, const TVector3< T > &to_look, const TVector3< T > &to_up)
const T * | GetValue () const
void | GetValue (T &q0, T &q1, T &q2, T &q3) const
TQuaternion & | SetValue (T q0, T q1, T q2, T q3)
void | GetValue (TVector3< T > &axis, T &radians) const
void | GetValue (TMatrix4x4< T > &m) const
TQuaternion & | SetValue (const T *qp)
TQuaternion & | SetValue (const TMatrix4x4< T > &m)
TQuaternion & | SetValue (const TVector3< T > &axis, T theta)
TQuaternion & | SetValue (const TVector3< T > &rotateFrom, const TVector3< T > &rotateTo)
TQuaternion & | SetValue (const TVector3< T > &from_look, const TVector3< T > &from_up, const TVector3< T > &to_look, const TVector3< T > &to_up)
TQuaternion & | operator *= (const TQuaternion &qr)
void | Normalize ()
bool | Equals (const TQuaternion &r, T tolerance) const
TQuaternion & | Conjugate ()
TQuaternion & | Invert ()
TQuaternion | Inverse () const
void | MultVec (const TVector3< T > &src, TVector3< T > &dst) const
void | MultVec (TVector3< T > &src_and_dst) const
void | ScaleAngle (T scaleFactor)
T & | operator[] (int i)
const T & | operator[] (int i) const

Static Public Member Functions

TQuaternion | Slerp (const TQuaternion &p, const TQuaternion &q, T alpha)
TQuaternion | Identity ()

Protected Member Functions

void | CounterNormalize ()

Protected Attributes

unsigned char | counter

Friends

bool | operator== (const TQuaternion &q1, const TQuaternion &q2)
bool | operator!= (const TQuaternion &q1, const TQuaternion &q2)
TQuaternion | operator * (const TQuaternion &q1, const TQuaternion &q2)

Related Functions

(Note that these are not member functions.)

TQuaternion< T_TO > | Conv (const TQuaternion< T_FROM > &u)
Convert TQuaternion<T_FROM> to TQuaternion<T_TO>.

TQuaternion< float > | ConvF (const TQuaternion< T > &u)
Convert TQuaternion<T> to TQuaternion<float>.

TQuaternion< double > | ConvD (const TQuaternion< T > &u)
Convert TQuaternion<T> to TQuaternion<double>.

Detailed Description

template<class T>
class gml::TQuaternion< T >

quaternion template

The documentation for this class was generated from the following file:
  • gmlquat.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTVector2 class Reference

TVector2 Class Template Reference
[Math2]

Template class for 2D vectors. More...

#include <gmlvector2.h>

List of all members.

Element access

T & | operator[] (int i)
const T & | operator[] (int i) const
void | SetValue (double x0, double y0)
Set elements by 2 double components.

void | SetValue (double a)
Set all the elements to the same T value.

GetDim ()

Public Member Functions

Constructors
TVector2 ()
No initialization.

TVector2 (double v)
Initialization by scalar.

TVector2 (double x0, double y0)
Initialization by given components.

TVector2 (const TVector3< T > &u)
Conversions
operator T * ()
Convert a TVector to array of (2) elements.

operator const T * () const
Convert a TVector to array of (2) elements.

Binary operations
TVector2< T > & | operator+= (const TVector2< T > &u)
TVector2< T > & | operator-= (const TVector2< T > &u)
TVector2< T > | operator+ (const TVector2< T > &u) const
TVector2< T > | operator- (const TVector2< T > &u) const
TVector2< T > & | operator *= (const double d)
TVector2< T > & | operator/= (const double d)
TVector2< T > | MultVec (const TVector2< T > &u) const
Vector scaling (this vector is not modified).

TVector2< T > | DivVec (const TVector2< T > &u) const
Vector-by vector division (this vector is not modified).

TVector2< T > | operator * (const double d) const
TVector2< T > | operator/ (const double d) const
double | operator * (const TVector2< T > &rhs) const
dot product

double | operator^ (const TVector2< T > &rhs) const
cross product

double | DotProduct (const TVector2< T > &rhs) const
dot product

double | CrossProduct (const TVector2< T > &rhs) const
cross product

Unary operations
void | Negate ()
Vector (self) negation.

TVector2< T > | operator- () const
Service methods
void | Clip (double vmin, double vmax)
Clip elements of this TVector to constraints from vmin to vmax.

TVector2< double > | operator~ () const
returns normalized vector (always double)

TVector2< T > & | Normalize ()
Normalize this vector, return vector itself.

bool | Normalized () const
Test whether the TVector is normalized.

double | SqrLength () const
Squared length of vector.

double | Length () const
Length of the vector.

bool | LessOrEqual (const TVector2< T > &u) const
Return true if all components of this vector less of equal than u.

double | operator! () const
Length of the vector.

TVector2< T > | NormalRight () const
Returns normal N to this vector, such that DotProduct(*this, N) = 0.

MFC, VCL, OWL - specific functions (defined only if proper defines are found)
TVector2 (const TPoint &p)
TVector2< T > & | operator= (const TPoint &p)
operator TPoint ()
TVector2 (const CPoint &p)
TVector2 (const POINT &p)
TVector2 (const CSize &p)
TVector2< T > & | operator= (const CPoint &p)
TVector2< T > & | operator= (const POINT &p)
TVector2< T > & | operator= (const CSize &p)
operator CPoint ()
operator CvPoint ()
operator CvSize ()
TVector2 (const CvPoint &p)
TVector2 | operator= (const CvPoint &p)

Static Public Member Functions

const TVector2< T > & | Cast (const T *u)
Treat array of (2) elements as a TVector.

TVector2< T > & | Cast (T *u)
Treat array of (2) elements as a TVector.

Related Functions

(Note that these are not member functions.)

TVector2< T > | operator * (const double d, const TVector2< T > &u)
Multiplication of scalar d by TVector u.

double | SqrLength (const TVector2< T > &u)
Squared length of given vector.

double | Length (const TVector2< T > &u)
Length of the vector.

double | DotProd (const TVector2< T > &v1, const TVector2< T > &v2)
Dot product.

double | DotProduct (const TVector2< T > &v1, const TVector2< T > &v2)
Dot product.

double | CrossProd (const TVector2< T > &v1, const TVector2< T > &v2)
Cross product.

double | CrossProduct (const TVector2< T > &v1, const TVector2< T > &v2)
Cross product.

double | Cos (const TVector2< T > &a, const TVector2< T > &b)
cos between two vectors

double | Sin (const TVector2< T > &a, const TVector2< T > &b)
sin between two vectors

TVector2< T_TO > | Conv (const TVector2< T_FROM > &u)
Convert TVector2<T_FROM> to TVector2<T_TO>.

TVector2< float > | ConvF (const TVector2< T > &u)
Convert TVector2<T> to TVector2<float>.

TVector2< double > | ConvD (const TVector2< T > &u)
Convert TVector2<T> to TVector2<double>.

TVector2< int > | ConvI (const TVector2< T > &u)
Convert TVector2<T> to TVector2<int>.

TVector2< short > | ConvS (const TVector2< T > &u)
Convert TVector2<T> to TVector2<int>.

Detailed Description

template<class T>
class gml::TVector2< T >

Template class for 2D vectors.

Parameters:
T - template type of TVector elements
Warning:
Use it with some SIGNED integral type, or a real type

Member Function Documentation

TVector2<T> NormalRight ( ) const [inline]

Returns normal N to this vector, such that DotProduct(*this, N) = 0.

Parameters:
def - vector returned if the length of this vector is near zero
Note:
Projection of the resulting vector to the X axis will have the same sign that projection of this vector. If x = 0, then normal will be equal (1,0)

The documentation for this class was generated from the following file:
  • gmlvector2.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTVector3 class Reference

TVector3 Class Template Reference
[Math3]

Template class for 3D geometric vectors. More...

#include <gmlvector3.h>

List of all members.

Element access

T & | operator[] (int i)
const T & | operator[] (int i) const
void | SetValue (double x0, double y0, double z0)
Set elements by 3 double components.

void | SetValue (double a)
Set all the elements to the same T value.

GetDim ()

Public Member Functions

Constructors
TVector3 ()
No initialization.

TVector3 (double v)
Initialization by scalar.

TVector3 (double x0, double y0, double z0)
Initialization by given components.

TVector3 (T *data)
TVector3 (const TVector3< T > &data)
Conversions
operator T * ()
Convert a TVector to array of (3) elements.

operator const T * () const
Convert a TVector to array of (3) elements.

Binary operations
TVector3< T > & | operator+= (const TVector3< T > &u)
TVector3< T > & | operator-= (const TVector3< T > &u)
TVector3< T > | operator+ (const TVector3< T > &u) const
TVector3< T > | operator- (const TVector3< T > &u) const
TVector3< T > & | operator *= (const double d)
TVector3< T > | MultVec (const TVector3< T > &u) const
Vector scaling (this vector is not modified).

TVector3< T > | DivVec (const TVector3< T > &u) const
Vector-by vector division (this vector is not modified).

TVector3< T > & | operator/= (const double d)
TVector3< T > | operator * (const double d) const
TVector3< T > | operator/ (const double d) const
TVector3< T > | operator/ (const TVector3< T > v) const
double | operator * (const TVector3< T > &rhs) const
dot product

TVector3< T > | operator^ (const TVector3< T > &rhs) const
cross product

double | DotProduct (const TVector3< T > &rhs) const
dot product

TVector3< T > | CrossProduct (const TVector3< T > &rhs) const
cross product

Unary operations
void | Negate ()
Vector (self) negation.

TVector3< T > | operator- () const
Unary negation operator.

TVector3< double > | operator~ () const
returns normalized vector (always double)

TVector3< T > & | Normalize ()
Normalize this vector, return vector itself.

double | Length () const
Length of the vector.

double | operator! () const
Length of the vector.

Service methods
Clip elements of this TVector to constraints from vmin to vmax

void | Clip (double vmin, double vmax)
bool | Normalized () const
Test whether the TVector is normalized.

double | SqrLength () const
Squared length of vector.

bool | LessOrEqual (const TVector3< T > &u) const
Return true if all components of this vector less of equal than u.

T | MaxValue () const
Return C-norm of the vector (maximal value among coords).

MFC, VCL, OWL - specific functions (defined only if proper defines are found)
TVector3 (const TPoint &p)
TVector3< T > & | operator= (const TPoint &p)
operator TPoint ()
TVector3 (const CPoint &p)
TVector3 (const CSize &p)
TVector3< T > & | operator= (const CPoint &p)
TVector3< T > & | operator= (const CSize &p)
operator CPoint ()
operator CvPoint ()
TVector3 (const CvPoint &p)
TVector3 | operator= (const CvPoint &p)

Static Public Member Functions

const TVector3< T > & | Cast (const T *u)
Treat array of (3) elements as a TVector.

TVector3< T > & | Cast (T *u)
Treat array of (3) elements as a TVector.

Related Functions

(Note that these are not member functions.)

TVector3< T > | operator * (const double d, const TVector3< T > &u)
Multiplication of scalar d by TVector u.

double | SqrLength (const TVector3< T > &u)
Squared length of given vector.

double | Length (const TVector3< T > &u)
Length of the vector.

double | DotProduct (const TVector3< T > &v1, const TVector3< T > &v2)
Dot product.

TVector3< T > | CrossProduct (const TVector3< T > &v1, const TVector3< T > &v2)
Cross product.

double | Cos (const TVector3< T > &a, const TVector3< T > &b)
cos between two vectors

double | Sin (const TVector3< T > &a, const TVector3< T > &b)
sin between two vectors

TVector3< T_TO > | Conv (const TVector3< T_FROM > &u)
Convert TVector3<T_FROM> to TVector3<T_TO>.

TVector3< float > | ConvF (const TVector3< T > &u)
Convert TVector3<T> to TVector3<float>.

TVector3< double > | ConvD (const TVector3< T > &u)
Convert TVector3<T> to TVector3<double>.

TVector3< int > | ConvI (const TVector3< T > &u)
Convert TVector3<T> to TVector3<int>.

TVector3< short > | ConvS (const TVector3< T > &u)
Convert TVector3<T> to TVector3<int>.

Detailed Description

template<class T>
class gml::TVector3< T >

Template class for 3D geometric vectors.

Parameters:
T - template type of TVector elements
Warning:
Use it with some SIGNED integral type, or a real type

The documentation for this class was generated from the following file:
  • gmlvector3.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: TemplateTVector4 class Reference

TVector4 Class Template Reference
[Math4]

Template class for 4D geometric vectors. More...

#include <gmlvector4.h>

List of all members.

Public Member Functions

Constructors
TVector4 ()
No initialization.

TVector4 (double v)
Initialization by scalar.

TVector4 (double x0, double y0, double z0, double w0)
Initialization by given components.

TVector4 (const TVector3< T > &v, double w0=1)
Initialization by given 3d-vector (w become equal to 1).

Element access
T & | operator[] (int i)
const T & | operator[] (int i) const
void | SetValue (double x0, double y0, double z0, double w0)
Set elements by 3 double components.

void | SetValue (double a)
Set all the elements to the same T value.

Conversions
operator T * ()
Convert a TVector to array of (3) elements.

operator const T * () const
Convert a TVector to array of (3) elements.

Binary operations
TVector4< T > & | operator+= (const TVector4< T > &u)
TVector4< T > & | operator-= (const TVector4< T > &u)
TVector4< T > | operator+ (const TVector4< T > &u) const
TVector4< T > | operator- (const TVector4< T > &u) const
TVector4< T > & | operator *= (const double d)
TVector4< T > & | operator/= (const double d)
TVector4< T > | MultVec (const TVector4< T > &u) const
Vector scaling (this vector is not modified).

TVector4< T > | DivVec (const TVector4< T > &u) const
Vector-by vector division (this vector is not modified).

TVector4< T > | operator * (const double d) const
TVector4< T > | operator/ (const double d) const
double | operator * (const TVector4< T > &rhs) const
dot product

double | DotProduct (const TVector4< T > &rhs) const
dot product

Unary operations
void | Negate ()
Vector (self) negation.

TVector4< T > | operator- () const
Unary negation operator.

TVector4< double > | operator~ () const
returns normalized vector (always double)

TVector4< T > & | Normalize ()
Normalize this vector, return vector itself.

double | Length () const
Length of the vector.

double | operator! () const
Length of the vector.

Service methods
void | Clip (double vmin, double vmax)
Clip elements of this TVector to constraints from vmin to vmax.

bool | Normalized () const
Test whether the TVector is normalized.

double | SqrLength () const
Squared length of vector.

bool | LessOrEqual (const TVector4< T > &u) const
Return true if all components of this vector less of equal than u.

bool | LessOrEqual (const TVector3< T > &u) const
Return true if all components of this vector less of equal than u.

T | MaxValue () const
Return C-norm of the vector (maximal value among coords).

TVector3< double > | Homogenize ()
MFC, VCL, OWL - specific functions (defined only if proper defines are found)
TVector4 (const TPoint &p)
TVector4< T > & | operator= (const TPoint &p)
operator TPoint ()
TVector4 (const CPoint &p)
TVector4 (const CSize &p)
TVector4< T > & | operator= (const CPoint &p)
TVector4< T > & | operator= (const CSize &p)
operator CPoint ()
operator CvPoint ()
TVector4 (const CvPoint &p)
TVector4 | operator= (const CvPoint &p)

Static Public Member Functions

const TVector4< T > & | Cast (const T *u)
Treat array of (3) elements as a TVector.

TVector4< T > & | Cast (T *u)
Treat array of (3) elements as a TVector.

Related Functions

(Note that these are not member functions.)

TVector4< T > | operator * (const double d, const TVector4< T > &u)
Multiplication of scalar d by TVector u.

double | SqrLength (const TVector4< T > &u)
Squared length of given vector.

double | Length (const TVector4< T > &u)
Length of the vector.

double | DotProduct (const TVector4< T > &v1, const TVector4< T > &v2)
Dot product.

TVector4< T_TO > | Conv (const TVector4< T_FROM > &u)
Convert TVector4<T_FROM> to TVector4<T_TO>.

TVector4< float > | ConvF (const TVector4< T > &u)
Convert TVector4<T> to TVector4<float>.

TVector4< double > | ConvD (const TVector4< T > &u)
Convert TVector4<T> to TVector4<double>.

TVector4< int > | ConvI (const TVector4< T > &u)
Convert TVector4<T> to TVector4<int>.

TVector4< short > | ConvS (const TVector4< T > &u)
Convert TVector4<T> to TVector4<int>.

Detailed Description

template<class T>
class gml::TVector4< T >

Template class for 4D geometric vectors.

Parameters:
T - template type of TVector elements
Warning:
Use it with some SIGNED integral type, or a real type

The documentation for this class was generated from the following file:
  • gmlvector4.h
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Viewport class Reference

Viewport Class Reference
[Utils3D]

Class representing 3d viewport (a window with accociated camera). More...

#include <gmlviewport.h>

List of all members.

Public Member Functions

Viewport (int x, int y, int xres, int yres, Camera *camera=0)
void | GetResolution (int &xres, int &yres) const
void | SetResolution (int xres, int yres)
void | SetOrigin (int x, int y)
void | GetOrigin (int &x, int &y) const
const Matrix4x4d & | GetTransform () const
void | SetTransform (const Matrix4x4d &view_transform)
float | GetViewAngle () const
void | SetViewAngle (float view_angle)
const Camera * | GetCamera () const
void | SetCamera (Camera *cam)
Vector3d | GetViewVector () const
get view vector of camera (normalized)

Vector3d | GetUpVector () const
get up vector of camera (normalized)

Vector3d | GetRightVector () const
get up vector of camera (normalized)

Vector3d | GetObserver () const
get camera position

void | SetObserver (const Vector3d &obs)
Matrix4x4d | GetRotation () const
void | SetRotation (const Matrix4x4d &rot)
void | SetDistanceToTarget (float dist)
float | GetDistanceToTarget () const

Detailed Description

Class representing 3d viewport (a window with accociated camera).

The documentation for this class was generated from the following file:
  • gmlviewport.h
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Compound Member Index

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AboutZero() : Math
  • AddRef() : SmartObject
  • Apply() : ImageFilter, ImageDecomposer, ImageComposer, SetRectFilter, ReflectFilter, FilterRGB2RGBA, FilterResize, FilterRepres, FilterMedianBlur, FilterLum2RGB, FilterGrayscale
  • ApplyFilter() : Image
  • ApplyInPlace() : ImageFilter, FilterRGB2BGR
  • AsCString() : String
  • AsDouble() : String
  • AsInt() : String
  • AttachImage() : DIntelImage

- b -

  • Basename() : PathString
  • BBox2() : BBox2
  • BBox3() : BBox3
  • BSphere3() : BSphere3

- c -

  • Call() : Callback
  • Cast() : TVector4, TVector3, TVector2, TColor4, TColor3
  • center : BSphere3
  • Center() : BBox3, BBox2
  • ChangeFormat() : Image
  • ChangeOrientation() : Image
  • ChangeRepres() : Image
  • ChDir() : PathString
  • CheckImage() : DIntelImage
  • CIniFile() : CIniFile
  • Clear() : Ref
  • Clip() : TVector4, TVector2
  • CloneImage() : DIntelImage
  • Close() : File
  • Conv() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvD() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvF() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvI() : TVector4, TVector3, TVector2
  • ConvRef() : Ref
  • ConvS() : TVector4, TVector3, TVector2
  • CopyOf() : DIntelImage
  • Cos() : TVector3, TVector2
  • Create() : GLRC, Image
  • CreateCopy() : Image
  • CreateFilteredCopy() : Image
  • CreateFromDIB() : Image
  • CreateImage() : DIntelImage
  • CrossProd() : TVector2
  • CrossProduct() : TVector3, TVector2, TVector3, TVector2
  • CurDir() : PathString

- d -

  • Decompose() : Image
  • DeleteImages() : DIntelImage
  • DeleteKey() : CIniFile
  • DeleteValue() : CIniFile
  • Destroy() : GLRC
  • DetachImage() : DIntelImage
  • Diag() : BBox3, BBox2
  • DIntelImage() : DIntelImage
  • DivVec() : TVector4, TVector3, TVector2
  • DotProd() : TVector2
  • DotProduct() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • DrawImage() : DIntelImage
  • DrawSurface() : DrawSurface

- e -

  • Elem() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • EPSILON : Math
  • error : CIniFile
  • ExePath() : PathString
  • ExpandBy() : BBox3, BBox2
  • Extension() : PathString

- f -

  • FastResizeImage() : GDIImage
  • File() : File
  • Filename() : PathString
  • FilePos() : File
  • FileSize() : File
  • FindFiles() : FileFinder
  • Format() : String
  • FormatV() : String
  • FrameCounter() : FrameCounter
  • FrameFinished() : FrameCounter
  • FrameStarted() : FrameCounter
  • FreeMembers() : SimpleImage, IntelImage, Image, GDIImage

- g -

  • GDIImage() : GDIImage
  • GDISurface() : GDISurface
  • GetBitsMemNeeded() : SimpleImage
  • GetBytesPerLine() : SimpleImage, IntelImage, Image, GDIImage
  • GetColumn() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • GetDistanceToTarget() : Camera
  • GetDrawSurface() : SimpleImage, IntelImage, GDIImage
  • GetFormatExtension() : ImageLoader
  • GetFrameCount() : FrameCounter
  • GetImage() : DIntelImage, IntelImage
  • GetLineArray() : Image
  • GetLineFast() : DIntelImage
  • GetLineSafe() : DIntelImage
  • GetMeanFrameTime() : FrameCounter
  • GetMemNeeded() : SimpleImage
  • GetMemUsed() : SimpleImage, IntelImage, GDIImage
  • GetMinimumFrameCount() : FrameCounter
  • GetNumKeys() : CIniFile
  • GetNumValues() : CIniFile
  • GetObserver() : Viewport
  • GetRawData() : SimpleImage, IntelImage, GDIImage
  • GetRightVector() : Viewport, Camera
  • GetRotation() : TMatrix4x4, TMatrix3x3
  • GetRow() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • GetTransform() : Camera
  • GetTranslation() : TMatrix4x4, TMatrix3x3
  • GetUpdateSpeed() : FrameCounter
  • GetUpVector() : Viewport, Camera
  • GetValue() : TMatrix4x4, TMatrix3x3, TMatrix2x2, CIniFile
  • GetValueF() : CIniFile
  • GetValueI() : CIniFile
  • GetViewAngle() : Camera
  • GetViewVector() : Viewport, Camera
  • GLRC() : GLRC

- h -

  • height() : DIntelImage
  • Height() : BBox2

- i -

  • Identity() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • Image() : Image
  • Include() : BSphere3, BBox3, BBox2
  • Includes() : BBox3, BBox2
  • InitLineArray() : SimpleImage, IntelImage, Image, GDIImage
  • InitLocals() : Image
  • InitSockets() : Socket
  • IntelImage() : IntelImage
  • IntelSurface() : IntelSurface
  • InternalChangeOrientation() : SimpleImage, IntelImage, Image, GDIImage
  • InternalCopy() : Image
  • InternalCreate() : SimpleImage, IntelImage, Image, GDIImage
  • Intersect() : BBox3, BBox2
  • Intersects() : BBox3, BBox2
  • Inverse() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • IsCurrent() : GLRC
  • IsDir() : PathString
  • IsDot() : BBox3, BBox2
  • IsFile() : PathString
  • IsSet() : Ref

- l -

  • Length() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • LessOrEqual() : TVector4, TVector3, TVector2
  • ListFileName() : PathString
  • LoadImage() : DIntelImage
  • Lock() : Image

- m -

  • m_BMInfo : GDIImage
  • m_created : GLRC
  • m_dc : GLRC
  • m_glrc : GLRC
  • m_hBMP : GDIImage
  • m_hDC : GDIImage
  • m_hOldHandle : GDIImage
  • m_iBytesPerLine : GDIImage
  • m_inv_view_transform : Camera
  • m_line_array : Image
  • m_lock_count : Image
  • m_orient : Image
  • m_pBits : SimpleImage, GDIImage
  • m_pImage : DIntelImage, IntelImage
  • m_pPalette : GDIImage
  • m_target_distance : Camera
  • m_view_angle : Camera
  • m_view_transform : Camera
  • m_wnd : GLRC
  • MakeCurrent() : GLRC
  • MakeFullPath() : PathString
  • MakeIdentity() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MAX_VALUE : Math
  • MaxValue() : TVector4, TVector3
  • METHOD : FilterGrayscale
  • MIN_VALUE : Math
  • MkDir() : PathString
  • MultDirMatrix() : TMatrix4x4, TMatrix3x3
  • MultLeft() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MultMatrixDir() : TMatrix4x4, TMatrix3x3
  • MultMatrixVec() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MultRight() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MultVec() : TVector4, TVector3, TVector2
  • MultVecMatrix() : TMatrix4x4, TMatrix3x3, TMatrix2x2

- n -

  • Negate() : TVector4, TVector3, TVector2
  • Normalize() : TVector4, TVector3, TVector2
  • Normalized() : TVector4, TVector3, TVector2
  • NormalRight() : TVector2
  • NotEmpty() : BBox3, BBox2

- o -

  • O_BOTTOMLEFT : Image
  • O_TOPLEFT : Image
  • Open() : File
  • Opened() : File
  • operator *() : TVector4, TVector3, TVector2, TColor4, TColor3, TVector4, TVector3, TVector2, TMatrix4x4, TMatrix3x3, TMatrix2x2, Ref
  • operator *=() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator const T *() : TVector4, TVector3, TVector2, TColor4, TColor3
  • operator T *() : TVector4, TVector3, TVector2, TColor4, TColor3, Ref
  • operator!() : TVector4, TVector3, TVector2
  • operator!= : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator()() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator+=() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator-() : TVector4, TVector3
  • operator->() : Ref
  • operator=() : DIntelImage, SimpleImage, IntelImage, Image, GDIImage, Ref
  • operator==() : TMatrix4x4, TMatrix3x3, TMatrix2x2, Image
  • operator^() : TVector3, TVector2
  • operator~() : TVector4, TVector3, TVector2
  • ORIENT : Image

- p -

  • PaintImage() : GDIImage
  • PaintImageRect() : GDIImage
  • Path() : PathString
  • PATH_SEPARATOR : PathString
  • PATH_SEPARATOR_STR : PathString
  • PathString() : PathString

- r -

  • radius : BSphere3
  • RawArray() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ReadFile() : CIniFile
  • Ref() : Ref
  • Release() : SmartObject
  • Reset() : FrameCounter, CIniFile
  • RmDir() : PathString

- s -

  • SaveImage() : DIntelImage
  • Set() : Ref
  • SetColumn() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • SetDistanceToTarget() : Camera
  • SetMinimumFrameCount() : FrameCounter
  • SetPath() : CIniFile
  • SetRect() : BBox2
  • SetRotation() : TMatrix4x4, TMatrix3x3
  • SetRow() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • SetScale() : TMatrix4x4, TMatrix3x3
  • SetTransform() : Camera
  • SetTranslation() : TMatrix4x4, TMatrix3x3
  • SetUpdateSpeed() : FrameCounter
  • SetValue() : TVector4, TVector3, TVector2, TMatrix4x4, TMatrix3x3, TMatrix2x2, CIniFile
  • SetValueF() : CIniFile
  • SetValueI() : CIniFile
  • SetViewAngle() : Camera
  • SignAbout() : Math
  • SimpleImage() : SimpleImage
  • Sin() : TVector3, TVector2
  • Split() : PathString
  • SqrLength() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • step() : DIntelImage
  • String() : String
  • SwapBuffers() : GLRC

- t -

  • TColor3() : TColor3
  • TColor4() : TColor4
  • TMatrix2x2() : TMatrix2x2
  • TMatrix3x3() : TMatrix3x3
  • TMatrix4x4() : TMatrix4x4
  • TOLERANCE : Math
  • Translate() : BBox3, BBox2
  • Translated() : BBox3, BBox2
  • Transpose() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • TVector2() : TVector2
  • TVector3() : TVector3
  • TVector4() : TVector4

- u -

  • Unlock() : Image
  • Updated() : FrameCounter

- v -

  • vmax : BBox3, BBox2
  • vmin : BBox3, BBox2
  • Volume() : BBox3, BBox2

- w -

  • Width() : BBox2
  • width() : DIntelImage
  • WriteFile() : CIniFile

- ~ -

  • ~CIniFile() : CIniFile
  • ~DIntelImage() : DIntelImage
  • ~DrawSurface() : DrawSurface
  • ~File() : File
  • ~FrameCounter() : FrameCounter
  • ~GDIImage() : GDIImage
  • ~GDISurface() : GDISurface
  • ~GLRC() : GLRC
  • ~Image() : Image
  • ~IntelImage() : IntelImage
  • ~IntelSurface() : IntelSurface
  • ~Ref() : Ref
  • ~SimpleImage() : SimpleImage
  • ~SmartObject() : SmartObject
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: DScene

DScene

Classes

class Mesh
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Base

Base

Classes

class | Callback
Base class for callback with no arguments and no return value. More...

class | CallbackR
class | Callback1
class | CallbackR1
class | Callback2
class | CallbackR2
class | Callback3
class | CallbackR3
class | FunctionCallback
class | FunctionCallbackR
class | FunctionCallback1
class | FunctionCallbackR1
class | FunctionCallback2
class | FunctionCallbackR2
class | FunctionCallback3
class | FunctionCallbackR3
class | MethodCallback
class | MethodCallbackR
class | MethodCallback1
class | MethodCallbackR1
class | MethodCallback2
class | MethodCallbackR2
class | MethodCallback3
class | MethodCallbackR3
class | Ref
Smart pointer class Smart pointers provide automatic memory management, so that programmer never cares on freeing memory. Smart pointers mechanism frees an object when there are no any references to it. Smart pointers should be used instead of standard C pointers:
  Object* obj; // standard pointer, should be deleted after use
  gml::Ref<Object> obj; // smart pointer frees memory when necessary
Attention:
Smart pointers works only with objects that support AddRef() and Release() operations. It is assumed that object keeps a reference count (a number of smapt pointers pointing to it). This reference count is incremented in AddRef() command and decremented in Release(). Also Release() performs check whether reference count is 0 and calls 'delete this'. GML provides special base class for this: gml::SmartObject. If you want to use smart pointers either derive your object from this class or provide own implementation of AddRef() and Release() methods. 1) initialization Smart pointers are initiliazed just like the standard pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);

Smart pointers must never be defined like this: gml::Rev<Object>* obj; !!! 2) use of smart pointers Smart pointers are dereferenced like normal pointers:

  gml::Ref<Object> obj =  new Object(1,2,3);
  obj->SomeMethod();
  (*obj).SomeMethod();
3) smart pointers as parameters Smart pointers are implicitly casted to normal pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);
  Object* obj1 =  obj;
This operation is dangerous unless used properly. You should use it like follows. Smart pointers may be passed to functions and returned from functions like normal pointers.
  ...
  Object* SomeMethod(Object* obj);
  ...
  gml::Ref<Object> obj =  new Object(1,2,3);
  gml::Ref<Object> obj1 = SomeMethod(obj);
The general rule is this: Use ONLY smart pointers when storing objects. Use normals pointers when passing smart pointers as parameters or return values So the following is forbidden:
  class SomeClass
    {
    private:
      Object* obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        } // at this point obj will be deleted, and m_obj will be undefined!!
    };
Correct use:
  class SomeClass
    {
    private:
      gml::Ref<Object> obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        }
    };
.
More...

class | SmartObject
Base class for objects with support for reference counting. More...

class | String
Standard string with some extensions. More...

class | Ref
Smart pointer class Smart pointers provide automatic memory management, so that programmer never cares on freeing memory. Smart pointers mechanism frees an object when there are no any references to it. Smart pointers should be used instead of standard C pointers:
  Object* obj; // standard pointer, should be deleted after use
  gml::Ref<Object> obj; // smart pointer frees memory when necessary
Attention:
Smart pointers works only with objects that support AddRef() and Release() operations. It is assumed that object keeps a reference count (a number of smapt pointers pointing to it). This reference count is incremented in AddRef() command and decremented in Release(). Also Release() performs check whether reference count is 0 and calls 'delete this'. GML provides special base class for this: gml::SmartObject. If you want to use smart pointers either derive your object from this class or provide own implementation of AddRef() and Release() methods. 1) initialization Smart pointers are initiliazed just like the standard pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);

Smart pointers must never be defined like this: gml::Rev<Object>* obj; !!! 2) use of smart pointers Smart pointers are dereferenced like normal pointers:

  gml::Ref<Object> obj =  new Object(1,2,3);
  obj->SomeMethod();
  (*obj).SomeMethod();
3) smart pointers as parameters Smart pointers are implicitly casted to normal pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);
  Object* obj1 =  obj;
This operation is dangerous unless used properly. You should use it like follows. Smart pointers may be passed to functions and returned from functions like normal pointers.
  ...
  Object* SomeMethod(Object* obj);
  ...
  gml::Ref<Object> obj =  new Object(1,2,3);
  gml::Ref<Object> obj1 = SomeMethod(obj);
The general rule is this: Use ONLY smart pointers when storing objects. Use normals pointers when passing smart pointers as parameters or return values So the following is forbidden:
  class SomeClass
    {
    private:
      Object* obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        } // at this point obj will be deleted, and m_obj will be undefined!!
    };
Correct use:
  class SomeClass
    {
    private:
      gml::Ref<Object> obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        }
    };
.
More...

Functions

Ref< newT > & | gml::Ref::ConvRef (const Ref< oldT > &old_ref)
Casting & convertion of smart references.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Color

Color

Classes

class | TColor3
3 Color repsentation More...

class | TColor4
4 Color repsentation More...

Typedefs

typedef TColor3< BYTE > | Color3ub
typedef TColor3< WORD > | Color3w
typedef TColor3< short > | Color3s
typedef TColor3< float > | Color3f
typedef TColor4< BYTE > | Color4ub
typedef TColor4< float > | Color4f
typedef TColor3< BYTE > | gml::ColorRGBub
typedef TColor3< WORD > | gml::ColorRGBw
typedef TColor3< float > | gml::ColorRGBf
typedef TColor4< BYTE > | gml::ColorRGBAub
typedef TColor4< float > | gml::ColorRGBAf

Functions

TColor3< T > | gml::TColor3::operator * (const double d, const TColor3< T > &u)
Multiplication of scalar d by TColor3 u.

TColor4< T > | gml::TColor4::operator * (const double d, const TColor4< T > &u)
Multiplication of scalar d by TColor4 u.

Typedef Documentation

typedef TColor3<BYTE> ColorRGBub

Deprecated:
use Color3 instead

typedef TColor3<WORD> ColorRGBw

Deprecated:
use Color3 instead

typedef TColor3<float> ColorRGBf

Deprecated:
use Color3 instead

typedef TColor4<BYTE> ColorRGBAub

Deprecated:
use Color3 instead

typedef TColor4<float> ColorRGBAf

Deprecated:
use Color3 instead

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Files

Files

Classes

class | File
A class for working with files (a wrapped to FILE *). More...

class | FileFinder
class | CIniFile
Handling of INI-files. More...

class | PathString
Processing of the path to file. More...

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: ImageFilters

ImageFilters
[Images]

Classes

class | FilterGrayscale
Creates a grayscale version of a color bitmap. More...

class | FilterLum2RGB
Creates a Lum2RGB version of a color bitmap. More...

class | FilterMedianBlur
Creates a MedianBlur version of a color bitmap. More...

class | FilterRepres
Transferres between different representations. More...

class | FilterResize
Creates a MedianBlur version of a color bitmap. More...

class | FilterRGB2BGR
Creates a Lum2RGB version of a color bitmap. More...

class | FilterRGB2RGBA
Creates a grayscale version of a color bitmap. More...

class | ReflectFilter
Creates a grayscale version of a color bitmap. More...

class | SetRectFilter
Creates a grayscale version of a color bitmap. More...

class | ImageComposer
Produce single image from several reference images. More...

class | ImageDecomposer
Decompose an image into several destination images. More...

class | ImageFilter
Interface for generic image modifier. More...

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math2x2

Math2x2
[Math]

Classes

class | TMatrix2x2
Template class for 2x2 matrix. More...

Typedefs

typedef TMatrix2x2< double > | Matrix2x2d
typedef TMatrix2x2< float > | Matrix2x2f

Functions

TMatrix2x2< T_TO > | gml::TMatrix2x2::Conv (const TMatrix2x2< T_FROM > &u)
Convert TMatrix2x2<T_FROM> to TMatrix2x2<T_TO>.

TMatrix2x2< float > | gml::TMatrix2x2::ConvF (const TMatrix2x2< T > &u)
Convert TMatrix2x2<T> to TMatrix2x2<float>.

TMatrix2x2< double > | gml::TMatrix2x2::ConvD (const TMatrix2x2< T > &u)
Convert TMatrix2x2<T> to TMatrix2x2<double>.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math3x3

Math3x3
[Math]

Classes

class | TMatrix3x3
Template class for 3x3 matrix. More...

Typedefs

typedef TMatrix3x3< double > | Matrix3x3d
typedef TMatrix3x3< float > | Matrix3x3f

Functions

template<class T> TMatrix3x3< T > | MultVectStr (TVector3< T > &v1, TVector3< T > &v2)
TMatrix3x3< T_TO > | gml::TMatrix3x3::Conv (const TMatrix3x3< T_FROM > &u)
Convert TMatrix3x3<T_FROM> to TMatrix3x3<T_TO>.

TMatrix3x3< float > | gml::TMatrix3x3::ConvF (const TMatrix3x3< T > &u)
Convert TMatrix3x3<T> to TMatrix3x3<float>.

TMatrix3x3< double > | gml::TMatrix3x3::ConvD (const TMatrix3x3< T > &u)
Convert TMatrix3x3<T> to TMatrix3x3<double>.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math4x4

Math4x4
[Math]

Classes

class | TMatrix4x4
Template class for 4x4 matrix. More...

Typedefs

typedef TMatrix4x4< double > | Matrix4x4d
typedef TMatrix4x4< float > | Matrix4x4f

Functions

TMatrix4x4< T_TO > | gml::TMatrix4x4::Conv (const TMatrix4x4< T_FROM > &u)
Convert TMatrix4x4<T_FROM> to TMatrix4x4<T_TO>.

TMatrix4x4< float > | gml::TMatrix4x4::ConvF (const TMatrix4x4< T > &u)
Convert TMatrix4x4<T> to TMatrix4x4<float>.

TMatrix4x4< double > | gml::TMatrix4x4::ConvD (const TMatrix4x4< T > &u)
Convert TMatrix4x4<T> to TMatrix4x4<double>.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math2

Math2
[Math]

Classes

class | BBox2
A template class for 2D boundary box. More...

class | TVector2
Template class for 2D vectors. More...

class | Math2
Comparison of 2D vectors with a tolerance. More...

Typedefs

typedef BBox2< double > | BBox2d
typedef BBox2< float > | BBox2f
typedef BBox2< int > | BBox2i
typedef TVector2< short > | Vector2s
typedef TVector2< int > | Vector2i
typedef TVector2< float > | Vector2f
typedef TVector2< double > | Vector2d
typedef Math2< float > | Math2f
typedef Math2< double > | Math2d

Functions

TVector2< T > | gml::TVector2::operator * (const double d, const TVector2< T > &u)
Multiplication of scalar d by TVector u.

double | gml::TVector2::SqrLength (const TVector2< T > &u)
Squared length of given vector.

double | gml::TVector2::Length (const TVector2< T > &u)
Length of the vector.

double | gml::TVector2::DotProd (const TVector2< T > &v1, const TVector2< T > &v2)
Dot product.

double | gml::TVector2::DotProduct (const TVector2< T > &v1, const TVector2< T > &v2)
Dot product.

double | gml::TVector2::CrossProd (const TVector2< T > &v1, const TVector2< T > &v2)
Cross product.

double | gml::TVector2::CrossProduct (const TVector2< T > &v1, const TVector2< T > &v2)
Cross product.

double | gml::TVector2::Cos (const TVector2< T > &a, const TVector2< T > &b)
cos between two vectors

double | gml::TVector2::Sin (const TVector2< T > &a, const TVector2< T > &b)
sin between two vectors

TVector2< T_TO > | gml::TVector2::Conv (const TVector2< T_FROM > &u)
Convert TVector2<T_FROM> to TVector2<T_TO>.

TVector2< float > | gml::TVector2::ConvF (const TVector2< T > &u)
Convert TVector2<T> to TVector2<float>.

TVector2< double > | gml::TVector2::ConvD (const TVector2< T > &u)
Convert TVector2<T> to TVector2<double>.

TVector2< int > | gml::TVector2::ConvI (const TVector2< T > &u)
Convert TVector2<T> to TVector2<int>.

TVector2< short > | gml::TVector2::ConvS (const TVector2< T > &u)
Convert TVector2<T> to TVector2<int>.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math3

Math3
[Math]

Classes

class | BBox3
A template class for 2D boundary box. More...

class | BSphere3
Template class for 3D bounding sphere. More...

class | TVector3
Template class for 3D geometric vectors. More...

class | Math3
Comparison of 2D vectors with a tolerance. More...

Typedefs

typedef BBox3< double > | BBox3d
typedef BBox3< float > | BBox3f
typedef BBox3< int > | BBox3i
typedef BSphere3< float > | BSphere3f
typedef BSphere3< double > | BSphere3d
typedef TVector3< short > | Vector3s
typedef TVector3< int > | Vector3i
typedef TVector3< float > | Vector3f
typedef TVector3< double > | Vector3d
typedef Math3< float > | Math3f
typedef Math3< double > | Math3d

Functions

template<class T_FROM> BBox3< double > | ConvD (const BBox3< T_FROM > &u)
template<class T_FROM> BBox3< float > | ConvF (const BBox3< T_FROM > &u)
TVector3< T > | gml::TVector3::operator * (const double d, const TVector3< T > &u)
Multiplication of scalar d by TVector u.

double | gml::TVector3::SqrLength (const TVector3< T > &u)
Squared length of given vector.

double | gml::TVector3::Length (const TVector3< T > &u)
Length of the vector.

double | gml::TVector3::DotProduct (const TVector3< T > &v1, const TVector3< T > &v2)
Dot product.

TVector3< T > | gml::TVector3::CrossProduct (const TVector3< T > &v1, const TVector3< T > &v2)
Cross product.

double | gml::TVector3::Cos (const TVector3< T > &a, const TVector3< T > &b)
cos between two vectors

double | gml::TVector3::Sin (const TVector3< T > &a, const TVector3< T > &b)
sin between two vectors

TVector3< T_TO > | gml::TVector3::Conv (const TVector3< T_FROM > &u)
Convert TVector3<T_FROM> to TVector3<T_TO>.

TVector3< float > | gml::TVector3::ConvF (const TVector3< T > &u)
Convert TVector3<T> to TVector3<float>.

TVector3< double > | gml::TVector3::ConvD (const TVector3< T > &u)
Convert TVector3<T> to TVector3<double>.

TVector3< int > | gml::TVector3::ConvI (const TVector3< T > &u)
Convert TVector3<T> to TVector3<int>.

TVector3< short > | gml::TVector3::ConvS (const TVector3< T > &u)
Convert TVector3<T> to TVector3<int>.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math4

Math4
[Math]

Classes

class | TVector4
Template class for 4D geometric vectors. More...

class | Math4
Comparison of 4D vectors with a tolerance. More...

Typedefs

typedef TVector4< short > | Vector4s
typedef TVector4< int > | Vector4i
typedef TVector4< float > | Vector4f
typedef TVector4< double > | Vector4d
typedef Math4< float > | Math4f
typedef Math4< double > | Math4d

Functions

TVector4< T > | gml::TVector4::operator * (const double d, const TVector4< T > &u)
Multiplication of scalar d by TVector u.

double | gml::TVector4::SqrLength (const TVector4< T > &u)
Squared length of given vector.

double | gml::TVector4::Length (const TVector4< T > &u)
Length of the vector.

double | gml::TVector4::DotProduct (const TVector4< T > &v1, const TVector4< T > &v2)
Dot product.

TVector4< T_TO > | gml::TVector4::Conv (const TVector4< T_FROM > &u)
Convert TVector4<T_FROM> to TVector4<T_TO>.

TVector4< float > | gml::TVector4::ConvF (const TVector4< T > &u)
Convert TVector4<T> to TVector4<float>.

TVector4< double > | gml::TVector4::ConvD (const TVector4< T > &u)
Convert TVector4<T> to TVector4<double>.

TVector4< int > | gml::TVector4::ConvI (const TVector4< T > &u)
Convert TVector4<T> to TVector4<int>.

TVector4< short > | gml::TVector4::ConvS (const TVector4< T > &u)
Convert TVector4<T> to TVector4<int>.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Net

Net

Classes

class Socket
A wrapper for Win32 stream socket. More...

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Utils3D

Utils3D

Classes

class | ModeBrowser
class | TrackballBrowser
class | WalkBrowser
class | Browser
3D navigation helper class More...

class | Camera
Class representing 3d virtual camera. More...

class | FrameCounter
Simple frame rate (FPS) counter. More...

class | Viewport
Class representing 3d viewport (a window with accociated camera). More...

Functions

void | CalculateClipPlanes (const Viewport &view, const BBox3d &domain, double &p_near, double &p_far)
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: UtilsGL

UtilsGL

Classes

class | GLRC
OpenGL context handling
Attention:
Include windows.h before using this file! Usage:
  GLRC glrc;
  // inside window creation
  glrc.Create(wnd);
  // before rendering into window
  glrc.MakeCurrent();
  // ...
  // display in the screen (in case of double buffering)
  glrc.SwapBuffers();
  // ..
  // delete gl context (may be avoided, because called in destructor anyway)
  glrc.Destroy();
.
More...

class | GLRC
OpenGL context handling
Attention:
Include windows.h before using this file! Usage:
  GLRC glrc;
  // inside window creation
  glrc.Create(wnd);
  // before rendering into window
  glrc.MakeCurrent();
  // ...
  // display in the screen (in case of double buffering)
  glrc.SwapBuffers();
  // ..
  // delete gl context (may be avoided, because called in destructor anyway)
  glrc.Destroy();
.
More...

Functions

int | gml::InitGLExtensions (const char *origReqExts)
Return 1 if all extensions listed in origReqExts are supported by GL implementation.

const char * | gml::GetUnsupportedGLExtensions ()
Return a list of unsupported extensions (should be called after InitGLExtensions).

void | RenderBBox (const gml::BBox3f &bbox, const gml::ColorRGBAf &color)

Function Documentation

int InitGLExtensions ( const char * origReqExts )

Return 1 if all extensions listed in origReqExts are supported by GL implementation.

Extensions should be separated with spaces, like "GL_ARB_multitexture " "GL_NV_evaluators " "GL_NV_texture_shader "

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: File Member Index

Here is a list of all documented file members with links to the documentation:

  • ASSERT : gmlcommon.h
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Todo List

Todo List

Class FileFinder
: add directory structure handling

Class GLRC
Add possibility to select pixel format (double/single buffer, stencil, etc)
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Deprecated List

Deprecated List

Member ColorRGBub
use Color3 instead

Member ColorRGBw
use Color3 instead

Member ColorRGBf
use Color3 instead

Member ColorRGBAub
use Color3 instead

Member ColorRGBAf
use Color3 instead

Member DotProd (const TVector2< T > &v1, const TVector2< T > &v2)
use use DotProduct instead

Member CrossProd (const TVector2< T > &v1, const TVector2< T > &v2)
use CrossProduct instead
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Annotated Index

Graphics and Media Lab CSL Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
BBox2 | A template class for 2D boundary box
BBox3 | A template class for 2D boundary box
Browser | 3D navigation helper class
BSphere3 | Template class for 3D bounding sphere
Callback | Base class for callback with no arguments and no return value
Camera | Class representing 3d virtual camera
CIniFile | Handling of INI-files
DIntelImage | Intel libraries IplImage wrap class
DrawSurface | Generic image class
File | A class for working with files (a wrapped to FILE *)
FileFinder
FilterGrayscale | Creates a grayscale version of a color bitmap
FilterLum2RGB | Creates a Lum2RGB version of a color bitmap
FilterMedianBlur | Creates a MedianBlur version of a color bitmap
FilterRepres | Transferres between different representations
FilterResize | Creates a MedianBlur version of a color bitmap
FilterRGB2BGR | Creates a Lum2RGB version of a color bitmap
FilterRGB2RGBA | Creates a grayscale version of a color bitmap
FrameCounter | Simple frame rate (FPS) counter
FRImageLoader | Image loader based on FreeImage third-party library
GDIImage | Manipulates uncompressed device- and platform-independent bitmaps
GDISurface | Generic image class
GLRC OpenGL context handling
Attention:
Include windows.h before using this file! Usage:
  GLRC glrc;
  // inside window creation
  glrc.Create(wnd);
  // before rendering into window
  glrc.MakeCurrent();
  // ...
  // display in the screen (in case of double buffering)
  glrc.SwapBuffers();
  // ..
  // delete gl context (may be avoided, because called in destructor anyway)
  glrc.Destroy();
Image | Generic image class
ImageComposer | Produce single image from several reference images
ImageDecomposer | Decompose an image into several destination images
ImageFilter | Interface for generic image modifier
ImageLoader | Loading and saving bitmaps to files (base class)
IntelImage | Manipulates uncompressed device- and platform-independent bitmaps
IntelSurface | Generic image class
Math | A template class for precision related staff
Math2 | Comparison of 2D vectors with a tolerance
Math3 | Comparison of 2D vectors with a tolerance
Math4 | Comparison of 4D vectors with a tolerance
PathString | Processing of the path to file
Ref Smart pointer class Smart pointers provide automatic memory management, so that programmer never cares on freeing memory. Smart pointers mechanism frees an object when there are no any references to it. Smart pointers should be used instead of standard C pointers:
  Object* obj; // standard pointer, should be deleted after use
  gml::Ref<Object> obj; // smart pointer frees memory when necessary
Attention:
Smart pointers works only with objects that support AddRef() and Release() operations. It is assumed that object keeps a reference count (a number of smapt pointers pointing to it). This reference count is incremented in AddRef() command and decremented in Release(). Also Release() performs check whether reference count is 0 and calls 'delete this'. GML provides special base class for this: gml::SmartObject. If you want to use smart pointers either derive your object from this class or provide own implementation of AddRef() and Release() methods. 1) initialization Smart pointers are initiliazed just like the standard pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);

Smart pointers must never be defined like this: gml::Rev<Object>* obj; !!! 2) use of smart pointers Smart pointers are dereferenced like normal pointers:

  gml::Ref<Object> obj =  new Object(1,2,3);
  obj->SomeMethod();
  (*obj).SomeMethod();
3) smart pointers as parameters Smart pointers are implicitly casted to normal pointers:
  gml::Ref<Object> obj =  new Object(1,2,3);
  Object* obj1 =  obj;
This operation is dangerous unless used properly. You should use it like follows. Smart pointers may be passed to functions and returned from functions like normal pointers.
  ...
  Object* SomeMethod(Object* obj);
  ...
  gml::Ref<Object> obj =  new Object(1,2,3);
  gml::Ref<Object> obj1 = SomeMethod(obj);
The general rule is this: Use ONLY smart pointers when storing objects. Use normals pointers when passing smart pointers as parameters or return values So the following is forbidden:
  class SomeClass
    {
    private:
      Object* obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        } // at this point obj will be deleted, and m_obj will be undefined!!
    };
Correct use:
  class SomeClass
    {
    private:
      gml::Ref<Object> obj;
    public:
      void CreateObject()
        {
        gml::Ref<Object> obj = new Object(1,2,3);
        m_obj = obj;
        }
    };
ReflectFilter | Creates a grayscale version of a color bitmap
SetRectFilter | Creates a grayscale version of a color bitmap
SimpleImage | Manipulates uncompressed device- and platform-independent bitmaps
SimpleImageLoader | Image loader based on FreeImage third-party library
SmartObject | Base class for objects with support for reference counting
Socket | A wrapper for Win32 stream socket
String | Standard string with some extensions
TColor3 | 3 Color repsentation
TColor4 | 4 Color repsentation
TMatrix2x2 | Template class for 2x2 matrix
TMatrix3x3 | Template class for 3x3 matrix
TMatrix4x4 | Template class for 4x4 matrix
TQuaternion | Quaternion template
TVector2 | Template class for 2D vectors
TVector3 | Template class for 3D geometric vectors
TVector4 | Template class for 4D geometric vectors
Viewport | Class representing 3d viewport (a window with accociated camera)
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

DIntelImage Member List

This is the complete list of members for DIntelImage, including all inherited members.
AttachImage(IplImage *in_pImage) | DIntelImage |
CheckImage(int width, int height, int in_iChannels) | DIntelImage | [inline]
CloneImage(IplImage *in_pImage) | DIntelImage |
CopyOf(DIntelImage &in_Image, int desired_color=-1) | DIntelImage |
CopyToSimpleImage() (defined in DIntelImage) | DIntelImage |
CreateImage(int width, int height, int depth=IPL_DEPTH_8U, int nChannels=3) | DIntelImage |
DeleteImages() | DIntelImage |
DetachImage() | DIntelImage |
DIntelImage(DIntelImage &) | DIntelImage | [protected]
DIntelImage() | DIntelImage |
DrawImage(CDC *in_pDC, CPoint in_vOrigin, float in_dRatio) | DIntelImage |
DrawImage(CDC *in_pDC, CPoint in_vOrigin, int in_iHeight=-1) | DIntelImage |
DrawImage(CDC *in_pDC, gml::BBox2i in_SrcBox, gml::BBox2i in_TrgBox) | DIntelImage |
DrawImage(Graphics::TBitmap *in_pTarget, TPoint in_vOrigin, float in_dRatio=1) | DIntelImage |
GetImage() | DIntelImage | [inline]
GetLineFast(int in_iLine) | DIntelImage | [inline]
GetLineSafe(int in_iLine) | DIntelImage | [inline]
height() | DIntelImage | [inline]
LoadImage(const char *in_sFileName) | DIntelImage |
m_pImage | DIntelImage | [protected]
operator=(DIntelImage &) | DIntelImage | [protected]
SaveImage(const char *in_sFileName) | DIntelImage |
step() | DIntelImage | [inline]
width() | DIntelImage | [inline]
~DIntelImage() | DIntelImage | [virtual]
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

BBox2 Member List

This is the complete list of members for BBox2, including all inherited members.
BBox2() | BBox2 | [inline]
BBox2(const TVector2< T > &point) | BBox2 | [inline]
BBox2(const TVector2< T > &point1, const TVector2< T > &point2) | BBox2 | [inline]
BBox2(const tagRECT &p) (defined in BBox2) | BBox2 | [inline]
Center() const | BBox2 | [inline]
Diag() const | BBox2 | [inline]
ExpandBy(const T &in_Value) | BBox2 | [inline]
ExpandBy(const T &in_HValue, const T &in_VValue) | BBox2 | [inline]
Height() const | BBox2 | [inline]
Include(const TVector2< T > &point) | BBox2 | [inline]
Include(const TVector2< T > *points, int npoints) | BBox2 | [inline]
Include(const BBox2< T > &box) | BBox2 | [inline]
Include(const BBox2< T > *bboxes, int nbboxes) | BBox2 | [inline]
Includes(const TVector2< T > &point) const | BBox2 | [inline]
Includes(const BBox2< T > &box) const | BBox2 | [inline]
Intersect(const BBox2< T > &box) | BBox2 | [inline]
Intersects(const BBox2< T > &box) const | BBox2 | [inline]
IsDot() const | BBox2 | [inline]
NotEmpty() const | BBox2 | [inline]
operator CvRect() (defined in BBox2) | BBox2 | [inline]
operator tagRECT() (defined in BBox2) | BBox2 | [inline]
operator=(const tagRECT &p) (defined in BBox2) | BBox2 | [inline]
SetRect(const T &in_Left, const T &in_Top, const T &in_Right, const T &in_Bottom) | BBox2 | [inline]
Translate(const TVector2< T > &vct) | BBox2 | [inline]
Translated(const TVector2< T > &vct) const | BBox2 | [inline]
vmax | BBox2 |
vmin | BBox2 |
Volume() const | BBox2 | [inline]
Width() const | BBox2 | [inline]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

BBox3 Member List

This is the complete list of members for BBox3, including all inherited members.
BBox3() | BBox3 | [inline]
BBox3(const TVector3< T > &point) | BBox3 | [inline]
BBox3(const TVector3< T > &point1, const TVector3< T > &point2) | BBox3 | [inline]
Center() const | BBox3 | [inline]
Diag() const | BBox3 | [inline]
ExpandBy(const T &in_Value) | BBox3 | [inline]
ExpandBy(const TVector3< T > &expand_vec) | BBox3 | [inline]
Include(const TVector3< T > &point) | BBox3 | [inline]
Include(const TVector3< T > *points, int npoints) | BBox3 | [inline]
Include(const BBox3< T > &box) | BBox3 | [inline]
Include(const BBox3< T > *bboxes, int nbboxes) | BBox3 | [inline]
Includes(const TVector3< T > &point) const | BBox3 | [inline]
Includes(const BBox3< T > &box) const | BBox3 | [inline]
Intersect(const BBox3< T > &box) | BBox3 | [inline]
Intersects(const BBox3< T > &box) const | BBox3 | [inline]
IsDot() const | BBox3 | [inline]
NotEmpty() const | BBox3 | [inline]
Translate(const TVector3< T > &vct) | BBox3 | [inline]
Translated(const TVector3< T > &vct) const | BBox3 | [inline]
vmax | BBox3 |
vmin | BBox3 |
Volume() const | BBox3 | [inline]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

BSphere3 Member List

This is the complete list of members for BSphere3, including all inherited members.
BSphere3() | BSphere3 | [inline]
BSphere3(const TVector3< T > &center0, const double radius0=0) | BSphere3 | [inline]
BSphere3(const BBox3< T > &bbox) | BSphere3 | [inline]
center | BSphere3 |
Include(const TVector3< T > &point) | BSphere3 | [inline]
Include(const BSphere3 &bsphere) | BSphere3 | [inline]
radius | BSphere3 |
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Browser Member List

This is the complete list of members for Browser, including all inherited members.
Browser(Viewport &viewport) (defined in Browser) | Browser |
GetDomain() const (defined in Browser) | Browser | [inline]
GetModeBrowser() (defined in Browser) | Browser | [inline]
KeyDown(int key, int options) (defined in Browser) | Browser | [inline]
KeyUp(int key, int options) (defined in Browser) | Browser | [inline]
MouseButton(const Vector2i &pos, int button, bool pressed) (defined in Browser) | Browser | [inline]
MouseMotion(const Vector2i &pos, int button) (defined in Browser) | Browser | [inline]
MousePassiveMotion(const Vector2i &pos) (defined in Browser) | Browser | [inline]
MouseWheel(const Vector2i &pos, int delta) (defined in Browser) | Browser | [inline]
NAV_MODE enum name (defined in Browser) | Browser |
NAV_TRACKBALL enum value (defined in Browser) | Browser |
NAV_WALK enum value (defined in Browser) | Browser |
SetDomain(const BBox3f &scene_size, bool update_position=true) (defined in Browser) | Browser | [inline]
SetNavigationMode(NAV_MODE nav_mode) (defined in Browser) | Browser | [inline]
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

CIniFile Member List

This is the complete list of members for CIniFile, including all inherited members.
CIniFile() | CIniFile |
CIniFile(const char *inipath) | CIniFile |
DeleteKey(const char *keyname) | CIniFile |
DeleteValue(const char *keyname, const char *valuename) | CIniFile |
error | CIniFile |
GetNumKeys() | CIniFile |
GetNumValues(const char *keyname) | CIniFile |
GetValue(const char *keyname, const char *valuename) | CIniFile |
GetValue(const char *keyname, const char *valuename, char *out_pcBuf, int in_iMaxChar) | CIniFile |
GetValueF(const char *keyname, const char *valuename) | CIniFile |
GetValueI(const char *keyname, const char *valuename) | CIniFile |
IsSuchKeyInFile(const char *key) (defined in CIniFile) | CIniFile | [inline]
IsSuchNameInThisKey(const char *key, const char *name) (defined in CIniFile) | CIniFile | [inline]
ReadFile() | CIniFile |
Reset() | CIniFile |
SetPath(const char *newpath) | CIniFile |
SetValue(const char *key, const char *valuename, const char *value, bool create=1) | CIniFile |
SetValueF(const char *key, const char *valuename, double value, bool create=1) | CIniFile |
SetValueI(const char *key, const char *valuename, int value, bool create=1) | CIniFile |
WriteFile() | CIniFile |
~CIniFile() | CIniFile | [virtual]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Callback Member List

This is the complete list of members for Callback, including all inherited members.
Call()=0 (defined in Callback) | Callback | [pure virtual]
Call() const | Callback | [inline]
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Camera Member List

This is the complete list of members for Camera, including all inherited members.
Camera() (defined in Camera) | Camera | [inline]
GetDistanceToTarget() const | Camera | [inline]
GetObserver() const (defined in Camera) | Camera | [inline]
GetRightVector() const | Camera | [inline]
GetRotation() const (defined in Camera) | Camera | [inline]
GetTransform() const | Camera | [inline]
GetUpVector() const | Camera | [inline]
GetViewAngle() const | Camera | [inline]
GetViewVector() const | Camera | [inline]
m_inv_view_transform | Camera | [protected]
m_target_distance | Camera | [protected]
m_view_angle | Camera | [protected]
m_view_transform | Camera | [protected]
SetDistanceToTarget(float target_distance) | Camera | [inline]
SetObserver(const Vector3d &obs) (defined in Camera) | Camera | [inline]
SetRotation(const Matrix4x4d &rot) (defined in Camera) | Camera | [inline]
SetTransform(const Matrix4x4d &view_transform) | Camera | [inline]
SetViewAngle(float view_angle) | Camera | [inline]
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

DrawSurface Member List

This is the complete list of members for DrawSurface, including all inherited members.
AddRef() | SmartObject | [inline]
Circle(int in_iX0, int in_iY0, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
Circle(gml::Vector2i in_vCenter, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
DrawLine(int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
DrawLine(gml::Vector2i in_vStart, gml::Vector2i in_vEnd, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
DrawSurface() | DrawSurface |
FrameRect(int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
FrameRect(gml::Vector2i in_vMin, gml::Vector2i in_vMax, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
PolyGon(gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
PolyLine(gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255))=0 (defined in DrawSurface) | DrawSurface | [pure virtual]
Release() | SmartObject | [inline]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
~DrawSurface() | DrawSurface | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FRImageLoader Member List

This is the complete list of members for FRImageLoader, including all inherited members.
CheckBitMapFile(const std::string &path) (defined in FRImageLoader) | FRImageLoader | [virtual]
EnumerateLoadableFormats(void(*f)(IMAGE_FORMAT f)) (defined in FRImageLoader) | FRImageLoader | [virtual]
EnumerateSaveableFormats(void(*f)(IMAGE_FORMAT f)) (defined in FRImageLoader) | FRImageLoader | [virtual]
FORMAT_BMP enum value (defined in ImageLoader) | ImageLoader |
FORMAT_ICO enum value (defined in ImageLoader) | ImageLoader |
FORMAT_JPEG enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PGM enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PGMRAW enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PNG enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PPM enum value (defined in ImageLoader) | ImageLoader |
FORMAT_TARGA enum value (defined in ImageLoader) | ImageLoader |
FORMAT_TIFF enum value (defined in ImageLoader) | ImageLoader |
FORMAT_UNKNOWN enum value (defined in ImageLoader) | ImageLoader |
GetFormatExtension(IMAGE_FORMAT format) | ImageLoader | [static]
IMAGE_FORMAT enum name (defined in ImageLoader) | ImageLoader |
LoadBitMap(const std::string &path, Image &out_bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int flags=0) (defined in FRImageLoader) | FRImageLoader | [virtual]
SaveBitMap(const std::string &path, const Image &bitmap, IMAGE_FORMAT format, int flags=0) (defined in FRImageLoader) | FRImageLoader | [virtual]
SaveBitMap(const std::string &path, const Image &bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int in_iQuality=100, int flags=0)=0 (defined in ImageLoader) | ImageLoader | [pure virtual]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

File Member List

This is the complete list of members for File, including all inherited members.
Close() | File |
Copy(const PathString &name_from, const PathString &name_to) (defined in File) | File | [static]
fd (defined in File) | File | [protected]
File(const PathString &full_pathname) | File |
File(const File &file) | File |
FilePos() const | File |
FileSize() const | File |
Flush() (defined in File) | File |
IsError() (defined in File) | File |
MODE_BINARY enum value (defined in File) | File | [protected]
MODE_READ enum value (defined in File) | File | [protected]
MODE_READ_WRITE enum value (defined in File) | File | [protected]
mode_rw (defined in File) | File | [protected]
mode_tb (defined in File) | File | [protected]
MODE_TEXT enum value (defined in File) | File | [protected]
MODE_WRITE enum value (defined in File) | File | [protected]
Open(const char *mode) | File |
Opened() const | File | [inline]
PathName() const (defined in File) | File | [inline]
Printf(const char *format,...) (defined in File) | File |
Read(BYTE *out_buff, int len_buff, int &out_size) (defined in File) | File |
ReadStr(String &out_buff, int len_buff, bool *out_nl=NULL) (defined in File) | File |
ReadStr(char *out_buff, int len_buff, bool *out_nl=NULL) (defined in File) | File |
ReadStr(String &out_buff) (defined in File) | File |
Remove() (defined in File) | File |
Rename(const PathString &new_file_name) (defined in File) | File |
Seek(long offset) (defined in File) | File |
SeekCur(long offset) (defined in File) | File |
SeekEnd(long offset) (defined in File) | File |
Write(const BYTE *buff, int size) (defined in File) | File |
WriteStr(const String &str) (defined in File) | File |
WriteStr(const char *out_buff,...) (defined in File) | File |
~File() | File |
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FileFinder Member List

This is the complete list of members for FileFinder, including all inherited members.
FileFinder() (defined in FileFinder) | FileFinder |
FileFinder(const FileFinder &right) (defined in FileFinder) | FileFinder | [protected]
FindFiles(const char *filefilter="*", const gml::PathString &="", int recursionlevel=-1) | FileFinder |
GetCompleteFileList() (defined in FileFinder) | FileFinder |
GetStartDir() (defined in FileFinder) | FileFinder |
operator=(const FileFinder &right) (defined in FileFinder) | FileFinder | [protected]
~FileFinder() (defined in FileFinder) | FileFinder | [virtual]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterGrayscale Member List

This is the complete list of members for FilterGrayscale, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | FilterGrayscale | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
FilterGrayscale() (defined in FilterGrayscale) | FilterGrayscale |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
M_AVERAGE enum value (defined in FilterGrayscale) | FilterGrayscale |
M_B enum value (defined in FilterGrayscale) | FilterGrayscale |
M_EYE enum value (defined in FilterGrayscale) | FilterGrayscale |
M_G enum value (defined in FilterGrayscale) | FilterGrayscale |
M_R enum value (defined in FilterGrayscale) | FilterGrayscale |
METHOD enum name | FilterGrayscale |
SetMethod(METHOD m) (defined in FilterGrayscale) | FilterGrayscale | [inline]
~FilterGrayscale() (defined in FilterGrayscale) | FilterGrayscale | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterLum2RGB Member List

This is the complete list of members for FilterLum2RGB, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | FilterLum2RGB | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
FilterLum2RGB() (defined in FilterLum2RGB) | FilterLum2RGB |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
~FilterLum2RGB() (defined in FilterLum2RGB) | FilterLum2RGB | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterMedianBlur Member List

This is the complete list of members for FilterMedianBlur, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | FilterMedianBlur | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
FilterMedianBlur() (defined in FilterMedianBlur) | FilterMedianBlur |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
SetRadius(int r) (defined in FilterMedianBlur) | FilterMedianBlur | [inline, virtual]
~FilterMedianBlur() (defined in FilterMedianBlur) | FilterMedianBlur | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterRGB2BGR Member List

This is the complete list of members for FilterRGB2BGR, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | ImageFilter | [virtual]
ApplyInPlace(Image *pBmp) const | FilterRGB2BGR | [virtual]
FilterRGB2BGR() (defined in FilterRGB2BGR) | FilterRGB2BGR |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
~FilterRGB2BGR() (defined in FilterRGB2BGR) | FilterRGB2BGR | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterRGB2RGBA Member List

This is the complete list of members for FilterRGB2RGBA, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | FilterRGB2RGBA | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
FilterRGB2RGBA(const gml::Color3ub &in_Color=gml::Color3ub(255, 255, 255)) (defined in FilterRGB2RGBA) | FilterRGB2RGBA |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
SetTransparentColor(const gml::Color3ub &in_Color) (defined in FilterRGB2RGBA) | FilterRGB2RGBA |
~FilterRGB2RGBA() (defined in FilterRGB2RGBA) | FilterRGB2RGBA | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterRepres Member List

This is the complete list of members for FilterRepres, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | FilterRepres | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
FilterRepres(Image::REPRES in_Repres=Image::R_BYTE, double in_dCoeff=1, bool in_bClipTypeBounds=true) (defined in FilterRepres) | FilterRepres |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
SetParam(Image::REPRES in_Repres=Image::R_BYTE, double in_dCoeff=1, bool in_bClipTypeBounds=true) (defined in FilterRepres) | FilterRepres |
~FilterRepres() (defined in FilterRepres) | FilterRepres | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FilterResize Member List

This is the complete list of members for FilterResize, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | FilterResize | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
BILINEAR enum value (defined in FilterResize) | FilterResize |
FASTEST enum value (defined in FilterResize) | FilterResize |
FilterResize() (defined in FilterResize) | FilterResize |
FilterResize(int in_iDstWdt, int in_iDstHgt, RESIZE_TYPE in_Type) (defined in FilterResize) | FilterResize |
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
RESIZE_TYPE enum name (defined in FilterResize) | FilterResize |
SetResizeParam(int in_iDstWdt, int in_iDstHgt, RESIZE_TYPE in_Type) (defined in FilterResize) | FilterResize | [inline, virtual]
~FilterResize() (defined in FilterResize) | FilterResize | [virtual]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

FrameCounter Member List

This is the complete list of members for FrameCounter, including all inherited members.
FrameCounter() | FrameCounter |
FrameFinished() | FrameCounter |
FrameStarted() | FrameCounter |
GetFrameCount() const | FrameCounter |
GetMeanFrameTime() const | FrameCounter |
GetMinimumFrameCount() const | FrameCounter | [inline]
GetUpdateSpeed() const | FrameCounter | [inline]
Reset() | FrameCounter |
SetMinimumFrameCount(int count) | FrameCounter | [inline]
SetUpdateSpeed(double ms) | FrameCounter | [inline]
Updated() const | FrameCounter |
~FrameCounter() | FrameCounter |
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

GDIImage Member List

This is the complete list of members for GDIImage, including all inherited members.
AddRef() | SmartObject | [inline]
AlmostEqual(const Image &Bmp, int epsilon) const (defined in Image) | Image |
ApplyFilter(const ImageFilter &filter) | Image |
ChangeFormat(FORMAT new_format) | Image |
ChangeOrientation(ORIENT new_orient) | Image |
ChangeRepres(REPRES new_repres) | Image |
Clear() (defined in Image) | Image |
ConstructorInitLocals() (defined in GDIImage) | GDIImage | [protected, virtual]
Create(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [virtual]
CreateComposition(const std::vector< Image * > &src, const ImageComposer &comp) (defined in Image) | Image |
CreateCopy(const Image &rSrImage) | Image |
Created() const (defined in Image) | Image |
CreateFilteredCopy(const Image &rSrImage, const ImageFilter &rFilter) | Image |
CreateFromDIB(struct tagBITMAPINFO *in_pDIB, BYTE *in_pcData=NULL) | Image |
Decompose(const ImageDecomposer &decomposer, std::vector< Image * > &out_res) | Image |
ElemSize(FORMAT f, REPRES r) (defined in Image) | Image | [inline, static]
F_BGR enum value (defined in Image) | Image |
F_L enum value (defined in Image) | Image |
F_RGB enum value (defined in Image) | Image |
F_RGBA enum value (defined in Image) | Image |
FastResizeImage(double in_dScale, gml::GDIImage &out_ResImg) | GDIImage | [virtual]
FORMAT enum name (defined in Image) | Image |
Format2Channels(FORMAT f) (defined in Image) | Image | [inline, static]
FreeMembers() | GDIImage | [protected, virtual]
GDIImage() | GDIImage |
GDIImage(const Image &Orig) | GDIImage | [inline]
GDIImage(const GDIImage &Orig) | GDIImage | [inline]
GDISurface (defined in GDIImage) | GDIImage | [friend]
GetBytesPerLine() const | GDIImage | [inline, virtual]
GetBytesPerLine(int width, FORMAT f, REPRES r) (defined in GDIImage) | GDIImage | [protected, static]
GetDrawSurface() | GDIImage | [virtual]
GetElemSize() const (defined in Image) | Image | [inline]
GetFormat() const (defined in Image) | Image | [inline]
GetHeight() const (defined in Image) | Image | [inline]
GetLineArray() const | Image | [inline]
GetMemUsed() | GDIImage | [virtual]
GetOrient() const (defined in Image) | Image | [inline]
GetRawData() const (defined in GDIImage) | GDIImage | [inline]
GetRawData() | GDIImage | [inline]
GetRepres() const (defined in Image) | Image | [inline]
GetWidth() const (defined in Image) | Image | [inline]
Image() | Image |
Image(Image &in_Image) (defined in Image) | Image |
InitLineArray() | GDIImage | [protected, virtual]
InitLocals(int width, int height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [protected]
InternalChangeOrientation(ORIENT new_orient) | GDIImage | [protected, virtual]
InternalCopy(const Image &rSrImage) | Image | [protected]
InternalCreate(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | GDIImage | [protected, virtual]
InternalPaint(HDC in_hDC, int in_iDstOrgX, int in_iDstOrgY, int in_iDstWdt, int in_iDstHgt, int in_iSrcOrgX, int in_iSrcOrgY, int in_iSrcWdt, int in_iSrcHgt, DWORD dwRop) (defined in GDIImage) | GDIImage | [protected, virtual]
IsLocked() const (defined in Image) | Image | [inline]
Lock(bool bReadable, bool bWriteable) | Image | [virtual]
m_BMInfo | GDIImage | [protected]
m_created (defined in Image) | Image | [protected]
m_format (defined in Image) | Image | [protected]
m_hBMP | GDIImage | [protected]
m_hDC | GDIImage | [protected]
m_height (defined in Image) | Image | [protected]
m_hOldHandle | GDIImage | [protected]
m_iBytesPerLine | GDIImage | [protected]
m_line_array | Image | [protected]
m_lock_count | Image | [protected]
m_orient | Image | [protected]
m_pBits | GDIImage | [protected]
m_pColorTable (defined in GDIImage) | GDIImage | [protected]
m_pPalette | GDIImage | [protected]
m_repres (defined in Image) | Image | [protected]
m_width (defined in Image) | Image | [protected]
O_BOTTOMLEFT enum value | Image |
O_TOPLEFT enum value | Image |
operator=(const Image &Orig) | GDIImage | [inline]
operator=(const GDIImage &Orig) (defined in GDIImage) | GDIImage | [inline]
operator==(Image const &Other) | Image |
ORIENT enum name | Image |
PaintImage(HDC in_hDC, DWORD dwRop=SRCCOPY) | GDIImage |
PaintImage(HDC in_hDC, POINT in_ptDstOrg, DWORD dwRop=SRCCOPY) | GDIImage |
PaintImage(HDC in_hDC, POINT in_ptDstOrg, SIZE in_DstSize, DWORD dwRop=SRCCOPY) | GDIImage |
PaintImage(CDC *in_pDC, CPoint dst_org, CSize dst_size, DWORD dwRop=SRCCOPY) (defined in Image) | Image |
PaintImageRect(HDC in_hDC, POINT in_ptDstOrg, RECT in_SrcRect, SIZE in_DstSize, DWORD dwRop=SRCCOPY) | GDIImage |
R_BYTE enum value (defined in Image) | Image |
R_DOUBLE enum value (defined in Image) | Image |
R_DWORD enum value (defined in Image) | Image |
R_FLOAT enum value (defined in Image) | Image |
R_WORD enum value (defined in Image) | Image |
Release() | SmartObject | [inline]
REPRES enum name (defined in Image) | Image |
Repres2Size(REPRES r) (defined in Image) | Image | [inline, static]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
Unlock() | Image | [virtual]
~GDIImage() | GDIImage | [virtual]
~Image() | Image | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

GDISurface Member List

This is the complete list of members for GDISurface, including all inherited members.
AddRef() | SmartObject | [inline]
Circle(int in_iX0, int in_iY0, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
Circle(gml::Vector2i in_vCenter, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
DrawLine(int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
DrawLine(gml::Vector2i in_vStart, gml::Vector2i in_vEnd, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
DrawSurface() | DrawSurface |
FrameRect(int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
FrameRect(gml::Vector2i in_vMin, gml::Vector2i in_vMax, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
GDISurface(gml::GDIImage *in_pImage) | GDISurface |
GetColor(gml::Color3ub in_Color) (defined in GDISurface) | GDISurface | [protected]
m_pImage (defined in GDISurface) | GDISurface | [protected]
PolyGon(gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
PolyLine(gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in GDISurface) | GDISurface | [virtual]
Release() | SmartObject | [inline]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
~DrawSurface() | DrawSurface | [virtual]
~GDISurface() | GDISurface | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

GLRC Member List

This is the complete list of members for GLRC, including all inherited members.
Create() | GLRC | [virtual]
Destroy() | GLRC |
GLRC(HWND wnd) | GLRC |
GLRC(HDC hdc) | GLRC |
IsCurrent() const | GLRC |
m_created | GLRC | [protected]
m_dc | GLRC | [protected]
m_glrc | GLRC | [protected]
m_wnd | GLRC | [protected]
MakeCurrent() | GLRC |
SwapBuffers() | GLRC |
~GLRC() | GLRC | [virtual]
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Image Member List

This is the complete list of members for Image, including all inherited members.
AddRef() | SmartObject | [inline]
AlmostEqual(const Image &Bmp, int epsilon) const (defined in Image) | Image |
ApplyFilter(const ImageFilter &filter) | Image |
ChangeFormat(FORMAT new_format) | Image |
ChangeOrientation(ORIENT new_orient) | Image |
ChangeRepres(REPRES new_repres) | Image |
Clear() (defined in Image) | Image |
Create(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [virtual]
CreateComposition(const std::vector< Image * > &src, const ImageComposer &comp) (defined in Image) | Image |
CreateCopy(const Image &rSrImage) | Image |
Created() const (defined in Image) | Image |
CreateFilteredCopy(const Image &rSrImage, const ImageFilter &rFilter) | Image |
CreateFromDIB(struct tagBITMAPINFO *in_pDIB, BYTE *in_pcData=NULL) | Image |
Decompose(const ImageDecomposer &decomposer, std::vector< Image * > &out_res) | Image |
ElemSize(FORMAT f, REPRES r) (defined in Image) | Image | [inline, static]
F_BGR enum value (defined in Image) | Image |
F_L enum value (defined in Image) | Image |
F_RGB enum value (defined in Image) | Image |
F_RGBA enum value (defined in Image) | Image |
FORMAT enum name (defined in Image) | Image |
Format2Channels(FORMAT f) (defined in Image) | Image | [inline, static]
FreeMembers()=0 | Image | [protected, pure virtual]
GetBytesPerLine() const =0 | Image | [pure virtual]
GetDrawSurface()=0 (defined in Image) | Image | [pure virtual]
GetElemSize() const (defined in Image) | Image | [inline]
GetFormat() const (defined in Image) | Image | [inline]
GetHeight() const (defined in Image) | Image | [inline]
GetLineArray() const | Image | [inline]
GetMemUsed()=0 (defined in Image) | Image | [pure virtual]
GetOrient() const (defined in Image) | Image | [inline]
GetRepres() const (defined in Image) | Image | [inline]
GetWidth() const (defined in Image) | Image | [inline]
Image() | Image |
Image(Image &in_Image) (defined in Image) | Image |
InitLineArray()=0 | Image | [protected, pure virtual]
InitLocals(int width, int height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [protected]
InternalChangeOrientation(ORIENT new_orient)=0 | Image | [protected, pure virtual]
InternalCopy(const Image &rSrImage) | Image | [protected]
InternalCreate(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT)=0 | Image | [protected, pure virtual]
IsLocked() const (defined in Image) | Image | [inline]
Lock(bool bReadable, bool bWriteable) | Image | [virtual]
m_created (defined in Image) | Image | [protected]
m_format (defined in Image) | Image | [protected]
m_height (defined in Image) | Image | [protected]
m_line_array | Image | [protected]
m_lock_count | Image | [protected]
m_orient | Image | [protected]
m_repres (defined in Image) | Image | [protected]
m_width (defined in Image) | Image | [protected]
O_BOTTOMLEFT enum value | Image |
O_TOPLEFT enum value | Image |
operator=(Image const &Orig) | Image | [inline]
operator==(Image const &Other) | Image |
ORIENT enum name | Image |
PaintImage(CDC *in_pDC, CPoint dst_org, CSize dst_size, DWORD dwRop=SRCCOPY) (defined in Image) | Image |
R_BYTE enum value (defined in Image) | Image |
R_DOUBLE enum value (defined in Image) | Image |
R_DWORD enum value (defined in Image) | Image |
R_FLOAT enum value (defined in Image) | Image |
R_WORD enum value (defined in Image) | Image |
Release() | SmartObject | [inline]
REPRES enum name (defined in Image) | Image |
Repres2Size(REPRES r) (defined in Image) | Image | [inline, static]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
Unlock() | Image | [virtual]
~Image() | Image | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

ImageComposer Member List

This is the complete list of members for ImageComposer, including all inherited members.
Apply(const std::vector< Image * > &source, Image *pBmpDest) const | ImageComposer | [virtual]
ImageComposer() (defined in ImageComposer) | ImageComposer | [inline]
~ImageComposer() (defined in ImageComposer) | ImageComposer | [inline, virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

ImageDecomposer Member List

This is the complete list of members for ImageDecomposer, including all inherited members.
Apply(Image *pBmpSource, std::vector< Image * > &out_dest) const | ImageDecomposer | [virtual]
ImageDecomposer() (defined in ImageDecomposer) | ImageDecomposer | [inline]
~ImageDecomposer() (defined in ImageDecomposer) | ImageDecomposer | [inline, virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

ImageFilter Member List

This is the complete list of members for ImageFilter, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | ImageFilter | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

ImageLoader Member List

This is the complete list of members for ImageLoader, including all inherited members.
CheckBitMapFile(const std::string &path)=0 (defined in ImageLoader) | ImageLoader | [pure virtual]
EnumerateLoadableFormats(void(*f)(IMAGE_FORMAT f))=0 (defined in ImageLoader) | ImageLoader | [pure virtual]
EnumerateSaveableFormats(void(*f)(IMAGE_FORMAT f))=0 (defined in ImageLoader) | ImageLoader | [pure virtual]
FORMAT_BMP enum value (defined in ImageLoader) | ImageLoader |
FORMAT_ICO enum value (defined in ImageLoader) | ImageLoader |
FORMAT_JPEG enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PGM enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PGMRAW enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PNG enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PPM enum value (defined in ImageLoader) | ImageLoader |
FORMAT_TARGA enum value (defined in ImageLoader) | ImageLoader |
FORMAT_TIFF enum value (defined in ImageLoader) | ImageLoader |
FORMAT_UNKNOWN enum value (defined in ImageLoader) | ImageLoader |
GetFormatExtension(IMAGE_FORMAT format) | ImageLoader | [static]
IMAGE_FORMAT enum name (defined in ImageLoader) | ImageLoader |
LoadBitMap(const std::string &path, Image &out_bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int flags=0)=0 (defined in ImageLoader) | ImageLoader | [pure virtual]
SaveBitMap(const std::string &path, const Image &bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int in_iQuality=100, int flags=0)=0 (defined in ImageLoader) | ImageLoader | [pure virtual]
Generated on Tue Jan 13 21:12:05 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

IntelImage Member List

This is the complete list of members for IntelImage, including all inherited members.
AddRef() | SmartObject | [inline]
AlmostEqual(const Image &Bmp, int epsilon) const (defined in Image) | Image |
ApplyFilter(const ImageFilter &filter) | Image |
ChangeFormat(FORMAT new_format) | Image |
ChangeOrientation(ORIENT new_orient) | Image |
ChangeRepres(REPRES new_repres) | Image |
Clear() (defined in Image) | Image |
ConstructorInitLocals() (defined in IntelImage) | IntelImage | [protected, virtual]
Create(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [virtual]
CreateComposition(const std::vector< Image * > &src, const ImageComposer &comp) (defined in Image) | Image |
CreateCopy(const Image &rSrImage) | Image |
Created() const (defined in Image) | Image |
CreateFilteredCopy(const Image &rSrImage, const ImageFilter &rFilter) | Image |
CreateFromDIB(struct tagBITMAPINFO *in_pDIB, BYTE *in_pcData=NULL) | Image |
Decompose(const ImageDecomposer &decomposer, std::vector< Image * > &out_res) | Image |
ElemSize(FORMAT f, REPRES r) (defined in Image) | Image | [inline, static]
F_BGR enum value (defined in Image) | Image |
F_L enum value (defined in Image) | Image |
F_RGB enum value (defined in Image) | Image |
F_RGBA enum value (defined in Image) | Image |
FORMAT enum name (defined in Image) | Image |
Format2Channels(FORMAT f) (defined in Image) | Image | [inline, static]
FreeMembers() | IntelImage | [protected, virtual]
GetBytesPerLine() const | IntelImage | [virtual]
GetDrawSurface() | IntelImage | [virtual]
GetElemSize() const (defined in Image) | Image | [inline]
GetFormat() const (defined in Image) | Image | [inline]
GetHeight() const (defined in Image) | Image | [inline]
GetImage() | IntelImage | [inline]
GetLineArray() const | Image | [inline]
GetMemUsed() | IntelImage | [virtual]
GetOrient() const (defined in Image) | Image | [inline]
GetRawData() const (defined in IntelImage) | IntelImage | [inline]
GetRawData() | IntelImage | [inline]
GetRepres() const (defined in Image) | Image | [inline]
GetWidth() const (defined in Image) | Image | [inline]
Image() | Image |
Image(Image &in_Image) (defined in Image) | Image |
InitLineArray() | IntelImage | [protected, virtual]
InitLocals(int width, int height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [protected]
IntelImage() | IntelImage |
IntelImage(const Image &Orig) | IntelImage | [inline]
IntelImage(const IntelImage &Orig) | IntelImage | [inline]
InternalChangeOrientation(ORIENT new_orient) | IntelImage | [protected, virtual]
InternalCopy(const Image &rSrImage) | Image | [protected]
InternalCreate(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | IntelImage | [protected, virtual]
IsLocked() const (defined in Image) | Image | [inline]
Lock(bool bReadable, bool bWriteable) | Image | [virtual]
m_created (defined in Image) | Image | [protected]
m_format (defined in Image) | Image | [protected]
m_height (defined in Image) | Image | [protected]
m_iBytesPerLine (defined in IntelImage) | IntelImage | [protected]
m_line_array | Image | [protected]
m_lock_count | Image | [protected]
m_orient | Image | [protected]
m_pBits (defined in IntelImage) | IntelImage | [protected]
m_pImage | IntelImage | [protected]
m_repres (defined in Image) | Image | [protected]
m_width (defined in Image) | Image | [protected]
O_BOTTOMLEFT enum value | Image |
O_TOPLEFT enum value | Image |
operator=(const Image &Orig) | IntelImage | [inline]
operator=(const IntelImage &Orig) (defined in IntelImage) | IntelImage | [inline]
operator==(Image const &Other) | Image |
ORIENT enum name | Image |
PaintImage(CDC *in_pDC, CPoint dst_org, CSize dst_size, DWORD dwRop=SRCCOPY) (defined in Image) | Image |
R_BYTE enum value (defined in Image) | Image |
R_DOUBLE enum value (defined in Image) | Image |
R_DWORD enum value (defined in Image) | Image |
R_FLOAT enum value (defined in Image) | Image |
R_WORD enum value (defined in Image) | Image |
Release() | SmartObject | [inline]
REPRES enum name (defined in Image) | Image |
Repres2Size(REPRES r) (defined in Image) | Image | [inline, static]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
Unlock() | Image | [virtual]
~Image() | Image | [virtual]
~IntelImage() | IntelImage | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

IntelSurface Member List

This is the complete list of members for IntelSurface, including all inherited members.
AddRef() | SmartObject | [inline]
Circle(int in_iX0, int in_iY0, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
Circle(gml::Vector2i in_vCenter, int in_iRadius, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
DrawLine(int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
DrawLine(gml::Vector2i in_vStart, gml::Vector2i in_vEnd, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
DrawSurface() | DrawSurface |
FrameRect(int in_iX0, int in_iY0, int in_iX1, int in_iY1, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
FrameRect(gml::Vector2i in_vMin, gml::Vector2i in_vMax, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
GetColor(gml::Color3ub in_Color) (defined in IntelSurface) | IntelSurface | [protected]
IntelSurface(gml::IntelImage *in_pImage) | IntelSurface |
m_pImage (defined in IntelSurface) | IntelSurface | [protected]
PolyGon(gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
PolyLine(gml::Vector2i *in_pVectors, int in_iPoints, Color3ub in_Color=Color3ub(255, 255, 255)) (defined in IntelSurface) | IntelSurface | [virtual]
Release() | SmartObject | [inline]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
~DrawSurface() | DrawSurface | [virtual]
~IntelSurface() | IntelSurface | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Math2 Member List

This is the complete list of members for Math2, including all inherited members.
AboutEqual(const TVector2< T > &v1, const TVector2< T > &v2, const double tolerance) (defined in Math2) | Math2 | [inline, static]
AboutEqual(const TVector2< T > &v1, const TVector2< T > &v2) (defined in Math2) | Math2 | [inline, static]
AboutEqual(const double v1, const double v2, const double tolerance) (defined in Math) | Math | [inline, static]
AboutEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
AboutZero(const TVector2< T > &v, const double tolerance) (defined in Math2) | Math2 | [inline, static]
AboutZero(const TVector2< T > &v) (defined in Math2) | Math2 | [inline, static]
gml::Math::AboutZero(const double v, const double tolerance) | Math | [inline, static]
AboutZero(const double v) (defined in Math) | Math | [inline, static]
EPSILON | Math | [static]
MAX_VALUE | Math | [static]
MIN_VALUE | Math | [static]
NearEqual(const TVector2< T > &v1, const TVector2< T > &v2) (defined in Math2) | Math2 | [inline, static]
NearEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
NearZero(const TVector2< T > &v) (defined in Math2) | Math2 | [inline, static]
NearZero(const double v) (defined in Math) | Math | [inline, static]
SignAbout(const double v, const double tolerance) | Math | [inline, static]
SignAbout(const double v) (defined in Math) | Math | [inline, static]
SignNear(const double v) (defined in Math) | Math | [inline, static]
TOLERANCE | Math | [static]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Math3 Member List

This is the complete list of members for Math3, including all inherited members.
AboutEqual(const TVector3< T > &v1, const TVector3< T > &v2, const double tolerance) (defined in Math3) | Math3 | [inline, static]
AboutEqual(const TVector3< T > &v1, const TVector3< T > &v2) (defined in Math3) | Math3 | [inline, static]
AboutEqual(const double v1, const double v2, const double tolerance) (defined in Math) | Math | [inline, static]
AboutEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
AboutZero(const TVector3< T > &v, const double tolerance) (defined in Math3) | Math3 | [inline, static]
AboutZero(const TVector3< T > &v) (defined in Math3) | Math3 | [inline, static]
gml::Math::AboutZero(const double v, const double tolerance) | Math | [inline, static]
AboutZero(const double v) (defined in Math) | Math | [inline, static]
EPSILON | Math | [static]
MAX_VALUE | Math | [static]
MIN_VALUE | Math | [static]
NearEqual(const TVector3< T > &v1, const TVector3< T > &v2) (defined in Math3) | Math3 | [inline, static]
NearEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
NearZero(const TVector3< T > &v) (defined in Math3) | Math3 | [inline, static]
NearZero(const double v) (defined in Math) | Math | [inline, static]
SignAbout(const double v, const double tolerance) | Math | [inline, static]
SignAbout(const double v) (defined in Math) | Math | [inline, static]
SignNear(const double v) (defined in Math) | Math | [inline, static]
TOLERANCE | Math | [static]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Math4 Member List

This is the complete list of members for Math4, including all inherited members.
AboutEqual(const TVector4< T > &v1, const TVector4< T > &v2, const double tolerance) (defined in Math4) | Math4 | [inline, static]
AboutEqual(const TVector4< T > &v1, const TVector4< T > &v2) (defined in Math4) | Math4 | [inline, static]
AboutEqual(const double v1, const double v2, const double tolerance) (defined in Math) | Math | [inline, static]
AboutEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
AboutZero(const TVector4< T > &v, const double tolerance) (defined in Math4) | Math4 | [inline, static]
AboutZero(const TVector4< T > &v) (defined in Math4) | Math4 | [inline, static]
gml::Math::AboutZero(const double v, const double tolerance) | Math | [inline, static]
AboutZero(const double v) (defined in Math) | Math | [inline, static]
EPSILON | Math | [static]
MAX_VALUE | Math | [static]
MIN_VALUE | Math | [static]
NearEqual(const TVector4< T > &v1, const TVector4< T > &v2) (defined in Math4) | Math4 | [inline, static]
NearEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
NearZero(const TVector4< T > &v) (defined in Math4) | Math4 | [inline, static]
NearZero(const double v) (defined in Math) | Math | [inline, static]
SignAbout(const double v, const double tolerance) | Math | [inline, static]
SignAbout(const double v) (defined in Math) | Math | [inline, static]
SignNear(const double v) (defined in Math) | Math | [inline, static]
TOLERANCE | Math | [static]
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Math Member List

This is the complete list of members for Math, including all inherited members.
AboutEqual(const double v1, const double v2, const double tolerance) (defined in Math) | Math | [inline, static]
AboutEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
AboutZero(const double v, const double tolerance) | Math | [inline, static]
AboutZero(const double v) (defined in Math) | Math | [inline, static]
EPSILON | Math | [static]
MAX_VALUE | Math | [static]
MIN_VALUE | Math | [static]
NearEqual(const double v1, const double v2) (defined in Math) | Math | [inline, static]
NearZero(const double v) (defined in Math) | Math | [inline, static]
SignAbout(const double v, const double tolerance) | Math | [inline, static]
SignAbout(const double v) (defined in Math) | Math | [inline, static]
SignNear(const double v) (defined in Math) | Math | [inline, static]
TOLERANCE | Math | [static]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

PathString Member List

This is the complete list of members for PathString, including all inherited members.
AsCString() const | String | [inline]
AsDouble() const | String | [inline]
AsInt() const | String | [inline]
Basename() const | PathString |
ChDir() const | PathString |
CheckMask(const PathString &mask) const (defined in PathString) | PathString | [protected]
CorrectSeparators() (defined in PathString) | PathString | [protected]
CurDir() | PathString |
ExePath() | PathString |
Extension() const | PathString |
Filename() const | PathString |
Format(const char *format,...) | String |
FormatV(const char *format, va_list arglist) | String |
IsDir() const | PathString |
IsFile() const | PathString |
ListFileName(list< PathString > &filelist, PathString *mask) const | PathString |
MakeFullPath(const PathString &relative_to=PathString()) | PathString |
MkDir() const | PathString |
Path() const | PathString |
PATH_SEPARATOR | PathString | [static]
PATH_SEPARATOR_STR | PathString | [static]
PathString() (defined in PathString) | PathString | [inline]
PathString(const string &rhs) (defined in PathString) | PathString | [inline]
PathString(const string &rhs, size_type pos, size_type n) (defined in PathString) | PathString | [inline]
PathString(const char *s, size_type n) (defined in PathString) | PathString | [inline]
PathString(const char *s) (defined in PathString) | PathString | [inline]
PathString(size_type n, char c) (defined in PathString) | PathString | [inline]
PathString(const_iterator first, const_iterator last) (defined in PathString) | PathString | [inline]
PathString(const string &path, const string &filename, const string &extension=string()) | PathString |
RmDir() const | PathString |
Split(string *path, string *filename, string *extension=NULL) const | PathString |
String() | String | [inline]
String(const string &rhs) | String | [inline]
String(const string &rhs, size_type pos, size_type n) | String | [inline]
String(const char *s, size_type n) | String | [inline]
String(const char *s) | String | [inline]
String(size_type n, char c) | String | [inline]
String(const_iterator first, const_iterator last) | String | [inline]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Ref Member List

This is the complete list of members for Ref, including all inherited members.
Clear() | Ref | [inline]
ConvRef(const Ref< oldT > &old_ref) | Ref | [related]
IsSet() const | Ref | [inline]
operator *() const | Ref | [inline]
operator T *() const | Ref | [inline]
operator->() const | Ref | [inline]
operator=(const Ref &rhs) | Ref | [inline]
Ref(T *real_ptr=NULL) | Ref | [inline]
Ref(const Ref &rhs) | Ref | [inline]
Set(T *real_ptr) | Ref | [inline]
~Ref() | Ref | [inline]
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

ReflectFilter Member List

This is the complete list of members for ReflectFilter, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | ReflectFilter | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
ReflectFilter(bool in_bVert, bool in_bHor) (defined in ReflectFilter) | ReflectFilter |
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
~ReflectFilter() (defined in ReflectFilter) | ReflectFilter | [virtual]
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

SetRectFilter Member List

This is the complete list of members for SetRectFilter, including all inherited members.
Apply(const Image *pBmpSource, Image *pBmpDest) const | SetRectFilter | [virtual]
ApplyInPlace(Image *pBmp) const | ImageFilter | [virtual]
ImageFilter() (defined in ImageFilter) | ImageFilter | [inline]
SetParam(double in_dValue) (defined in SetRectFilter) | SetRectFilter |
SetParam(double in_dValue, gml::Vector2i in_vMin, gml::Vector2i in_vMax) (defined in SetRectFilter) | SetRectFilter |
SetParam(double in_dValue, int in_iMinX, int in_iMinY, int in_iMaxX, int in_iMaxY) (defined in SetRectFilter) | SetRectFilter |
SetRectFilter(double in_dValue) (defined in SetRectFilter) | SetRectFilter |
SetRectFilter(double in_dValue, gml::Vector2i in_vMin, gml::Vector2i in_vMax) (defined in SetRectFilter) | SetRectFilter |
SetRectFilter(double in_dValue, int in_iMinX, int in_iMinY, int in_iMaxX, int in_iMaxY) (defined in SetRectFilter) | SetRectFilter |
~ImageFilter() (defined in ImageFilter) | ImageFilter | [inline, virtual]
~SetRectFilter() (defined in SetRectFilter) | SetRectFilter | [virtual]
Generated on Tue Jan 13 21:12:04 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

SimpleImage Member List

This is the complete list of members for SimpleImage, including all inherited members.
AddRef() | SmartObject | [inline]
AlmostEqual(const Image &Bmp, int epsilon) const (defined in Image) | Image |
ApplyFilter(const ImageFilter &filter) | Image |
ChangeFormat(FORMAT new_format) | Image |
ChangeOrientation(ORIENT new_orient) | Image |
ChangeRepres(REPRES new_repres) | Image |
Clear() (defined in Image) | Image |
ConstructorInitLocals() (defined in SimpleImage) | SimpleImage | [protected, virtual]
Create(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [virtual]
CreateComposition(const std::vector< Image * > &src, const ImageComposer &comp) (defined in Image) | Image |
CreateCopy(const Image &rSrImage) | Image |
Created() const (defined in Image) | Image |
CreateFilteredCopy(const Image &rSrImage, const ImageFilter &rFilter) | Image |
CreateFromDIB(struct tagBITMAPINFO *in_pDIB, BYTE *in_pcData=NULL) | Image |
Decompose(const ImageDecomposer &decomposer, std::vector< Image * > &out_res) | Image |
ElemSize(FORMAT f, REPRES r) (defined in Image) | Image | [inline, static]
F_BGR enum value (defined in Image) | Image |
F_L enum value (defined in Image) | Image |
F_RGB enum value (defined in Image) | Image |
F_RGBA enum value (defined in Image) | Image |
FORMAT enum name (defined in Image) | Image |
Format2Channels(FORMAT f) (defined in Image) | Image | [inline, static]
FreeMembers() | SimpleImage | [protected, virtual]
GetBitsMemNeeded(int width, int height, FORMAT f, REPRES r) | SimpleImage | [static]
GetBytesPerLine() const | SimpleImage | [virtual]
GetDrawSurface() | SimpleImage | [virtual]
GetElemSize() const (defined in Image) | Image | [inline]
GetFormat() const (defined in Image) | Image | [inline]
GetHeight() const (defined in Image) | Image | [inline]
GetLineArray() const | Image | [inline]
GetMemNeeded(int width, int height, FORMAT f, REPRES r) | SimpleImage | [static]
GetMemUsed() | SimpleImage | [virtual]
GetOrient() const (defined in Image) | Image | [inline]
GetRawData() const (defined in SimpleImage) | SimpleImage | [inline]
GetRawData() | SimpleImage | [inline]
GetRawDataSize() const (defined in SimpleImage) | SimpleImage | [inline, virtual]
GetRepres() const (defined in Image) | Image | [inline]
GetWidth() const (defined in Image) | Image | [inline]
Image() | Image |
Image(Image &in_Image) (defined in Image) | Image |
InitLineArray() | SimpleImage | [protected, virtual]
InitLocals(int width, int height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | Image | [protected]
InternalChangeOrientation(ORIENT new_orient) | SimpleImage | [protected, virtual]
InternalCopy(const Image &rSrImage) | Image | [protected]
InternalCreate(int Width, int Height, FORMAT format, REPRES repres, ORIENT orient=O_BOTTOMLEFT) | SimpleImage | [protected, virtual]
IsLocked() const (defined in Image) | Image | [inline]
Lock(bool bReadable, bool bWriteable) | Image | [virtual]
m_created (defined in Image) | Image | [protected]
m_format (defined in Image) | Image | [protected]
m_height (defined in Image) | Image | [protected]
m_line_array | Image | [protected]
m_lock_count | Image | [protected]
m_orient | Image | [protected]
m_pBits | SimpleImage | [protected]
m_repres (defined in Image) | Image | [protected]
m_width (defined in Image) | Image | [protected]
O_BOTTOMLEFT enum value | Image |
O_TOPLEFT enum value | Image |
operator=(const Image &Orig) | SimpleImage | [inline]
operator=(const SimpleImage &Orig) (defined in SimpleImage) | SimpleImage | [inline]
operator==(Image const &Other) | Image |
ORIENT enum name | Image |
PaintImage(CDC *in_pDC, CPoint dst_org, CSize dst_size, DWORD dwRop=SRCCOPY) (defined in Image) | Image |
R_BYTE enum value (defined in Image) | Image |
R_DOUBLE enum value (defined in Image) | Image |
R_DWORD enum value (defined in Image) | Image |
R_FLOAT enum value (defined in Image) | Image |
R_WORD enum value (defined in Image) | Image |
Release() | SmartObject | [inline]
REPRES enum name (defined in Image) | Image |
Repres2Size(REPRES r) (defined in Image) | Image | [inline, static]
SimpleImage() | SimpleImage |
SimpleImage(const Image &Orig) | SimpleImage | [inline]
SimpleImage(const SimpleImage &Orig) | SimpleImage | [inline]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
Unlock() | Image | [virtual]
~Image() | Image | [virtual]
~SimpleImage() | SimpleImage | [virtual]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

SimpleImageLoader Member List

This is the complete list of members for SimpleImageLoader, including all inherited members.
CheckBitMapFile(const std::string &path) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
EnumerateLoadableFormats(void(*f)(IMAGE_FORMAT f)) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
EnumerateSaveableFormats(void(*f)(IMAGE_FORMAT f)) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
FORMAT_BMP enum value (defined in ImageLoader) | ImageLoader |
FORMAT_ICO enum value (defined in ImageLoader) | ImageLoader |
FORMAT_JPEG enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PGM enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PGMRAW enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PNG enum value (defined in ImageLoader) | ImageLoader |
FORMAT_PPM enum value (defined in ImageLoader) | ImageLoader |
FORMAT_TARGA enum value (defined in ImageLoader) | ImageLoader |
FORMAT_TIFF enum value (defined in ImageLoader) | ImageLoader |
FORMAT_UNKNOWN enum value (defined in ImageLoader) | ImageLoader |
GetExifMarker(std::vector< unsigned char > &out_pcData) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
GetFormatExtension(IMAGE_FORMAT format) | ImageLoader | [static]
IMAGE_FORMAT enum name (defined in ImageLoader) | ImageLoader |
LoadBitMap(const std::string &path, Image &out_bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int flags=0) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
SaveBitMap(const std::string &path, const Image &bitmap, IMAGE_FORMAT format=FORMAT_UNKNOWN, int in_iQuality=100, int flags=0) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
SetExifMarker(std::vector< unsigned char > &in_pcData) (defined in SimpleImageLoader) | SimpleImageLoader | [virtual]
Generated on Tue Jan 13 21:12:06 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

SmartObject Member List

This is the complete list of members for SmartObject, including all inherited members.
AddRef() | SmartObject | [inline]
Release() | SmartObject | [inline]
SmartObject() (defined in SmartObject) | SmartObject | [inline]
~SmartObject() | SmartObject | [inline, virtual]
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Socket Member List

This is the complete list of members for Socket, including all inherited members.
Accept(gml::Socket &rConnectedSocket) (defined in Socket) | Socket |
Bind(int nSocketPort, const char *lpszSocketAddress=NULL) (defined in Socket) | Socket |
Close() (defined in Socket) | Socket |
Connect(const char *lpszHostAddress, int nHostPort) (defined in Socket) | Socket |
Create(int nSocketPort=0, const char *lpszSocketAddress=NULL) (defined in Socket) | Socket |
InitSockets() | Socket | [static]
Listen(int nConnectionBacklog=5) (defined in Socket) | Socket |
Receive(void *lpBuf, int nBufLen, int nFlags=0) (defined in Socket) | Socket |
ReceiveFile(const std::string in_filename) (defined in Socket) | Socket |
Send(const void *lpBuf, int nBufLen, int nFlags=0) (defined in Socket) | Socket |
SendFile(const std::string &out_filename) (defined in Socket) | Socket |
Socket() (defined in Socket) | Socket |
~Socket() (defined in Socket) | Socket |
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

String Member List

This is the complete list of members for String, including all inherited members.
AsCString() const | String | [inline]
AsDouble() const | String | [inline]
AsInt() const | String | [inline]
Format(const char *format,...) | String |
FormatV(const char *format, va_list arglist) | String |
String() | String | [inline]
String(const string &rhs) | String | [inline]
String(const string &rhs, size_type pos, size_type n) | String | [inline]
String(const char *s, size_type n) | String | [inline]
String(const char *s) | String | [inline]
String(size_type n, char c) | String | [inline]
String(const_iterator first, const_iterator last) | String | [inline]
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TColor3 Member List

This is the complete list of members for TColor3, including all inherited members.
b (defined in TColor3) | TColor3 |
c (defined in TColor3) | TColor3 |
Cast(const T *u) | TColor3 | [inline, static]
Cast(T *u) | TColor3 | [inline, static]
g (defined in TColor3) | TColor3 |
operator *(const double d) const (defined in TColor3) | TColor3 | [inline]
operator *(const double d, const TColor3< T > &u) | TColor3 | [related]
operator *=(const double d) (defined in TColor3) | TColor3 | [inline]
operator const T *() const | TColor3 | [inline]
operator T *() | TColor3 | [inline]
operator+(const TColor3< T > &u) const (defined in TColor3) | TColor3 | [inline]
operator+=(const TColor3< T > &u) (defined in TColor3) | TColor3 | [inline]
operator-(const TColor3< T > &u) const (defined in TColor3) | TColor3 | [inline]
operator-=(const TColor3< T > &u) (defined in TColor3) | TColor3 | [inline]
operator/(const double d) const (defined in TColor3) | TColor3 | [inline]
operator/=(const double d) (defined in TColor3) | TColor3 | [inline]
r (defined in TColor3) | TColor3 |
TColor3() | TColor3 | [inline]
TColor3(T r0, T g0, T b0) (defined in TColor3) | TColor3 | [inline]
x (defined in TColor3) | TColor3 |
y (defined in TColor3) | TColor3 |
z (defined in TColor3) | TColor3 |
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TColor4 Member List

This is the complete list of members for TColor4, including all inherited members.
a (defined in TColor4) | TColor4 |
b (defined in TColor4) | TColor4 |
c (defined in TColor4) | TColor4 |
Cast(const T *u) | TColor4 | [inline, static]
Cast(T *u) | TColor4 | [inline, static]
g (defined in TColor4) | TColor4 |
operator *(const double d) const (defined in TColor4) | TColor4 | [inline]
operator *(const double d, const TColor4< T > &u) | TColor4 | [related]
operator *=(const double d) (defined in TColor4) | TColor4 | [inline]
operator const T *() const | TColor4 | [inline]
operator T *() | TColor4 | [inline]
operator+(const TColor4< T > &u) const (defined in TColor4) | TColor4 | [inline]
operator+=(const TColor4< T > &u) (defined in TColor4) | TColor4 | [inline]
operator-(const TColor4< T > &u) const (defined in TColor4) | TColor4 | [inline]
operator-=(const TColor4< T > &u) (defined in TColor4) | TColor4 | [inline]
operator/(const double d) const (defined in TColor4) | TColor4 | [inline]
operator/=(const double d) (defined in TColor4) | TColor4 | [inline]
r (defined in TColor4) | TColor4 |
TColor4() | TColor4 | [inline]
TColor4(T r0, T g0, T b0, T w0=1) (defined in TColor4) | TColor4 | [inline]
w (defined in TColor4) | TColor4 |
x (defined in TColor4) | TColor4 |
y (defined in TColor4) | TColor4 |
z (defined in TColor4) | TColor4 |
Generated on Tue Jan 13 21:12:03 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TMatrix2x2 Member List

This is the complete list of members for TMatrix2x2, including all inherited members.
Conv(const TMatrix2x2< T_FROM > &u) | TMatrix2x2 | [related]
ConvD(const TMatrix2x2< T > &u) | TMatrix2x2 | [related]
ConvF(const TMatrix2x2< T > &u) | TMatrix2x2 | [related]
Det() (defined in TMatrix2x2) | TMatrix2x2 | [inline]
Elem(int row, int col) | TMatrix2x2 | [inline]
Elem(int row, int col) const | TMatrix2x2 | [inline]
GetColumn(int c, TVector2< T > &t) const | TMatrix2x2 | [inline]
GetColumn(int c) const | TMatrix2x2 | [inline]
GetRow(int r, TVector2< T > &t) const | TMatrix2x2 | [inline]
GetRow(int r) const | TMatrix2x2 | [inline]
GetValue(T *mp) const | TMatrix2x2 | [inline]
GetValue() const | TMatrix2x2 | [inline]
Identity() | TMatrix2x2 | [inline, static]
Inverse() const | TMatrix2x2 | [inline]
m (defined in TMatrix2x2) | TMatrix2x2 | [protected]
MakeIdentity() | TMatrix2x2 | [inline]
MultLeft(const TMatrix2x2< T > &b) | TMatrix2x2 | [inline]
MultMatrixVec(const TVector2< T > &src, TVector2< T > &dst) const | TMatrix2x2 | [inline]
MultMatrixVec(TVector2< T > &src_and_dst) const | TMatrix2x2 | [inline]
MultRight(const TMatrix2x2< T > &b) | TMatrix2x2 | [inline]
MultVecMatrix(const TVector2< T > &src, TVector2< T > &dst) const | TMatrix2x2 | [inline]
MultVecMatrix(TVector2< T > &src_and_dst) const | TMatrix2x2 | [inline]
MultVectStr(TVector2< T > &v1, TVector2< T > &v2) (defined in TMatrix2x2) | TMatrix2x2 | [inline]
operator *(const TMatrix2x2< T > &m1, const TMatrix2x2< T > &m2) | TMatrix2x2 | [friend]
operator *=(const TMatrix2x2< T > &mat) | TMatrix2x2 | [inline]
operator *=(const T &r) | TMatrix2x2 | [inline]
operator!=(const TMatrix2x2< T > &m1, const TMatrix2x2< T > &m2) | TMatrix2x2 | [friend]
operator()(int row, int col) | TMatrix2x2 | [inline]
operator()(int row, int col) const | TMatrix2x2 | [inline]
operator+=(const TMatrix2x2< T > &mat) | TMatrix2x2 | [inline]
operator/(const double d) (defined in TMatrix2x2) | TMatrix2x2 | [inline]
operator==(const TMatrix2x2< T > &m1, const TMatrix2x2< T > &m2) | TMatrix2x2 | [friend]
RawArray() | TMatrix2x2 | [inline]
SetColumn(int c, const TVector2< T > &t) | TMatrix2x2 | [inline]
SetRow(int r, const TVector2< T > &t) | TMatrix2x2 | [inline]
SetValue(const T *mp) | TMatrix2x2 | [inline]
SetValue(T r) | TMatrix2x2 | [inline]
TMatrix2x2() | TMatrix2x2 | [inline]
TMatrix2x2(T r) | TMatrix2x2 | [inline]
TMatrix2x2(const T *m) | TMatrix2x2 | [inline]
TMatrix2x2(T a00, T a01, T a10, T a11) | TMatrix2x2 | [inline]
Transpose() const | TMatrix2x2 | [inline]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TMatrix3x3 Member List

This is the complete list of members for TMatrix3x3, including all inherited members.
Conv(const TMatrix3x3< T_FROM > &u) | TMatrix3x3 | [related]
ConvD(const TMatrix3x3< T > &u) | TMatrix3x3 | [related]
ConvF(const TMatrix3x3< T > &u) | TMatrix3x3 | [related]
Det() (defined in TMatrix3x3) | TMatrix3x3 | [inline]
Elem(int row, int col) | TMatrix3x3 | [inline]
Elem(int row, int col) const | TMatrix3x3 | [inline]
GetColumn(int c, TVector3< T > &t) const | TMatrix3x3 | [inline]
GetColumn(int c) const | TMatrix3x3 | [inline]
GetRotation(TMatrix3x3< T > &mat) const | TMatrix3x3 | [inline]
GetRotation() const | TMatrix3x3 | [inline]
GetRow(int r, TVector3< T > &t) const | TMatrix3x3 | [inline]
GetRow(int r) const | TMatrix3x3 | [inline]
GetTranslation(TVector2< T > &t) const | TMatrix3x3 | [inline]
GetTranslation() const | TMatrix3x3 | [inline]
GetValue(T *mp) const | TMatrix3x3 | [inline]
GetValue() const | TMatrix3x3 | [inline]
Identity() | TMatrix3x3 | [inline, static]
Inverse() const | TMatrix3x3 | [inline]
m (defined in TMatrix3x3) | TMatrix3x3 | [protected]
MakeIdentity() | TMatrix3x3 | [inline]
MultDirMatrix(const TVector2< T > &src, TVector2< T > &dst) const | TMatrix3x3 | [inline]
MultDirMatrix(TVector2< T > &src_and_dst) const | TMatrix3x3 | [inline]
MultLeft(const TMatrix3x3< T > &b) | TMatrix3x3 | [inline]
MultMatrixDir(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix3x3 | [inline]
MultMatrixDir(TVector3< T > &src_and_dst) const | TMatrix3x3 | [inline]
MultMatrixVec(const TVector2< T > &src, TVector2< T > &dst) const | TMatrix3x3 | [inline]
MultMatrixVec(TVector2< T > &src_and_dst) const | TMatrix3x3 | [inline]
MultMatrixVec(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix3x3 | [inline]
MultMatrixVec(TVector3< T > &src_and_dst) const | TMatrix3x3 | [inline]
MultRight(const TMatrix3x3< T > &b) | TMatrix3x3 | [inline]
MultVecMatrix(const TVector2< T > &src, TVector2< T > &dst) const | TMatrix3x3 | [inline]
MultVecMatrix(TVector2< T > &src_and_dst) const | TMatrix3x3 | [inline]
MultVecMatrix(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix3x3 | [inline]
MultVecMatrix(TVector3< T > &src_and_dst) const | TMatrix3x3 | [inline]
MultVectStr(TVector3< T > &v1, TVector3< T > &v2) (defined in TMatrix3x3) | TMatrix3x3 | [inline]
operator *(const TMatrix3x3< T > &m1, const TMatrix3x3< T > &m2) | TMatrix3x3 | [friend]
operator *=(const TMatrix3x3< T > &mat) | TMatrix3x3 | [inline]
operator *=(const double d) (defined in TMatrix3x3) | TMatrix3x3 | [inline]
operator!=(const TMatrix3x3< T > &m1, const TMatrix3x3< T > &m2) | TMatrix3x3 | [friend]
operator()(int row, int col) | TMatrix3x3 | [inline]
operator()(int row, int col) const | TMatrix3x3 | [inline]
operator+=(const TMatrix3x3< T > &mat) | TMatrix3x3 | [inline]
operator/(const double d) (defined in TMatrix3x3) | TMatrix3x3 | [inline]
operator/=(const double d) (defined in TMatrix3x3) | TMatrix3x3 | [inline]
operator=(const TMatrix3x3< T > &mat) (defined in TMatrix3x3) | TMatrix3x3 | [inline]
operator==(const TMatrix3x3< T > &m1, const TMatrix3x3< T > &m2) | TMatrix3x3 | [friend]
RawArray() | TMatrix3x3 | [inline]
SetColumn(int c, const TVector3< T > &t) | TMatrix3x3 | [inline]
SetRotation(const TMatrix3x3< T > &mat) | TMatrix3x3 | [inline]
SetRow(int r, const TVector3< T > &t) | TMatrix3x3 | [inline]
SetScale(T s) | TMatrix3x3 | [inline]
SetScale(const TVector3< T > &s) | TMatrix3x3 | [inline]
SetTranslation(const TVector2< T > &t) | TMatrix3x3 | [inline]
SetValue(const T *mp) | TMatrix3x3 | [inline]
SetValue(T r) | TMatrix3x3 | [inline]
TMatrix3x3() | TMatrix3x3 | [inline]
TMatrix3x3(T r) | TMatrix3x3 | [inline]
TMatrix3x3(const T *m) | TMatrix3x3 | [inline]
TMatrix3x3(T a00, T a01, T a02, T a10, T a11, T a12, T a20, T a21, T a22) | TMatrix3x3 | [inline]
Transpose() const | TMatrix3x3 | [inline]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TMatrix4x4 Member List

This is the complete list of members for TMatrix4x4, including all inherited members.
Conv(const TMatrix4x4< T_FROM > &u) | TMatrix4x4 | [related]
ConvD(const TMatrix4x4< T > &u) | TMatrix4x4 | [related]
ConvF(const TMatrix4x4< T > &u) | TMatrix4x4 | [related]
Elem(int row, int col) | TMatrix4x4 | [inline]
Elem(int row, int col) const | TMatrix4x4 | [inline]
GetColumn(int c, TVector4< T > &t) const | TMatrix4x4 | [inline]
GetColumn(int c) const | TMatrix4x4 | [inline]
GetRotation(TMatrix4x4< T > &mat) const | TMatrix4x4 | [inline]
GetRotation() const | TMatrix4x4 | [inline]
GetRow(int r, TVector4< T > &t) const | TMatrix4x4 | [inline]
GetRow(int r) const | TMatrix4x4 | [inline]
GetTranslation(TVector3< T > &t) const | TMatrix4x4 | [inline]
GetTranslation() const | TMatrix4x4 | [inline]
GetValue(T *mp) const | TMatrix4x4 | [inline]
GetValue() const | TMatrix4x4 | [inline]
Identity() | TMatrix4x4 | [inline, static]
Inverse() const | TMatrix4x4 | [inline]
m (defined in TMatrix4x4) | TMatrix4x4 | [protected]
MakeIdentity() | TMatrix4x4 | [inline]
MultDirMatrix(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix4x4 | [inline]
MultDirMatrix(TVector3< T > &src_and_dst) const | TMatrix4x4 | [inline]
MultLeft(const TMatrix4x4< T > &b) | TMatrix4x4 | [inline]
MultMatrixDir(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix4x4 | [inline]
MultMatrixDir(TVector3< T > &src_and_dst) const | TMatrix4x4 | [inline]
MultMatrixVec(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix4x4 | [inline]
MultMatrixVec(TVector3< T > &src_and_dst) const | TMatrix4x4 | [inline]
MultMatrixVec(const TVector4< T > &src, TVector4< T > &dst) const | TMatrix4x4 | [inline]
MultMatrixVec(TVector4< T > &src_and_dst) const | TMatrix4x4 | [inline]
MultRight(const TMatrix4x4< T > &b) | TMatrix4x4 | [inline]
MultVecMatrix(const TVector3< T > &src, TVector3< T > &dst) const | TMatrix4x4 | [inline]
MultVecMatrix(TVector3< T > &src_and_dst) const | TMatrix4x4 | [inline]
MultVecMatrix(const TVector4< T > &src, TVector4< T > &dst) const | TMatrix4x4 | [inline]
MultVecMatrix(TVector4< T > &src_and_dst) const | TMatrix4x4 | [inline]
operator *(const TMatrix4x4< T > &m1, const TMatrix4x4< T > &m2) | TMatrix4x4 | [friend]
operator *=(const TMatrix4x4< T > &mat) | TMatrix4x4 | [inline]
operator *=(const T &r) | TMatrix4x4 | [inline]
operator!=(const TMatrix4x4< T > &m1, const TMatrix4x4< T > &m2) | TMatrix4x4 | [friend]
operator()(int row, int col) | TMatrix4x4 | [inline]
operator()(int row, int col) const | TMatrix4x4 | [inline]
operator+=(const TMatrix4x4< T > &mat) | TMatrix4x4 | [inline]
operator==(const TMatrix4x4< T > &m1, const TMatrix4x4< T > &m2) | TMatrix4x4 | [friend]
Ortho(double left, double right, double bottom, double top, double znear, double zfar) (defined in TMatrix4x4) | TMatrix4x4 | [inline]
RawArray() | TMatrix4x4 | [inline]
SetColumn(int c, const TVector4< T > &t) | TMatrix4x4 | [inline]
SetRotation(const TMatrix4x4< T > &mat) | TMatrix4x4 | [inline]
SetRow(int r, const TVector4< T > &t) | TMatrix4x4 | [inline]
SetScale(T s) | TMatrix4x4 | [inline]
SetScale(const TVector3< T > &s) | TMatrix4x4 | [inline]
SetTranslation(const TVector3< T > &t) | TMatrix4x4 | [inline]
SetValue(const T *mp) | TMatrix4x4 | [inline]
SetValue(T r) | TMatrix4x4 | [inline]
TMatrix4x4() | TMatrix4x4 | [inline]
TMatrix4x4(T r) | TMatrix4x4 | [inline]
TMatrix4x4(const T *m) | TMatrix4x4 | [inline]
TMatrix4x4(T a00, T a01, T a02, T a03, T a10, T a11, T a12, T a13, T a20, T a21, T a22, T a23, T a30, T a31, T a32, T a33) | TMatrix4x4 | [inline]
Transpose() const | TMatrix4x4 | [inline]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TQuaternion Member List

This is the complete list of members for TQuaternion, including all inherited members.
Conjugate() (defined in TQuaternion) | TQuaternion | [inline]
Conv(const TQuaternion< T_FROM > &u) | TQuaternion | [related]
ConvD(const TQuaternion< T > &u) | TQuaternion | [related]
ConvF(const TQuaternion< T > &u) | TQuaternion | [related]
counter (defined in TQuaternion) | TQuaternion | [protected]
CounterNormalize() (defined in TQuaternion) | TQuaternion | [inline, protected]
Equals(const TQuaternion &r, T tolerance) const (defined in TQuaternion) | TQuaternion | [inline]
GetValue() const (defined in TQuaternion) | TQuaternion | [inline]
GetValue(T &q0, T &q1, T &q2, T &q3) const (defined in TQuaternion) | TQuaternion | [inline]
GetValue(TVector3< T > &axis, T &radians) const (defined in TQuaternion) | TQuaternion | [inline]
GetValue(TMatrix4x4< T > &m) const (defined in TQuaternion) | TQuaternion | [inline]
Identity() (defined in TQuaternion) | TQuaternion | [inline, static]
Inverse() const (defined in TQuaternion) | TQuaternion | [inline]
Invert() (defined in TQuaternion) | TQuaternion | [inline]
MultVec(const TVector3< T > &src, TVector3< T > &dst) const (defined in TQuaternion) | TQuaternion | [inline]
MultVec(TVector3< T > &src_and_dst) const (defined in TQuaternion) | TQuaternion | [inline]
Normalize() (defined in TQuaternion) | TQuaternion | [inline]
operator * (defined in TQuaternion) | TQuaternion | [friend]
operator *=(const TQuaternion &qr) (defined in TQuaternion) | TQuaternion | [inline]
operator!= (defined in TQuaternion) | TQuaternion | [friend]
operator== (defined in TQuaternion) | TQuaternion | [friend]
operator[](int i) (defined in TQuaternion) | TQuaternion | [inline]
operator[](int i) const (defined in TQuaternion) | TQuaternion | [inline]
q (defined in TQuaternion) | TQuaternion | [protected]
ScaleAngle(T scaleFactor) (defined in TQuaternion) | TQuaternion | [inline]
SetValue(T q0, T q1, T q2, T q3) (defined in TQuaternion) | TQuaternion | [inline]
SetValue(const T *qp) (defined in TQuaternion) | TQuaternion | [inline]
SetValue(const TMatrix4x4< T > &m) (defined in TQuaternion) | TQuaternion | [inline]
SetValue(const TVector3< T > &axis, T theta) (defined in TQuaternion) | TQuaternion | [inline]
SetValue(const TVector3< T > &rotateFrom, const TVector3< T > &rotateTo) (defined in TQuaternion) | TQuaternion | [inline]
SetValue(const TVector3< T > &from_look, const TVector3< T > &from_up, const TVector3< T > &to_look, const TVector3< T > &to_up) (defined in TQuaternion) | TQuaternion | [inline]
Slerp(const TQuaternion &p, const TQuaternion &q, T alpha) (defined in TQuaternion) | TQuaternion | [inline, static]
TQuaternion() (defined in TQuaternion) | TQuaternion | [inline]
TQuaternion(const T v[4]) (defined in TQuaternion) | TQuaternion | [inline]
TQuaternion(T q0, T q1, T q2, T q3) (defined in TQuaternion) | TQuaternion | [inline]
TQuaternion(const TMatrix4x4< T > &m) (defined in TQuaternion) | TQuaternion | [inline]
TQuaternion(const TVector3< T > &axis, T radians) (defined in TQuaternion) | TQuaternion | [inline]
TQuaternion(const TVector3< T > &rotateFrom, const TVector3< T > &rotateTo) (defined in TQuaternion) | TQuaternion | [inline]
TQuaternion(const TVector3< T > &from_look, const TVector3< T > &from_up, const TVector3< T > &to_look, const TVector3< T > &to_up) (defined in TQuaternion) | TQuaternion | [inline]
w (defined in TQuaternion) | TQuaternion | [protected]
x (defined in TQuaternion) | TQuaternion | [protected]
y (defined in TQuaternion) | TQuaternion | [protected]
z (defined in TQuaternion) | TQuaternion | [protected]
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TVector2 Member List

This is the complete list of members for TVector2, including all inherited members.
c (defined in TVector2) | TVector2 |
Cast(const T *u) | TVector2 | [inline, static]
Cast(T *u) | TVector2 | [inline, static]
Clip(double vmin, double vmax) | TVector2 | [inline]
Conv(const TVector2< T_FROM > &u) | TVector2 | [related]
ConvD(const TVector2< T > &u) | TVector2 | [related]
ConvF(const TVector2< T > &u) | TVector2 | [related]
ConvI(const TVector2< T > &u) | TVector2 | [related]
ConvS(const TVector2< T > &u) | TVector2 | [related]
Cos(const TVector2< T > &a, const TVector2< T > &b) | TVector2 | [related]
CrossProd(const TVector2< T > &v1, const TVector2< T > &v2) | TVector2 | [related]
CrossProduct(const TVector2< T > &rhs) const | TVector2 | [inline]
CrossProduct(const TVector2< T > &v1, const TVector2< T > &v2) | TVector2 | [related]
DivVec(const TVector2< T > &u) const | TVector2 | [inline]
DotProd(const TVector2< T > &v1, const TVector2< T > &v2) | TVector2 | [related]
DotProduct(const TVector2< T > &rhs) const | TVector2 | [inline]
DotProduct(const TVector2< T > &v1, const TVector2< T > &v2) | TVector2 | [related]
GetDim() (defined in TVector2) | TVector2 | [inline, static]
Length() const | TVector2 | [inline]
Length(const TVector2< T > &u) | TVector2 | [related]
LessOrEqual(const TVector2< T > &u) const | TVector2 | [inline]
MultVec(const TVector2< T > &u) const | TVector2 | [inline]
Negate() | TVector2 | [inline]
Normalize() | TVector2 | [inline]
Normalized() const | TVector2 | [inline]
NormalRight() const | TVector2 | [inline]
operator *(const double d) const (defined in TVector2) | TVector2 | [inline]
operator *(const TVector2< T > &rhs) const | TVector2 | [inline]
operator *(const double d, const TVector2< T > &u) | TVector2 | [related]
operator *=(const double d) (defined in TVector2) | TVector2 | [inline]
operator const T *() const | TVector2 | [inline]
operator CPoint() (defined in TVector2) | TVector2 | [inline]
operator CvPoint() (defined in TVector2) | TVector2 | [inline]
operator CvSize() (defined in TVector2) | TVector2 | [inline]
operator T *() | TVector2 | [inline]
operator TPoint() (defined in TVector2) | TVector2 | [inline]
operator!() const | TVector2 | [inline]
operator+(const TVector2< T > &u) const (defined in TVector2) | TVector2 | [inline]
operator+=(const TVector2< T > &u) (defined in TVector2) | TVector2 | [inline]
operator-(const TVector2< T > &u) const (defined in TVector2) | TVector2 | [inline]
operator-() const (defined in TVector2) | TVector2 | [inline]
operator-=(const TVector2< T > &u) (defined in TVector2) | TVector2 | [inline]
operator/(const double d) const (defined in TVector2) | TVector2 | [inline]
operator/=(const double d) (defined in TVector2) | TVector2 | [inline]
operator=(const TPoint &p) (defined in TVector2) | TVector2 | [inline]
operator=(const CPoint &p) (defined in TVector2) | TVector2 | [inline]
operator=(const POINT &p) (defined in TVector2) | TVector2 | [inline]
operator=(const CSize &p) (defined in TVector2) | TVector2 | [inline]
operator=(const CvPoint &p) (defined in TVector2) | TVector2 | [inline]
operator[](int i) (defined in TVector2) | TVector2 | [inline]
operator[](int i) const (defined in TVector2) | TVector2 | [inline]
operator^(const TVector2< T > &rhs) const | TVector2 | [inline]
operator~() const | TVector2 | [inline]
SetValue(double x0, double y0) | TVector2 | [inline]
SetValue(double a) | TVector2 | [inline]
Sin(const TVector2< T > &a, const TVector2< T > &b) | TVector2 | [related]
SqrLength() const | TVector2 | [inline]
SqrLength(const TVector2< T > &u) | TVector2 | [related]
TVector2() | TVector2 | [inline]
TVector2(double v) | TVector2 | [inline, explicit]
TVector2(double x0, double y0) | TVector2 | [inline]
TVector2(const TVector3< T > &u) (defined in TVector2) | TVector2 | [inline, explicit]
TVector2(const TPoint &p) (defined in TVector2) | TVector2 | [inline]
TVector2(const CPoint &p) (defined in TVector2) | TVector2 | [inline]
TVector2(const POINT &p) (defined in TVector2) | TVector2 | [inline]
TVector2(const CSize &p) (defined in TVector2) | TVector2 | [inline]
TVector2(const CvPoint &p) (defined in TVector2) | TVector2 | [inline]
x (defined in TVector2) | TVector2 |
y (defined in TVector2) | TVector2 |
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TVector3 Member List

This is the complete list of members for TVector3, including all inherited members.
c (defined in TVector3) | TVector3 |
Cast(const T *u) | TVector3 | [inline, static]
Cast(T *u) | TVector3 | [inline, static]
Clip(double vmin, double vmax) (defined in TVector3) | TVector3 | [inline]
Conv(const TVector3< T_FROM > &u) | TVector3 | [related]
ConvD(const TVector3< T > &u) | TVector3 | [related]
ConvF(const TVector3< T > &u) | TVector3 | [related]
ConvI(const TVector3< T > &u) | TVector3 | [related]
ConvS(const TVector3< T > &u) | TVector3 | [related]
Cos(const TVector3< T > &a, const TVector3< T > &b) | TVector3 | [related]
CrossProduct(const TVector3< T > &rhs) const | TVector3 | [inline]
CrossProduct(const TVector3< T > &v1, const TVector3< T > &v2) | TVector3 | [related]
DivVec(const TVector3< T > &u) const | TVector3 | [inline]
DotProduct(const TVector3< T > &rhs) const | TVector3 | [inline]
DotProduct(const TVector3< T > &v1, const TVector3< T > &v2) | TVector3 | [related]
GetDim() (defined in TVector3) | TVector3 | [inline, static]
Length() const | TVector3 | [inline]
Length(const TVector3< T > &u) | TVector3 | [related]
LessOrEqual(const TVector3< T > &u) const | TVector3 | [inline]
MaxValue() const | TVector3 | [inline]
MultVec(const TVector3< T > &u) const | TVector3 | [inline]
Negate() | TVector3 | [inline]
Normalize() | TVector3 | [inline]
Normalized() const | TVector3 | [inline]
operator *(const double d) const (defined in TVector3) | TVector3 | [inline]
operator *(const TVector3< T > &rhs) const | TVector3 | [inline]
operator *(const double d, const TVector3< T > &u) | TVector3 | [related]
operator *=(const double d) (defined in TVector3) | TVector3 | [inline]
operator const T *() const | TVector3 | [inline]
operator CPoint() (defined in TVector3) | TVector3 | [inline]
operator CvPoint() (defined in TVector3) | TVector3 | [inline]
operator T *() | TVector3 | [inline]
operator TPoint() (defined in TVector3) | TVector3 | [inline]
operator!() const | TVector3 | [inline]
operator+(const TVector3< T > &u) const (defined in TVector3) | TVector3 | [inline]
operator+=(const TVector3< T > &u) (defined in TVector3) | TVector3 | [inline]
operator-(const TVector3< T > &u) const (defined in TVector3) | TVector3 | [inline]
operator-() const | TVector3 | [inline]
operator-=(const TVector3< T > &u) (defined in TVector3) | TVector3 | [inline]
operator/(const double d) const (defined in TVector3) | TVector3 | [inline]
operator/(const TVector3< T > v) const (defined in TVector3) | TVector3 | [inline]
operator/=(const double d) (defined in TVector3) | TVector3 | [inline]
operator=(const TPoint &p) (defined in TVector3) | TVector3 | [inline]
operator=(const CPoint &p) (defined in TVector3) | TVector3 | [inline]
operator=(const CSize &p) (defined in TVector3) | TVector3 | [inline]
operator=(const CvPoint &p) (defined in TVector3) | TVector3 | [inline]
operator[](int i) (defined in TVector3) | TVector3 | [inline]
operator[](int i) const (defined in TVector3) | TVector3 | [inline]
operator^(const TVector3< T > &rhs) const | TVector3 | [inline]
operator~() const | TVector3 | [inline]
SetValue(double x0, double y0, double z0) | TVector3 | [inline]
SetValue(double a) | TVector3 | [inline]
Sin(const TVector3< T > &a, const TVector3< T > &b) | TVector3 | [related]
SqrLength() const | TVector3 | [inline]
SqrLength(const TVector3< T > &u) | TVector3 | [related]
TVector3() | TVector3 | [inline]
TVector3(double v) | TVector3 | [inline, explicit]
TVector3(double x0, double y0, double z0) | TVector3 | [inline]
TVector3(T *data) (defined in TVector3) | TVector3 | [inline]
TVector3(const TVector3< T > &data) (defined in TVector3) | TVector3 | [inline]
TVector3(const TPoint &p) (defined in TVector3) | TVector3 | [inline]
TVector3(const CPoint &p) (defined in TVector3) | TVector3 | [inline]
TVector3(const CSize &p) (defined in TVector3) | TVector3 | [inline]
TVector3(const CvPoint &p) (defined in TVector3) | TVector3 | [inline]
x (defined in TVector3) | TVector3 |
y (defined in TVector3) | TVector3 |
z (defined in TVector3) | TVector3 |
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

TVector4 Member List

This is the complete list of members for TVector4, including all inherited members.
c (defined in TVector4) | TVector4 |
Cast(const T *u) | TVector4 | [inline, static]
Cast(T *u) | TVector4 | [inline, static]
Clip(double vmin, double vmax) | TVector4 | [inline]
Conv(const TVector4< T_FROM > &u) | TVector4 | [related]
ConvD(const TVector4< T > &u) | TVector4 | [related]
ConvF(const TVector4< T > &u) | TVector4 | [related]
ConvI(const TVector4< T > &u) | TVector4 | [related]
ConvS(const TVector4< T > &u) | TVector4 | [related]
DivVec(const TVector4< T > &u) const | TVector4 | [inline]
DotProduct(const TVector4< T > &rhs) const | TVector4 | [inline]
DotProduct(const TVector4< T > &v1, const TVector4< T > &v2) | TVector4 | [related]
Homogenize() (defined in TVector4) | TVector4 | [inline]
Length() const | TVector4 | [inline]
Length(const TVector4< T > &u) | TVector4 | [related]
LessOrEqual(const TVector4< T > &u) const | TVector4 | [inline]
LessOrEqual(const TVector3< T > &u) const | TVector4 | [inline]
MaxValue() const | TVector4 | [inline]
MultVec(const TVector4< T > &u) const | TVector4 | [inline]
Negate() | TVector4 | [inline]
Normalize() | TVector4 | [inline]
Normalized() const | TVector4 | [inline]
operator *(const double d) const (defined in TVector4) | TVector4 | [inline]
operator *(const TVector4< T > &rhs) const | TVector4 | [inline]
operator *(const double d, const TVector4< T > &u) | TVector4 | [related]
operator *=(const double d) (defined in TVector4) | TVector4 | [inline]
operator const T *() const | TVector4 | [inline]
operator CPoint() (defined in TVector4) | TVector4 | [inline]
operator CvPoint() (defined in TVector4) | TVector4 | [inline]
operator T *() | TVector4 | [inline]
operator TPoint() (defined in TVector4) | TVector4 | [inline]
operator!() const | TVector4 | [inline]
operator+(const TVector4< T > &u) const (defined in TVector4) | TVector4 | [inline]
operator+=(const TVector4< T > &u) (defined in TVector4) | TVector4 | [inline]
operator-(const TVector4< T > &u) const (defined in TVector4) | TVector4 | [inline]
operator-() const | TVector4 | [inline]
operator-=(const TVector4< T > &u) (defined in TVector4) | TVector4 | [inline]
operator/(const double d) const (defined in TVector4) | TVector4 | [inline]
operator/=(const double d) (defined in TVector4) | TVector4 | [inline]
operator=(const TPoint &p) (defined in TVector4) | TVector4 | [inline]
operator=(const CPoint &p) (defined in TVector4) | TVector4 | [inline]
operator=(const CSize &p) (defined in TVector4) | TVector4 | [inline]
operator=(const CvPoint &p) (defined in TVector4) | TVector4 | [inline]
operator[](int i) (defined in TVector4) | TVector4 | [inline]
operator[](int i) const (defined in TVector4) | TVector4 | [inline]
operator~() const | TVector4 | [inline]
SetValue(double x0, double y0, double z0, double w0) | TVector4 | [inline]
SetValue(double a) | TVector4 | [inline]
SqrLength() const | TVector4 | [inline]
SqrLength(const TVector4< T > &u) | TVector4 | [related]
TVector4() | TVector4 | [inline]
TVector4(double v) | TVector4 | [inline, explicit]
TVector4(double x0, double y0, double z0, double w0) | TVector4 | [inline]
TVector4(const TVector3< T > &v, double w0=1) | TVector4 | [inline]
TVector4(const TPoint &p) (defined in TVector4) | TVector4 | [inline]
TVector4(const CPoint &p) (defined in TVector4) | TVector4 | [inline]
TVector4(const CSize &p) (defined in TVector4) | TVector4 | [inline]
TVector4(const CvPoint &p) (defined in TVector4) | TVector4 | [inline]
w (defined in TVector4) | TVector4 |
x (defined in TVector4) | TVector4 |
y (defined in TVector4) | TVector4 |
z (defined in TVector4) | TVector4 |
Generated on Tue Jan 13 21:12:07 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Member List

Viewport Member List

This is the complete list of members for Viewport, including all inherited members.
GetCamera() const (defined in Viewport) | Viewport | [inline]
GetDistanceToTarget() const (defined in Viewport) | Viewport | [inline]
GetObserver() const | Viewport | [inline]
GetOrigin(int &x, int &y) const (defined in Viewport) | Viewport | [inline]
GetResolution(int &xres, int &yres) const (defined in Viewport) | Viewport | [inline]
GetRightVector() const | Viewport | [inline]
GetRotation() const (defined in Viewport) | Viewport | [inline]
GetTransform() const (defined in Viewport) | Viewport | [inline]
GetUpVector() const | Viewport | [inline]
GetViewAngle() const (defined in Viewport) | Viewport | [inline]
GetViewVector() const | Viewport | [inline]
SetCamera(Camera *cam) (defined in Viewport) | Viewport | [inline]
SetDistanceToTarget(float dist) (defined in Viewport) | Viewport | [inline]
SetObserver(const Vector3d &obs) (defined in Viewport) | Viewport | [inline]
SetOrigin(int x, int y) (defined in Viewport) | Viewport | [inline]
SetResolution(int xres, int yres) (defined in Viewport) | Viewport | [inline]
SetRotation(const Matrix4x4d &rot) (defined in Viewport) | Viewport | [inline]
SetTransform(const Matrix4x4d &view_transform) (defined in Viewport) | Viewport | [inline]
SetViewAngle(float view_angle) (defined in Viewport) | Viewport | [inline]
Viewport() (defined in Viewport) | Viewport | [inline]
Viewport(int x, int y, int xres, int yres, Camera *camera=0) (defined in Viewport) | Viewport | [inline]
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: File Index

Graphics and Media Lab CSL File List

Here is a list of all documented files with brief descriptions:
gmlbbox2.h | A class for 2D boundary box (BBox2) definition
gmlbbox3.h | A class for 2D boundary box (BBox3) definition
gmlbrowser.h | A class for 3d virtual camera
gmlbsphere3.h | Defines template class BSphere33<T>
gmlcallback.h | Definitions of callback helpers
gmlcamera.h | A class for 3d virtual camera
gmlcommon.h | General routines like ASSERT etc
gmlcommongl.h | OpenGL helpers
gmlframecounter.h | Simple frame rate (FPS) counter
gmlglrc.h | Class for operations with GL Win32 context
gmlmath.h | Common mathematic utility routines, gml::Math
gmlmatrix2.h | Definition of TMatrix2x2 template class and utility routines
gmlmatrix3.h | Definition of TMatrix3x3 template class and utility routines
gmlmatrix4.h | Definition of TMatrix4x4 template class and utility routines
gmlmesh.h | Definition of gml::Mesh class
gmlpathstring.h | Defines gml::PathString
gmlquat.h | Definition of TQuaternion template class
gmlref.h | Definitions of smart reference
gmlsmartobject.h | Definitions of smart object (which supports smart references)
gmlsocket.h | Windows sockets handling (Win32 API)
gmlstring.h | Defines gml::String
gmlutils3d.h | 3d projections etc (utilities)
gmlutilsgl.h | A set of OGL utitility functions
gmlvector2.h | Defines template gml::TVector2, gml::Math2 and typedefs with utility functions
gmlvector3.h | Defines template gml::TVector3, gml::Math3 and typedefs with utility functions
gmlvector4.h | Defines template gml::TVector4, gml::Math3 and typedefs with utility functions
gmlviewport.h | A class for 3d viewport
Generated on Tue Jan 13 21:12:01 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Compound Member Index

  • METHOD : FilterGrayscale
  • ORIENT : Image
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Compound Member Index

  • O_BOTTOMLEFT : Image
  • O_TOPLEFT : Image
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Compound Member Index

- a -

  • AboutZero() : Math
  • AddRef() : SmartObject
  • Apply() : ImageFilter, ImageDecomposer, ImageComposer, SetRectFilter, ReflectFilter, FilterRGB2RGBA, FilterResize, FilterRepres, FilterMedianBlur, FilterLum2RGB, FilterGrayscale
  • ApplyFilter() : Image
  • ApplyInPlace() : ImageFilter, FilterRGB2BGR
  • AsCString() : String
  • AsDouble() : String
  • AsInt() : String
  • AttachImage() : DIntelImage

- b -

  • Basename() : PathString
  • BBox2() : BBox2
  • BBox3() : BBox3
  • BSphere3() : BSphere3

- c -

  • Call() : Callback
  • Cast() : TVector4, TVector3, TVector2, TColor4, TColor3
  • Center() : BBox3, BBox2
  • ChangeFormat() : Image
  • ChangeOrientation() : Image
  • ChangeRepres() : Image
  • ChDir() : PathString
  • CheckImage() : DIntelImage
  • CIniFile() : CIniFile
  • Clear() : Ref
  • Clip() : TVector4, TVector2
  • CloneImage() : DIntelImage
  • Close() : File
  • Conv() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvD() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvF() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvI() : TVector4, TVector3, TVector2
  • ConvRef() : Ref
  • ConvS() : TVector4, TVector3, TVector2
  • CopyOf() : DIntelImage
  • Cos() : TVector3, TVector2
  • Create() : GLRC, Image
  • CreateCopy() : Image
  • CreateFilteredCopy() : Image
  • CreateFromDIB() : Image
  • CreateImage() : DIntelImage
  • CrossProd() : TVector2
  • CrossProduct() : TVector3, TVector2, TVector3, TVector2
  • CurDir() : PathString

- d -

  • Decompose() : Image
  • DeleteImages() : DIntelImage
  • DeleteKey() : CIniFile
  • DeleteValue() : CIniFile
  • Destroy() : GLRC
  • DetachImage() : DIntelImage
  • Diag() : BBox3, BBox2
  • DIntelImage() : DIntelImage
  • DivVec() : TVector4, TVector3, TVector2
  • DotProd() : TVector2
  • DotProduct() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • DrawImage() : DIntelImage
  • DrawSurface() : DrawSurface

- e -

  • Elem() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ExePath() : PathString
  • ExpandBy() : BBox3, BBox2
  • Extension() : PathString

- f -

  • FastResizeImage() : GDIImage
  • File() : File
  • Filename() : PathString
  • FilePos() : File
  • FileSize() : File
  • FindFiles() : FileFinder
  • Format() : String
  • FormatV() : String
  • FrameCounter() : FrameCounter
  • FrameFinished() : FrameCounter
  • FrameStarted() : FrameCounter
  • FreeMembers() : SimpleImage, IntelImage, Image, GDIImage

- g -

  • GDIImage() : GDIImage
  • GDISurface() : GDISurface
  • GetBitsMemNeeded() : SimpleImage
  • GetBytesPerLine() : SimpleImage, IntelImage, Image, GDIImage
  • GetColumn() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • GetDistanceToTarget() : Camera
  • GetDrawSurface() : SimpleImage, IntelImage, GDIImage
  • GetFormatExtension() : ImageLoader
  • GetFrameCount() : FrameCounter
  • GetImage() : DIntelImage, IntelImage
  • GetLineArray() : Image
  • GetLineFast() : DIntelImage
  • GetLineSafe() : DIntelImage
  • GetMeanFrameTime() : FrameCounter
  • GetMemNeeded() : SimpleImage
  • GetMemUsed() : SimpleImage, IntelImage, GDIImage
  • GetMinimumFrameCount() : FrameCounter
  • GetNumKeys() : CIniFile
  • GetNumValues() : CIniFile
  • GetObserver() : Viewport
  • GetRawData() : SimpleImage, IntelImage, GDIImage
  • GetRightVector() : Viewport, Camera
  • GetRotation() : TMatrix4x4, TMatrix3x3
  • GetRow() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • GetTransform() : Camera
  • GetTranslation() : TMatrix4x4, TMatrix3x3
  • GetUpdateSpeed() : FrameCounter
  • GetUpVector() : Viewport, Camera
  • GetValue() : TMatrix4x4, TMatrix3x3, TMatrix2x2, CIniFile
  • GetValueF() : CIniFile
  • GetValueI() : CIniFile
  • GetViewAngle() : Camera
  • GetViewVector() : Viewport, Camera
  • GLRC() : GLRC

- h -

  • height() : DIntelImage
  • Height() : BBox2

- i -

  • Identity() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • Image() : Image
  • Include() : BSphere3, BBox3, BBox2
  • Includes() : BBox3, BBox2
  • InitLineArray() : SimpleImage, IntelImage, Image, GDIImage
  • InitLocals() : Image
  • InitSockets() : Socket
  • IntelImage() : IntelImage
  • IntelSurface() : IntelSurface
  • InternalChangeOrientation() : SimpleImage, IntelImage, Image, GDIImage
  • InternalCopy() : Image
  • InternalCreate() : SimpleImage, IntelImage, Image, GDIImage
  • Intersect() : BBox3, BBox2
  • Intersects() : BBox3, BBox2
  • Inverse() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • IsCurrent() : GLRC
  • IsDir() : PathString
  • IsDot() : BBox3, BBox2
  • IsFile() : PathString
  • IsSet() : Ref

- l -

  • Length() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • LessOrEqual() : TVector4, TVector3, TVector2
  • ListFileName() : PathString
  • LoadImage() : DIntelImage
  • Lock() : Image

- m -

  • MakeCurrent() : GLRC
  • MakeFullPath() : PathString
  • MakeIdentity() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MaxValue() : TVector4, TVector3
  • MkDir() : PathString
  • MultDirMatrix() : TMatrix4x4, TMatrix3x3
  • MultLeft() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MultMatrixDir() : TMatrix4x4, TMatrix3x3
  • MultMatrixVec() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MultRight() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • MultVec() : TVector4, TVector3, TVector2
  • MultVecMatrix() : TMatrix4x4, TMatrix3x3, TMatrix2x2

- n -

  • Negate() : TVector4, TVector3, TVector2
  • Normalize() : TVector4, TVector3, TVector2
  • Normalized() : TVector4, TVector3, TVector2
  • NormalRight() : TVector2
  • NotEmpty() : BBox3, BBox2

- o -

  • Open() : File
  • Opened() : File
  • operator *() : TVector4, TVector3, TVector2, TColor4, TColor3, TVector4, TVector3, TVector2, TMatrix4x4, TMatrix3x3, TMatrix2x2, Ref
  • operator *=() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator const T *() : TVector4, TVector3, TVector2, TColor4, TColor3
  • operator T *() : TVector4, TVector3, TVector2, TColor4, TColor3, Ref
  • operator!() : TVector4, TVector3, TVector2
  • operator()() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator+=() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator-() : TVector4, TVector3
  • operator->() : Ref
  • operator=() : DIntelImage, SimpleImage, IntelImage, Image, GDIImage, Ref
  • operator==() : TMatrix4x4, TMatrix3x3, TMatrix2x2, Image
  • operator^() : TVector3, TVector2
  • operator~() : TVector4, TVector3, TVector2

- p -

  • PaintImage() : GDIImage
  • PaintImageRect() : GDIImage
  • Path() : PathString
  • PathString() : PathString

- r -

  • RawArray() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ReadFile() : CIniFile
  • Ref() : Ref
  • Release() : SmartObject
  • Reset() : FrameCounter, CIniFile
  • RmDir() : PathString

- s -

  • SaveImage() : DIntelImage
  • Set() : Ref
  • SetColumn() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • SetDistanceToTarget() : Camera
  • SetMinimumFrameCount() : FrameCounter
  • SetPath() : CIniFile
  • SetRect() : BBox2
  • SetRotation() : TMatrix4x4, TMatrix3x3
  • SetRow() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • SetScale() : TMatrix4x4, TMatrix3x3
  • SetTransform() : Camera
  • SetTranslation() : TMatrix4x4, TMatrix3x3
  • SetUpdateSpeed() : FrameCounter
  • SetValue() : TVector4, TVector3, TVector2, TMatrix4x4, TMatrix3x3, TMatrix2x2, CIniFile
  • SetValueF() : CIniFile
  • SetValueI() : CIniFile
  • SetViewAngle() : Camera
  • SignAbout() : Math
  • SimpleImage() : SimpleImage
  • Sin() : TVector3, TVector2
  • Split() : PathString
  • SqrLength() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • step() : DIntelImage
  • String() : String
  • SwapBuffers() : GLRC

- t -

  • TColor3() : TColor3
  • TColor4() : TColor4
  • TMatrix2x2() : TMatrix2x2
  • TMatrix3x3() : TMatrix3x3
  • TMatrix4x4() : TMatrix4x4
  • Translate() : BBox3, BBox2
  • Translated() : BBox3, BBox2
  • Transpose() : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • TVector2() : TVector2
  • TVector3() : TVector3
  • TVector4() : TVector4

- u -

  • Unlock() : Image
  • Updated() : FrameCounter

- v -

  • Volume() : BBox3, BBox2

- w -

  • Width() : BBox2
  • width() : DIntelImage
  • WriteFile() : CIniFile

- ~ -

  • ~CIniFile() : CIniFile
  • ~DIntelImage() : DIntelImage
  • ~DrawSurface() : DrawSurface
  • ~File() : File
  • ~FrameCounter() : FrameCounter
  • ~GDIImage() : GDIImage
  • ~GDISurface() : GDISurface
  • ~GLRC() : GLRC
  • ~Image() : Image
  • ~IntelImage() : IntelImage
  • ~IntelSurface() : IntelSurface
  • ~Ref() : Ref
  • ~SimpleImage() : SimpleImage
  • ~SmartObject() : SmartObject
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Compound Member Index

  • Conv() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvD() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvF() : TVector4, TVector3, TVector2, TQuaternion, TMatrix4x4, TMatrix3x3, TMatrix2x2
  • ConvI() : TVector4, TVector3, TVector2
  • ConvRef() : Ref
  • ConvS() : TVector4, TVector3, TVector2
  • Cos() : TVector3, TVector2
  • CrossProd() : TVector2
  • CrossProduct() : TVector3, TVector2, TVector3, TVector2
  • DotProd() : TVector2
  • DotProduct() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • Length() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
  • operator * : TVector4, TVector3, TVector2, TColor4, TColor3, TVector4, TVector3, TVector2, TMatrix4x4, TMatrix3x3, TMatrix2x2, Ref
  • operator!= : TMatrix4x4, TMatrix3x3, TMatrix2x2
  • operator== : TMatrix4x4, TMatrix3x3, TMatrix2x2, Image
  • Sin() : TVector3, TVector2
  • SqrLength() : TVector4, TVector3, TVector2, TVector4, TVector3, TVector2
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Compound Member Index

  • center : BSphere3
  • EPSILON : Math
  • error : CIniFile
  • m_BMInfo : GDIImage
  • m_created : GLRC
  • m_dc : GLRC
  • m_glrc : GLRC
  • m_hBMP : GDIImage
  • m_hDC : GDIImage
  • m_hOldHandle : GDIImage
  • m_iBytesPerLine : GDIImage
  • m_inv_view_transform : Camera
  • m_line_array : Image
  • m_lock_count : Image
  • m_orient : Image
  • m_pBits : SimpleImage, GDIImage
  • m_pImage : DIntelImage, IntelImage
  • m_pPalette : GDIImage
  • m_target_distance : Camera
  • m_view_angle : Camera
  • m_view_transform : Camera
  • m_wnd : GLRC
  • MAX_VALUE : Math
  • MIN_VALUE : Math
  • PATH_SEPARATOR : PathString
  • PATH_SEPARATOR_STR : PathString
  • radius : BSphere3
  • TOLERANCE : Math
  • vmax : BBox3, BBox2
  • vmin : BBox3, BBox2
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: File Member Index

  • ASSERT : gmlcommon.h
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Images

Images

Modules

ImageFilters

Classes

class | GDIImage
Manipulates uncompressed device- and platform-independent bitmaps. More...

class | GDISurface
Generic image class. More...

class | Image
Generic image class. More...

class | ImageLoader
Loading and saving bitmaps to files (base class). More...

class | IntelImage
Manipulates uncompressed device- and platform-independent bitmaps. More...

class | IntelSurface
Generic image class. More...

class | SimpleImage
Manipulates uncompressed device- and platform-independent bitmaps. More...

class | FRImageLoader
Image loader based on FreeImage third-party library. More...

class | DIntelImage
Intel libraries IplImage wrap class. More...

class | SimpleImageLoader
Image loader based on FreeImage third-party library. More...

Functions

gml::GDIImage::GDIImage (const GDIImage &Orig)
Copy constructor.

gml::GDIImage::GDIImage (const Image &Orig)
Copy constructor.

GDIImage & | gml::GDIImage::operator= (const Image &Orig)
Assignment operator.

GDIImage & | operator= (const GDIImage &Orig)
Image & | gml::Image::operator= (Image const &Orig)
int | GetWidth () const
int | GetHeight () const
FORMAT | GetFormat () const
REPRES | GetRepres () const
ORIENT | GetOrient () const
int | GetElemSize () const
BYTE ** | gml::Image::GetLineArray () const
Returns pointer to an array containing the starting addresses of the bitmap lines.

bool | IsLocked () const
gml::IntelImage::IntelImage (const IntelImage &Orig)
Copy constructor.

gml::IntelImage::IntelImage (const Image &Orig)
Copy constructor.

IntelImage & | gml::IntelImage::operator= (const Image &Orig)
Assignment operator.

IntelImage & | operator= (const IntelImage &Orig)
gml::SimpleImage::SimpleImage (const SimpleImage &Orig)
Copy constructor.

gml::SimpleImage::SimpleImage (const Image &Orig)
Copy constructor.

SimpleImage & | gml::SimpleImage::operator= (const Image &Orig)
Assignment operator.

SimpleImage & | operator= (const SimpleImage &Orig)

Variables

const | PRESERVE_JPEG_EXIF = 1

Function Documentation

Image & operator= ( Image const & Orig ) [inline, inherited]

Assignment operator. Note that assignment between different derived classes is possible and results in a format conversion.

Reimplemented in GDIImage, IntelImage, and SimpleImage.

BYTE ** GetLineArray ( ) const [inline, inherited]

Returns pointer to an array containing the starting addresses of the bitmap lines.

This array should be used whenever the bitmap bits need to be manipulated directly.

Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Math

Math

Modules

Math2x2
Math3x3
Math4x4
Math2
Math3
Math4

Classes

class | Math
A template class for precision related staff. More...

class | TQuaternion
quaternion template More...

Defines

#define | PI 3.1415926535897

Typedefs

typedef Math< float > | MathF
typedef Math< double > | MathD
typedef TQuaternion< float > | Quaternionf
typedef TQuaternion< double > | Quaterniond

Functions

double | ToDegrees (double radians)
double | ToRadians (double degrees)
template<class T> void | gml::Clip (T &v, const double a_min, const double a_max)
Clip a value of given variable by given range for different types T.

template<class T> T | gml::Clipped (const T v, const double a_min, const double a_max)
Clip a value of given variable by given range for different types T.

template<class T> T | gml::Min (const T u, const T v)
Find minimal value for different type T.

template<class T> T | gml::Min3 (const T u, const T v, const T w)
Find minimal value for different type T within three vars.

template<class T> T | gml::Max (const T u, const T v)
Find maximal value for different type T.

template<class T> T | gml::Max3 (const T u, const T v, const T w)
Find maximal value for different type T within three vars.

template<class T> bool | operator== (const TQuaternion< T > &q1, const TQuaternion< T > &q2)
template<class T> bool | operator!= (const TQuaternion< T > &q1, const TQuaternion< T > &q2)
template<class T> TQuaternion< T > | operator * (const TQuaternion< T > &q1, const TQuaternion< T > &q2)
TQuaternion< T_TO > | gml::TQuaternion::Conv (const TQuaternion< T_FROM > &u)
Convert TQuaternion<T_FROM> to TQuaternion<T_TO>.

TQuaternion< float > | gml::TQuaternion::ConvF (const TQuaternion< T > &u)
Convert TQuaternion<T> to TQuaternion<float>.

TQuaternion< double > | gml::TQuaternion::ConvD (const TQuaternion< T > &u)
Convert TQuaternion<T> to TQuaternion<double>.

Variables

const double | RAD_TO_DEG = 57.2957795130823208767981548141052
const double | DEG_TO_RAD = 0.0174532925199432957692369076848861
const int | QUATERNION_NORMALIZATION_THRESHOLD = 64
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Hierarchical Index

Graphics and Media Lab CSL Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • BBox2
  • BBox3
  • Browser
  • BSphere3
  • Callback
    • gml::FunctionCallback
    • gml::MethodCallback
  • Callback1
  • Callback2
  • Callback3
  • CallbackR
  • CallbackR1
  • CallbackR2
  • CallbackR3
  • Camera
  • CIniFile
  • DIntelImage
  • File
  • FileFinder
  • FrameCounter
  • FunctionCallback1
  • FunctionCallback2
  • FunctionCallback3
  • FunctionCallbackR
  • FunctionCallbackR1
  • FunctionCallbackR2
  • FunctionCallbackR3
  • GLRC
  • ImageComposer
  • ImageDecomposer
  • ImageFilter
    • FilterGrayscale
    • FilterLum2RGB
    • FilterMedianBlur
    • FilterRepres
    • FilterResize
    • FilterRGB2BGR
    • FilterRGB2RGBA
    • ReflectFilter
    • SetRectFilter
  • ImageLoader
    • FRImageLoader
    • SimpleImageLoader
  • LoaderColor
  • Math
    • Math2
    • Math3
    • Math4
  • MethodCallback1
  • MethodCallback2
  • MethodCallback3
  • MethodCallbackR
  • MethodCallbackR1
  • MethodCallbackR2
  • MethodCallbackR3
  • ModeBrowser
  • Ref
  • RGBQUAD
  • SmartObject
    • DrawSurface
      • GDISurface
      • IntelSurface
    • Image
      • GDIImage
      • IntelImage
      • SimpleImage
    • gml::Mesh
    • MyObject
    • MySecondObject
  • Socket
  • String
    • PathString
  • tagBITMAPFILEHEADER
  • tagBITMAPINFOHEADER
  • TColor3
  • TColor4
  • TMatrix2x2
  • TMatrix3x3
  • TMatrix4x4
  • TQuaternion
  • TrackballBrowser
  • TVector2
  • TVector3
  • TVector4
  • Viewport
  • WalkBrowser
Generated on Tue Jan 13 21:12:02 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Module Index

Graphics and Media Lab CSL Modules

Here is a list of all modules:
  • DScene
  • Base
  • Color
  • Files
  • Images
    • ImageFilters
  • Math
    • Math2x2
    • Math3x3
    • Math4x4
    • Math2
    • Math3
    • Math4
  • Net
  • Utils3D
  • UtilsGL
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4


Graphics and Media Lab CSL: Page Index

Graphics and Media Lab CSL Related Pages

Here is a list of all related documentation pages:
  • Todo List
  • Deprecated List
Generated on Tue Jan 13 21:12:08 2004 for Graphics and Media Lab CSL by doxygen 1.3.4